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Nuance Communications, Inc. RealSpeak™ License

1. License Grant. Mayer-Johnson LLC. grants to End User a non-exclusive, non-transferable right and license to use RealSpeak on a 
single copy of Speaking Dynamically Pro.

2. Ownership of RealSpeak. End User acknowledges that Mayer-Johnson LLC and its licensors and/or suppliers retain all right, title and 
interest in and to the original, and any copies, of software which is incorporated into Speaking Dynamically Pro. Without limiting the 
generality of the foregoing, End User agrees not to: (i) modify, port, translate, or create derivative works of the Speaking Dynamically Pro; 
(ii) decompile, disassemble, reverse engineer or attempt to reconstruct, identify or discover any source code, underlying user interface 
techniques or algorithms of the Speaking Dynamically Pro by an means whatsoever, or disclose any of the foregoing; (iii) knowingly take 
any action that would cause Speaking Dynamically Pro to be placed in the public domain.

3. LIMITATION OF LIABILITY. MAYER-JOHNSON LLC AND ITS LICENSORS’ LIABILITY TO END USER FOR ANY CLAIM ARISING 
UNDER THIS AGREEMENT OR OTHERWISE ARISING FROM THE TRANSACTIONS CONTEMPLATED HEREIN, REGARDLESS OF 
THE FORM OF ACTION WILL NOT EXCEED AGGREGATE FEES ACTUALLY PAID TO MAYER-JOHNSON LLC DURING THE ONE 
YEAR PERIOD PRECEDING SUCH CLAIM.

4. CONSEQUENTIAL DAMAGE. IN NO EVENT SHALL MAYER-JOHNSON LLC OR ITS LICENSORS OR SUPPLIERS BE LIABLE FOR 
ANY SPECIAL, INDIRECT OR CONSQUENTIAL DAMAGES, INCLUDING, BUT NOT LIMITED TO, LOSS OF REVENUES AND LOSS 
OF PROFITS, EVEN IF MAYER-JOHNSON LLC HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.
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Boardmaker Software Family v6 User’s Guide
Introduction
Printed User’s Guide

This user's guide was written to support version 6 of the complete Boardmaker Software Family (BSF) of 
products: Boardmaker (BM), Boardmaker Plus! (BM Plus) and Boardmaker with Speaking Dynamically Pro 
(BM with SDP). 

This manual is divided into two parts. The first part focuses on the features provided within Boardmaker and 
the use of these features. All the information in this part of the manual applies to all the BSF products. The 
second part focuses on the interactive features of BM Plus and BM with SDP and their use. This part of the 
manual does not apply to Boardmaker. To help you identify the chapters that apply to the BSF product you 
purchased, product icons (shown above) will appear at the beginning of each chapter and in specific sections 
within a chapter as necessary.

In Program Help

Note: The in- program help will be updated as necessary via free downloadable program updates available 
at the Mayer-Johnson website (www.mayer-johnson.com) or via the on-line updater (Start menu > 
All Programs > Mayer-Johnson > Check for Updates).

Boardmaker is the premiere software among clinicians, SLPs, and educators for 
creating printed symbol-based communication and educational materials. 
Boardmaker is a drawing program combined with a graphics database featuring 
more than 4,500 Picture Communication Symbols (PCS). Boardmaker is the 
backbone of the BSF because its complete set of features is part of both BM Plus 
and BM with SDP.

Boardmaker Plus! allows you to bring the static BM activities to life and make your 
computer an interactive student-learning and speaking tool. Featuring the ability to 
talk, play recordings, move between boards and interact with buttons on the screen, 
BM Plus allows you to create interactive books, worksheets, schedules, basic 
communication, learning games and more, all of which can be adapted to each 
student’s needs.

Boardmaker with Speaking Dynamically Pro is for power users and high-level AAC 
needs. With the addition of word prediction, abbreviation expansion and the high 
quality RealSpeak® voices, plus all the capabilities of BM Plus, BM with SDP will 
turn your computer into a speech output device and a powerful learning tool.
1



Introduction
System Requirements

The system requirements to run version 6 in Windows are:

• Windows 2000 or higher • 512 Mb RAM • 400 Mb free disk space

Where to Get Additional Support

If you have access to the Internet, you can get support online at:

http://www.mayer-johnson.com
e-mail: support@mayer-johnson.com

Answers to frequently-asked questions will appear under the Support link at the top of the Mayer-Johnson 
home page. If you don’t find the answer to your question there, you may send an e-mail with your technical 
support question to our office for a prompt response.

If you don’t have Internet access, you may call our office for assistance:

Mayer-Johnson 
Phone: (800) 588-4548 or (858) 550-0084

Hours: 8:00 - 4:00 Pacific Time
Fax: (858) 550-0449

To assist us in quickly answering your questions, please be ready to provide computer and system 
information, as well as the application version number (on startup screen). It is extremely helpful if you can 
call when you are in front of the computer.
2
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Program Window at a Glance
 

Zoom Out

1

2

3 4 5 6 7 8 9 10 11 12 13 14 15 16

19

20

1

2

4

3

5

6

7

8

9

10

Symbol Finder Tool (Ctrl + F)
Makes the Symbol Finder window visible

Button Sprayer Tool (Ctrl + F2)
Sprays out button copies to make a grid

Line Tool (Ctrl + F4)
Draws lines

Color Tool
Displays a color palette to set the color of 
buttons, text, graphics, and backgrounds

Corner Tool
Displays a palette of button corner options

Pointer Tool (Ctrl + F1)
Selects buttons, text, graphics, etc

Button Tool (Ctrl + F3)
Creates buttons for symbols and pictures

11

13

12

14

15

16

17

18

Shadow Tool
Toggles 3-D button shadows

Dynamic Help
Displays helpful information relative to the
pointer position and action being performed

Thickness Tool
Displays a palette of line thickness options

Movable Button Tool
Create Movable\Destination button pairings

17

21 22

18

Symbolate Tool
Creates a button in which symbols will 
appear as text is typed

Freeform Button Tool(Ctrl + F7)
Create freeform or polygon buttons

Text Tool (Ctrl + F5)
Insert and edit text

19

20

21

22

Zoom In

Board Workspace

Symbol Finder Window
Searches for symbols

Board Magnification Indicator
Displays the current view magnification

Page Break Indicator
Displays where printed page breaks will occur

Title Bar

Menu Bar
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Symbol Finder at a Glance

1

3

4

5

6

7

8

11

Current Symbol1

2

Minimize, Maximize & Close Buttons4

3

5

6

7

8

Display Thumbnail View (Ctrl + T))
Display thumbnails of matching symbols

Symbol FinderSettings Button
Changes various Symbol Finder settings

Symbol Names Button
Adds an alternate name or category to a symbol

9

10

11

13

14

Alternate Symbol Name Field
Replaces a symbol name with a new name

Previous/Next Symbol Arrows
Steps through the symbols or thumbnail screens

Current Symbol Number
Displays the current and total matching symbols

Search Text Field
Finds a symbol from a full or partial name

Selection Marquee
Selects a rectangular region to copy

12

Alternate Symbol Names List
Displays a list of alternate names to select

Note: Pop-up descriptions of each button appear
when you position the pointer on them and 

2

9

10

12 13 14

Symbol Name Search Options
Begin Word, Anywhere, Whole Word

Select Categories Button (Ctrl + L)
Selects the symbol categories to search

Selection Lasso
Selects a freeform region to copy

pause briefly.
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Exploring the Templates and Sample Boards

Templates for Printing 

All of the Boardmaker Software Family products come with over 325 print templates. Templates for 
calendars and schedules and most communication devices are provided in the Templates folder. 

The templates can be accessed by clicking on the Open a Template button on the open options screen that 
appears when you first launch the program or when you choose File > Open (Ctrl + O).

Note: The templates are “read only” files and will open as “untitled” boards. This prevents the template 
from accidentally being overwritten.

Interactive Templates (not included with Boardmaker)

Boardmaker Plus! and Boardmaker with Speaking Dynamically Pro come with over 600 sample boards, 
designed to demonstrate how the features and symbols can be applied to cover a range of curricular areas, 
provide communication and language support, assist in the development of functional living skills, and 
more.  The activities are designed to provide a range of applications that target ability levels that vary from 
early childhood through adulthood. Please take some time to explore the sample boards to help you gain an 
understanding of the features presented throughout this reference manual.

Boardmaker Plus! and Boardmaker with Speaking Dynamically Pro both have a Use mode and a Design 
mode. The Use mode will allow you to interact with your boards. The Design mode is for creating and 
editing boards, buttons and actions. The program can be put in the Use mode by pressing Ctrl + U, and then 
return to the Design mode by pressing Esc or Ctrl + D.

Navigate to the 
desired template.

Click here to access 
all template boards.

Open Options screen
5
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1

Starting the Program in the Use Mode on the 
Main Sample Board 

Double-click the BSF Interactive Sample 
Boards icon on your desktop. This will launch 
the program, open the main board for the 
interactive samples, and place the program in the 
Use mode.

You may now proceed to the next section, or 
review the alternate steps below.

---------------------------------------------------------------------- OR -----------------------------------------------------------

Opening the Main Sample Board from within 
the Program

Launch the program by double-clicking on the 
appropriate icon on your desktop or select the 
program within the Start menu (Start > All 
Programs > Mayer-Johnson).

 

2

Click the Open a Template button.

3

The Select a Board dialog will display the 
contents of the Templates folder.

Double-click the Interactive Sample Boards 
folder.

Note: You will find the templates for printing in 
the folders that start with “BM,” although 
you can print any of the interactive 
boards in the “BM Plus” folders as well.

Not included with 
Boardmaker
6
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4

Double-click the _Main board.bm2 to open it. 
This board gives you access to over 600 sample 
boards.

5

You will need to put the program in the Use mode to explore the sample boards.

Choose Dynamic Boards > Use or press Ctrl + U. Click the buttons to explore different sample 
boards. The “Main” button in the bottom left corner of each board will bring you back to the main 
board.

Press the Esc key or press Ctrl + D to return to the Design mode.

You must put the program in 
the Use mode to use the 
interactive sample boards.
7
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Working with AdaptedLearning.com

The AdaptedLearning website is a powerful resource from Mayer-Johnson that allows users of the 
Boardmaker Software Family (BSF) of products to share adapted learning materials with other users. 
AdaptedLearning.com offers a variety of content and implementation resources, provided through 
downloadable files, news, and information. Membership is free. 

To get started, in the Help menu, select Visit the AdaptedLearning Sharing Site, and follow the onscreen 
instructions to register. Once you have registered, you can search for boards in any topic area, upload the 
boards you have created and access them from any computer with an Internet connection, share your boards 
with other users, and start or join a group of colleagues with whom you can share resources. Adapted 
Learning also offers advice, tips, and training.

Following are brief instructions for searching for files, downloading files, and uploading your files to 
AdaptedLearning. Refer to the Support area of the AdaptedLearning website, which offers detailed help and 
step-by-step instructions to access all of the features available on the website.

Searching for Files on AdaptedLearning

A Find what you need search box is available on most of the pages of the AdaptedLearning website. You 
can perform a simple or advanced search of all of the BSF files available to share on the website.

After you find a file on Adapted Learning, you cannot use that file in your BSF program until you download 
it to your computer. You can either immediately download the file to your computer, or you can copy it to 
your My Files page and download it later. 

1

In the Find what you need search box, type in a 
keyword, or keywords, to help identify the type 
of file for which you are searching.

NOTE: If you want to further define your search, 
use the drop-down lists in the search box 
to select a category and grade level for 
your search.

 

8
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2

When you have selected all of your search 
options, click Search. The files that meet your 
search criteria will be listed in a new Search 
Results pane.

To find detailed information on any file listed in 
the Search Results pane, click on the file’s title to 
highlight it, then click Open File in the command 
bar at the top of the Search Results pane.

3

If you decide you want to save a copy of the file 
to your My Files page on AdaptedLearning, click 
the Copy to My Files button.

NOTE:You will only be able to use interactive 
files if you are using Boardmaker Plus or 
Boardmaker with Speaking Dynamically 
Pro. If you are using Boardmaker, you 
may want to select only “Print” files to 
save and download.

If you decide you want to download the file 
immediately, click on Download the File. The 
Save As dialog will open. Navigate to the folder 
on your computer where you want to save the file 
and click Save.

Click on the title to 
get file information.

Click here to 
download the 
file.

Click here to 
copy the file to 
your My Files 
page.
9
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Uploading your Files to AdaptedLearning

The files you upload to the AdaptedLearning website will be available on your My Files page for you to 
access from any computer with an Internet connection, and, if you wish, you can share your files with other 
members of AdaptedLearning.

1

Click the Share what you have button at the top 
of any page on the AdaptedLearning website. The 
Upload File screen will open.

Click the Upload button. The Upload File screen 
will open.

 

2

Click the Upload button on the Upload File 
screen. 

Click the Browse button on the Upload File 
dialog that appears and select the file you want to 
upload.

NOTE:Refer to the Support area of the 
AdaptedLearning website for instructions 
for creating .zip and .zbp files.

Click Upload. When the file has uploaded, you 
will be returned to the Upload File screen. 

Click here to 
upload files. The 
Upload File 
screen will open.
10
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3

Type in the title and a short description of the file 
in the Basic Information area of the Upload File 
screen. Choose the appropriate grade levels. 

Check the applicable boxes in the Categorization 
area, and type in keywords to describe the file to 
other users.

Finally, designate to whom you want the file to be 
available. Use the drop-down list to choose 
whether the file will be available to all users, to a 
group, or only to yourself.
11



 Introduction
Basic Mouse Skills

As with any modern software program, it is important to be familiar with basic mouse skills. This is 
especially important with a drawing program like Boardmaker. Here is a quick review of the basic mouse 
skills that are used repeatedly throughout this user's guide.

Click

Press the left mouse button to select buttons, text, 
graphics, and lines within the program. This is typically 
done with the Pointer Tool.

Right-click

Press the right mouse button to access contextual menus 
and perform special functions. This is typically done with 
the Pointer Tool. 

Right-clicking on most items will provide access to 
contextual (right-click) menus containing commands that 
are specific to the item or items that are selected. The 
contextual menus provide a quick way to perform common 
tasks like copying, pasting, aligning, setting properties, 
and much more. 

Note: Some advanced program commands are only 
available in the contextual menus.

Double-click 

Click twice, quickly, with the left mouse button to open 
buttons and displays so that actions can be assigned or 
settings changed. This is typically done with the Pointer 
Tool. (BM Plus and BM with SDP only)

Click to select items like symbols.

Right-click to access the contextual 
menu for items.

Double-click on a button to assign it 
actions (BM Plus & BM with SDP only.)
12
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Click and Drag 

Click and hold the left mouse button down while moving 
the mouse in the appropriate direction. Click and drag is 
used with a variety of tools to select, draw and move 
objects or items.

Shift-click 

Click on the first item, hold the Shift key down, and then 
click on the next item or items. You can use Shift-click to 
select multiple items or buttons. Each item you Shift-click 
will be added to the selection group. Shift-click an item 
that is part of a selection group to de-select it. 

Note: You can not select buttons and items at the same 
time. They are mutually exclusive.

Click and drag to draw a button or 
move items around.

Shift-click on items to add them to the 
selection group.
13
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Chapter 1 
Building a Board and Working with Its 
Appearance

Chapter Overview 

When creating a new communication board, it is important to understand how to properly orient and size a 
board for printing, create a grid of buttons, and manage boards within the drawing window. You will also 
learn how to change the color, shape, and size of the buttons on a board which helps to organize its content 
and makes it easier for the user to understand.

The following topics will be covered:

• Setting the Correct Paper and Board Size

• Working with Multiple Boards

• Creating a Grid of Buttons

• Changing the Board or Button Background Color

• Changing the Appearance of the Buttons

• Drawing a Freeform Button

• Creating Multi-Page Boards

• Resizing a Board’s Window

• Adjusting the Button Gap Spacing

• Applying Dashed Button Borders

• Drawing a Line

• Drawing a Polygonal Freeform Button

Create boards 
that will print to 
match an exact 
size need. 

Use different sizes of 
buttons and symbols.

Organize the board using 
colored button borders.

Select from a variety 
of button corners.

Organize the board using colored 
button backgrounds.
17
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Setting the Correct Paper and Board Size

1

The first step in creating a new board is to determine its size. You will need to tell the program how big 
of a workspace you will need and what size paper you will be using in your printer.

Printer Setup

The printer settings for paper size and orientation should be set for a board before you enter the 
dimensions for a board size. This will help you create boards that print on a single piece of paper.

Choose File > Print Setup (Board Size/Ruler/Grid/Gaps). Check the current printer settings for the 
proper paper size and orientation. If the paper size or orientation is not correct, click the Print Setup 
button.

Current printer page 
size and orientation 
information.

Click here to 
change the paper 
size or orientation.
18



Boardmaker Software Family v6 User’s Guide
2

Make sure the paper size you will be using is selected, then set the print orientation for your board. 
Click OK when finished.

Choose the 
size of paper 
that you will be 
using.

Select the print 
orientation for 
your board.

Make sure the 
correct printer 
is chosen.
19
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3

Setting the Board Size

Typically, you will click the Use Printer Page button to make the board size match the printable 
area for the paper size and orientation you previously set. (In the next section you will learn to work 
with multi-page boards.) Click OK when finished.

Note: The printable area for a specific paper size and orientation can vary from one printer to the 
next. You may need to adjust the board size if you try printing this board on a different 
printer.

Tip: Setting a Default Board Size and Printer Page Setting for All New Boards 
If you will be making a lot of boards that need to be the same size, i.e., a set of boards for a 
specific device or activity, you will want to use the “Remember” buttons on the right side of 
the Print Setup screen above. You may click on one or both of these buttons to automatically 
apply the current board size and/or printer page orientation settings to any new board you 
create.

Click here to use 
the current board 
size setting on all 
new boards.

Click here to use 
the current printer 
page orientation 
on all new boards.

Use Display 
Size
Click here to set 
the board size 
to match the 
display size for 
on-screen use.

Use Printer 
Page

Click here to 
set the board 
size to match 
the printer page 
size.

Current Board Size

To set a specific board 
size, specify the values 
here.
20
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Creating Multi-Page Boards

You have the option to create boards that can span multiple sheets of paper. Creating multi-page boards 
allows you to support larger communication devices or make poster-sized communication boards.

1
Choose File > Print Setup (Board Size/Ruler/Grip/Gaps). Check the current printer settings for 
the proper paper size and orientation. If not correct, click the Print Setup button.

In the Width and Height boxes shown above, enter the desired dimensions for the board up to the 
values listed under Maximum. Click OK when finished.

Enter the 
desired 
board size.
21
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2

When the board is viewed as Fit to Window (default), the page break lines will mark the different 
sheets of paper.

Most printers have a minimum necessary margin and cannot print right up to the edge of the paper. 
Therefore, when a multi-page board is assembled, you will need to trim the edges of each page 
before taping them together.

The different 
pieces of paper 
are marked by 
green dashed 
page break lines.
22
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Working with Multiple Boards

View Options

The first board opened or created in the program is 
maximized and will fill the screen as shown.

You can have multiple boards open at once. As 
additional boards are opened, they will appear in 
smaller windows cascaded on the screen.

Selecting View > Tile will allow you to view all currently open boards at the same time. The Tile view is 
useful for copying and pasting buttons between boards.
23
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Resizing a Board’s Window

By default, a board’s window is set to the Fit To 
Window view so the entire board can be seen.

Different view sizes are available in the View menu 
and are useful especially when editing a symbol.

Note: The button sizes as viewed on screen do not 
necessarily match the printed size. Refer to 
the rulers in the window to determine the 
actual print sizes.

Manually

By moving the pointer over any edge of the window, 
the pointer will become a double arrow. Click and 
drag the edge of the window to a new position.

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - OR - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Using the Maximize and Restore Buttons

Click the Maximize button in the upper right corner 
of a board’s window to expand it to fill the 
workspace as shown above.

Click the Restore button in the upper right corner of 
a maximized board’s window to restore it to its 
reduced size as shown above.

Drag to resize 
a window.

The board is shown 
maximized.

The board is shown 
restored to its 
smaller size.
24
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Creating a Grid of Buttons

1

First, you must create the initial button for your 
grid.

Select the Button Tool in the Standard toolbar.

Tip: Change the orientation of the Standard 
toolbar by dragging the bar next to the 
Symbol Finder Tool to either the top or 
left side of the screen.

2

Move the crosshair into the blank workspace.

Tip: Noting the initial position of the red 
indicators in the rulers will help you 
create a button of a specific size.

Note: The rulers can be set to display inches 
or centimeters. The units of measure 
can be set by choosing File > Print 
Setup (Board Size/Ruler/Grid/Gaps).

3

Click and drag diagonally to create a button. 
Release the mouse button when the new button 
is the correct size.

Tip: To create a square button, hold down 
the Shift key while dragging out the 
button.

Note: The cursor moves in 1/8 inch (0.3 cm) 
increments on an invisible grid. You 
can change the grid spacing by 
selecting File > Print Setup (Board 
Size/Ruler/Grid/Gaps) or unchecking 
the View > Snap to Grid.

Standard Tool Palette
(Vertical and horizontal 
orientations)

Red position 
indicators

crosshair
25
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4

If it is necessary to resize the button, move the 
pointer over any edge or corner of the selected 
button until the double arrow appears as shown. 
Click and drag the edge or corner to change the 
button’s size as necessary.

Note: A dashed line indicates that a button is 
selected.

5
You are now going to spray out copies of the 
button you have created to form a grid.

Select the Button Sprayer Tool.

6

Position the Button Sprayer Tool on top of the 
button. Click and drag diagonally to spray out 
the desired grid of buttons.

Note: If you want to change the gap spacing 
between the buttons, delete all buttons 
except for the initial button, change the 
gap spacing for the Button Sprayer 
Tool and drag out a new grid. For more 
information, refer to “Adjusting the 
Button Gap Spacing” on page 27.

Use the double 
arrow to change 
a button’s size.
26
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Adjusting the Button Gap Spacing

The Button Sprayer Tool is used to create a grid of buttons. By default, the horizontal and vertical gaps 
between buttons are set to 1/8 inch (0.125). This spacing can be adjusted as needed.

Choose File > Print Setup (Board Size/Ruler/Grid/Gaps).

Enter the desired gap spacing and click OK.

Note: You must make your changes to the gap spacing before using the Button Sprayer Tool.

7

While all the buttons are still selected*, click 
and drag any button to reposition the whole grid 
in the center of the page.

*If the buttons become deselected, choose 
Edit > Select All (Ctrl + A).

Tip: If you create a board layout you would 
like to use as a template for future 
boards, please refer to Appendix E - 
Creating a Template Board.

Gaps for Sprayed Buttons

Enter the desired gap 
spacing here.
27
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Changing the Board or Button Background Color

Changing the Button Border Thickness

Click on the board’s background 
or select a button or group of 
buttons.

Select the Color Tool. Click on the desired color in the 
Color Palette.

Select a button or group of 
buttons.

Select the Thickness Tool. Click the desired button border 
thickness.
28
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Invisible Button Borders

The dashed line in the Thickness Tool represents an “invisible” border. When selected, the buttons will 
appear with a light-gray dot-dash border that will not print.

Note: Do not confuse the dashed line in the Thickness Tool with dashed button borders which are set by 
right-clicking on a button and selecting Properties > Dashed Border. (Refer to the Applying Dashed 
Button Borders section.)

Changing the Button Border Color

Select a button or group of 
buttons.

Select the Color Tool. Click on Border, then select the 
desired button border color.

Tip: Use the eye dropper to select a color that does not appear in the palette by clicking on any color 
shown on the board.

Solid border Invisible border
(Will not print.)

Dashed borderSelecting the 
invisible border.

Click Border to change the 
button border color.
29
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Changing the Button Shape 

Drawing a Line 

Select a button or group of buttons. Select the Corner Tool. Select the desired button border corner.

Note: If a freeform button is selected, the Corner Tool will act as a “polygon tool.” Refer to the Creating 
a Regular Polygon from a Freeform Button section.

Select the Line Tool. Click and drag on a button or on 
the board background to draw a 
line.

Click the Thickness Tool, and 
make a selection to change the 
line’s thickness.
30



Boardmaker Software Family v6 User’s Guide
Applying Dashed Button Borders

Note: Dashes can also be applied to lines created with the Line Tool.

Tip: Dashed borders look better with thicker button borders (Thickness Tool).

Applying 3-D Button Shadows

Note: The Thickness Tool, Corner Tool, and Color Tool can be used to change the look of the button 
shadows.

Select a button or group of 
buttons.

Right-click a button and select 
Dashed Borders in the 
Properties submenu. Uncheck 
this option to return to solid 
border lines.

The dashed borders are great for 
cutting activities and worksheets.

Select a button or group of 
buttons.

Select the Shadow Tool. Select the shadowed box to create 
the 3-D button shadows.
31
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Clearing a Group of Buttons

Drawing a Freeform Button

The Freeform Button Tool allows you to draw buttons that have any shape. You can use this tool to create 
“hotspots” around parts of a background picture, emphasize certain buttons by giving them a very different 
look from the others, or simply create fun new shapes.

Note: A freeform button behaves exactly like a standard button with two exceptions; it cannot have 
shadowed borders and its corners cannot be rounded.

Select a button or group of 
buttons.

Choose Edit > Clear or right- 
click on one of the buttons and 
select Clear Buttons > Face.

The symbols and text are 
removed from the buttons.

Create uniquely shaped buttons 
over an item in a photo and 
make them invisible.

Turn any freeform button 
into a standard polygon.

Create polygon shapes and 
make the borders dashed.
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1
Select the Freeform Button Tool.

2

On the board background, click and hold the 
mouse button down. Drag the mouse around 
to draw the freeform button.

3

Release the mouse button to automatically 
close off the button border with a straight line 
between the mouse position and where you 
started drawing the freeform button.

Click and drag to 
draw a freeform 
button.

Release the mouse 
button to close the 
button with a 
straight line.
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Drawing a Polygonal Freeform Button

1
The Freeform Button Tool can also be used 
to draw polygons.

Select the Freeform Button Tool.

2

Press and hold the Control (Ctrl) key, click to 
set the starting point for the button and move 
the mouse to drag out the first side of the 
polygon. Click to set that side.

3

While continuing to hold down the Ctrl key, 
click the mouse where you want each corner 
of the polygon to be.

4

To finish your polygonal freeform button, 
double-click to specify the position of the 
final corner (or you can just release the Ctrl 
key). The program will automatically close 
the polygon.

While holding down the 
Ctrl key, click then 
move the mouse and 
click to create the first 
side of the button.

Continue to hold 
down the Ctrl key 
and click to set 
each corner.

Release the Ctrl key 
and the application 
will automatically 
close the button.
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Drawing a Button with Straight and Freeform Sides

1
The Freeform Button Tool can be used to 
draw buttons that have both freeform and 
straight sides.

Select the Freeform Button Tool.

2

Press and hold the Ctrl key, then click and 
drag to define the first side of the polygon.

3

Now, while continuing to hold the mouse 
button down, release the Ctrl key. Move the 
mouse around to draw a freeform side.

4

To draw a straight side again, press and hold 
the Ctrl key and release the mouse button. 
Click to set the next corner.

Alternate between holding down the Ctrl key 
and the mouse button to switch between 
drawing straight or freeform sides.

While holding down the 
Ctrl key, click then 
move the mouse and 
click to create the first 
side of the button.

Hold down the 
mouse button 
and release the 
Ctrl key to draw a 
freeform side.

Hold down the Ctrl 
key again and 
release the mouse 
button to define 
another straight 
side.
35



Chapter 1 - Building a Board and Working with Its Appearance
Creating a Regular Polygon from a Freeform Button

Tip: Hold the Shift (constrain) key while selecting a shape to create a regular polygon (all sides having the 
same length).

5

To finish your freeform button, simply release 
the mouse button and the Ctrl key. The 
application will automatically close the 
polygon.

Although it's possible to manually draw regular polygons (like triangles and hexagons) using the methods 
described in the Drawing a Polygonal Freeform Button section, it can be very tricky to get such polygons 
just right. The applicationprogram therefore provides a way to convert any freeform button to a regular 
polygon by using the Corner Tool.

Select a freeform button. 

Select the Corner Tool; then 
select a shape.

The freeform button will appear 
with the new shape.

Release the Ctrl 
key or the mouse 
button to close 
the button with a 
straight line.
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Chapter 2 
Working with the Symbol Finder

Chapter Overview 

The Symbol Finder allows you to quickly search for symbols and copy them to buttons or to other programs. 
You can easily change the text above a symbol or work in another language. This section will show you how 
to use the Symbol Finder’s different features so you can easily get the symbols and text you need.

The following topics will be covered:

• Searching for Symbols

• Copying a Symbol to a Button

• Adding a Symbol to the Symbol Finder

• Using the Alternate Symbol Names Menu

• Adding or Editing a Symbol’s Alternate Names

• Using Different Languages with the Symbols

• Working with a Category Search

• Creating Your Own Symbol Category

• Selecting the Display Option for Symbol 
Names

• Searching for Symbols Using Categories

• Copying a Symbol to Another Program

• Making a One-Time Symbol Name Change

• Setting the Symbol Finder Font Size

• Selecting a Search Category

• Assigning Categories to a Symbol

• Enlarging the Symbol Finder Window

• Selecting the Black & White Color Libraries

You can use different 
languages or display 
two at once. The text 
can also be hidden 
or positioned below 
the symbol.

Select just a portion 
of a symbol to copy.

Browse multiple 
symbols using the 
thumbnail view.

Enter alternate 
symbol names.
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Searching for Symbols

1

Select the Symbol Finder Tool to open the Symbol Finder. Click the appropriate Symbol Name 
Search Option button. This determines how the Symbol Finder matches symbols to your search text.

Type the name of the symbol you want to find.

2

The symbols that match your search text can be displayed either one at a time within the Symbol Finder 
window or in a popup window with up to 49 thumbnail pictures.

Searching for Symbols Individually

If the first symbol that appears is not correct, use the Previous/Next Arrows or the right and left arrows 
on your keyboard to step through the symbols that match the search.

Search Options

Search Text Field

Beginning of Word
Search text: “her”
Matches: “here,” “her,” “come here”

Anywhere
Search text: “her”
Matches: “where,” “cherries,” “here”

Whole Word
Search text: “her”
Matches: “her” (only match)

Indicates the current 
symbol number and 
total number of 
matching symbols.

Next Arrow

Previous Arrow
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Searching for Symbols Using Categories

If you are working on a topic-based board, i.e. breakfast or clothes items, you may find that doing a category 
search will be quicker than searching for each symbol separately. You can set the Symbol Finder to search 
for or display only those symbols within a specific category.

Category searches are covered in-depth in Working with a Category Search section.

3

Searching for Symbols Using Thumbnails

Click the Thumbnails button (Ctrl + T) to view thumbnail pictures of all symbols that match the 
search.

You can use the Previous/Next Arrows or the arrow keys on your keyboard to step through the 
thumbnail screens. Click the thumbnail picture of the symbol you want to use.

Note: As you pass the pointer over each thumbnail picture, its symbol name will appear in the 
Alternate Symbol Names field.

Tip: Right-click on a thumbnail to paste it into the currently selected button. The thumbnail view 
will remain open so you can continue right-clicking on thumbnails to quickly paste them into 
your blank buttons.

Thumbnail
Button

Click the symbol you want to use, or 
right-click the symbol to paste it into 
the selected region.

Alternate Symbol 
Names field

Name of the selected 
thumbnail.

You will be shown 
thumbnail pictures 
of the first 49 
matching symbols.
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Copying a Symbol to a Button

Automatic Placement

The Symbol Finder will select the first empty button 
on the board.

Pressing the Enter key will automatically place the 
current symbol on the selected button.

Once the symbol is placed, the next empty button 
will become selected.

Note: If there are no empty buttons, the Symbol 
Finder will place the symbol on the board 
background.

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - OR - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Manual Placement

You can place the current symbol on any button on 
the board, not just on the selected button.

Using the Placement Cursor, click the button where 
the symbol should be placed.

Note: The next empty button that follows the 
button you just clicked on will become 
selected for automatic placement.

Tip: With the Placement Cursor, you can click 
and drag out a marquee box into which the 
current symbol will be placed. This is an 
easy way to size and position a symbol 
within a button or on the board background.

Selected Button

Placement Cursor

Click and drag to 
create a marquee 
box
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Copying a Symbol to Another Program

Adding a Symbol to the Symbol Finder

You can create your own library of symbols by adding symbols, graphics, or photos to the Symbol Finder. 
Please refer to Chapter 8 - Adding New Symbols or Photos to the Symbol Finder.

1
You can copy symbols from a Boardmaker program and paste them into other programs as needed.

Locate the symbol you want, then choose Edit > Copy, or press Ctrl+C.

2 Assuming you have already launched the program that will receive the symbol, select that program 
from the Windows taskbar.

Tip: If you minimize the Boardmaker program window, you might be able to see the window of 
your other program in the background. You could then switch between the programs by 
clicking on their respective windows.

3
Paste the symbol into your other program. Please refer to that program’s manual if you are not sure how 
to paste a picture from the clipboard.

When you are ready to copy another picture, click on the Boardmaker program’s button on the 
Windows taskbar or the program window to return to the Boardmaker program.
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Using the Alternate Symbol Names Menu

Many symbols are assigned alternate symbol names (synonyms). If you search for any of these alternate 
names, the symbol will appear in the Symbol Finder with that name above it.

If you want to use an alternate name for a symbol, click the black triangle and select a name from the pull-
down menu.

Note: Changing the text using the Alternate Symbol Names field is a one-time change and will not affect 
the original symbol name.

Making a One-Time Symbol Name Change

You can change the text that appears above a symbol by typing in the Alternate Symbol Names field. As 
you type the text, it will automatically appear above the symbol.

Note: Changing the text using the Alternate Symbol Names field is a one-time change and will not affect 
the original symbol name.

Alternate names for 
the current symbol.

Click here to show 
any alternate symbol 
names.

Original search text

Alternate Symbol 
Names field
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Adding or Editing a Symbol’s Alternate Names

1

If you are continually typing in an alternate name 
for a specific symbol, you should add that alternate 
name to the symbol for future use.

Click on the Change Symbol Names button.

2

Type a new alternate symbol name, then click on the Add Name button. The new name appears in the 
list of defined names. Once a name is added, you can search for a symbol using that name.

To remove a name from the list, select the name then click on the Remove Selected Name button.

Note: You cannot remove the first name listed for a symbol (the default name) that belongs to a PCS 
symbol library or any PCS addendum library you purchase.

Tip: You can add a name for the symbol in another language by selecting the desired language in 
the drop-down menu, then adding the new symbol name.

Change Symbol 
Names button

Current symbol’s library name
Select which language 
will receive the new 
symbol name.

Name(s) defined 
for the current 
symbol in the 
selected language.

Type the new 
name here.

Click here to add 
the symbol name.
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Setting the Symbol Finder Font Size
When placing a symbol from the Symbol Finder on a button, the Symbol Finder will scale the symbol to fit 
the button, but the font size of the text will remain the same regardless of the button’s size. This allows you 
to use consistently sized text throughout your board.

You can set the font size for the Symbol Finder to match your needs.

1 Click on the Symbol Finder Settings button.

2
Select the desired font size in the Line 1 Size drop-down menu. (If you are displaying two different 
language lines, set the Line 2 Size as well.)
Click on the OK button when finished.

Note: If you get partway through placing symbols on a board and discover that you should have used 
a different font size, you can change the font size for a group of selected buttons later. Please 
refer to the Changing the Text Settings on Multiple Buttons section in Chapter 3- Working 
With Button Text.

14-point font size

Change Symbol Finder 
Settings button

The same font 
size is used 
regardless of 
button size.
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Using Different Languages with the Symbols
The PCS libraries that came with your software are translated into many different languages. You may 
change the displayed language, add a second language line, or set a different search language.

1 Click the Symbol Finder Settings button.

2
Use the drop-down menus to select the desired languages for the Line 1 Language and/or Line 2 
Language.

Click the OK button when finished.

Changing the Line 1 Language changes the Search Language to match. You can set the Search 
Language independently after setting the Line 1 Language (see above; an English speaker can 
make a board for a Spanish speaker).

Note: Some languages require special fonts and font scripts to display their text correctly. The 
fonts and scripts for the Eastern European languages are available within Windows 2000 or 
higher if Multilanguage Support is enabled in the Windows Setup. Refer to Enabling 
Multilanguage Support in Help Topics in the Help menu.

Line 1 Language: Spanish
Line 2 Language: English

Symbol Finder 
Settings Button
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Selecting a Search Category

1

2

Select Categories button
Click here to select a category 
to search or view.

Checks all category fields Unchecks all category fields

Shows/selects any user categories Cancels any 
selection changes

Closes the Categories 
window

Click Clear All Standard Categories to uncheck all category selections.

Check any category or categories you want to search or browse. Click OK when finished.
46



Boardmaker Software Family v6 User’s Guide
Working with a Category Search

Symbol Finder Details

Once you have selected a search category, only those symbols assigned to that category will be available in 
the Symbol Finder.

Using the Thumbnails View

Search categories are best used in conjunction with the thumbnail view. The thumbnail view will allow you 
to see up to 49 symbols at a time from a selected category. This will allow you to quickly locate the symbols 
you want to use. Use the Next Arrow to view the next 49 symbol thumbnails.

Selected search category

If the search field is 
blank, you can step 
through all symbols in 
a selected category.

Steps through 
the matching 
symbols.

Current symbol 
number

Number of 
matching symbols

Click on the 
thumbnail of the 
symbol you want.

Previous/Next 
Arrows

The search field must 
be blank to view all 
symbols in a selected 
category.

Displays the name 
of the selected 
symbol thumbnail.
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Filling a Topic Board Quickly

There are two methods you can use to quickly fill a topic-based board with symbols from a specific search 
category. In the examples below, the “breakfast” category is selected.

Method 1 - The Enter key and automatic placement

Repeatedly pressing the Enter key fills the buttons with “breakfast” symbols in the order they appear within 
that category. Use the Right Arrow key to skip unwanted symbol(s).

Method 2 - Right-click a thumbnail and automatic placement

Right-click on a thumbnail to paste it onto the currently selected button. The thumbnail view will remain 
open so you can continue right-clicking on thumbnails to quickly paste them onto your blank buttons.

Symbol 8 of 25 Symbol 9 of 25 Symbol 10 of 25

Press the Enter key Press the Enter key Press the Enter key
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Assigning Categories to a Symbol

Each symbol in the library is assigned to at least one of the standard categories. You can change a symbol’s 
categorization if necessary.

1

Locate a symbol whose category assignment(s) you want to change, then click on the Change 
Symbol Names button.

2

Click on the Assign Categories button.

Assigned Categories
Breakfast
Breads/Grains

Assigned Categories
Breakfast
Drinks

Symbol Names button.
Click here to edit the 
current symbol’s name 
or category assign-
ments.

Assigned Categories

Current symbol

Assign Categories button
Click here to edit assigned 
categories.
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3

Add or edit any of the category assignments as necessary for the symbol. In this example, the 
“bagel” symbol is being added to the “Lunch/Dinner” category.

Click on the OK button when finished.

4

“Bagel” is now a part of the “Lunch/Dinner” category.

Click on the OK button when finished.
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Creating Your Own Symbol Category

You can create up to 28 custom user categories. Creating your own symbol categories allows you to search/
view groups of symbols you use frequently.

1

In the Symbol Finder, locate a symbol that 
will be included in your new category.

For example, “cow” will be a part of the new 
“farm animals” category.

Click on the Change Symbol Names button.

2

Click on the Assign Categories button.

3

Click on Show My Categories.

Change 
Symbol 
Names 
button

Click here to show/edit 
the user categories.
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4

Check the Unlock Category Names box so the names can be edited.

In an available user category, type a name for your new category. In this case, “Farm Animals.”

Check the new “Farm Animals” category to assign the current symbol to that category.

Click on the OK button when finished.

To enter a category name, check the Unlock Category Names box. 
You can then type a category name in the correct field.

Click to edit category names Show custom categories Show standard categories

Unchecks all user categories Cancels all selection 
changes

Returns to the symbol/
name category window
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Note: Plan your user categories carefully. There are only 28 user categories. Assigning symbols to a new 
category is time consuming. If you use all 28 categories and then have to change an existing user 
category, you will have to remove the unwanted category from all the symbols that were assigned to it 
before you change its name and start adding the new category to the correct symbols.

5

The current symbol is now a part of the new “Farm Animals” category. Click on the OK button.

6

Symbols that could be assigned to the new “Farm Animals” category

Locate and assign each appropriate symbol to your new category.
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Enlarging the Symbol Finder Window

The Symbol Finder can be enlarged to give you a larger view of the symbols. This is useful when using the 
Marquee/Lasso.

To enlarge the Symbol Finder, click the Maximize button. The Maximize button is then replaced by the 
Restore button and is used to return the Symbol Finder to its normal size.

You can set the size of the enlarged Symbol Finder by clicking on the Symbol Finder Settings button, then 
selecting a magnification in the Magnification for Enlarged Window box popup.

Selecting the Display Option for Symbol Names
The Symbol Finder can be set to display the symbol names above the symbol, below the symbol or not at all. 

To change the symbol names display option, click the Symbol Finder Settings button then select the desired 
option.

Note: When the No Labels option is selected, the Line1 and Line2 language settings are preserved, but 
appear grayed out and are unselectable.

Maximize 
button

Symbol Finder 
Settings button

Select the display 
option for the 
symbol names.
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Selecting the Black & White Color Libraries

You can choose to use either the color or black & white symbols on your boards (assuming both sets are 
installed).

To switch symbol sets, click on the Symbol Finder Settings button, then select the desired option.

Symbol thumbnails will always appear in color, even if the Use Black & White Symbols option is selected.

Select which symbol 
set to use.
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Chapter 3 
Working with Button Text

Chapter Overview 

You can use the Text Tool and Text menu to edit text above a symbol or add text directly to a button or the 
background. This chapter will show you how to work with the text on your boards.

The following topics will be covered: 
• Adding Text with the Text Tool
• Editing a Symbol Name with the Text Tool
• Setting the Font, Style, and Size
• Changing the Text Settings on Multiple Buttons

• Repositioning Text Fields
• Changing the Text Color
• Changing the Text Justification

Use the Text Tool to 
change a symbol’s name.

Create buttons or boards with only text.

You can change the font, size, style, and color of the text 
on all selected buttons in one step.
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Adding Text with the Text Tool 

Repositioning Text Fields 

Select the Text Tool. Click with the I-beam cursor where 
you want to type text.

The blinking insertion cursor marks 
your position in the text field.

Type your text.

Select the Pointer Tool. Click and drag the text field to a 
new position. You may also use the 
keyboard arrow keys to nudge the 
text field around.

Tip: You can also click and 
drag on the top or 
bottom of a multi-word 
text field to resize the 
text block.
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Editing a Symbol Name with the Text Tool 

Changing the Text Color 

Click with the I-beam cursor on the symbol name, then type the new 
name.

Select the Text Tool.

Note: The first time you click on a text field with the I-beam cursor the entire text field will be selected. 
The second click places the insertion cursor. A double-click will select a single word.

Tip: Right-click on any text with the pointer, and select Edit Text from the contextual menu to edit 
the text. Move the I-beam cursor off the text and right-click again to select the Pointer Tool to 
stop editing text.

Select the text field using the Text 
Tool or Pointer Tool.

Select the Color Tool. Click the desired color in the 
Color Palette.

Tip: You can change the color of text with the Pointer Tool by right-clicking on the text and selecting 
the color from the Font Color submenu.

Tip: Use the eyedropper to set a custom color for the text by clicking on any color on the board. For 
more information, refer to Color Tool in Chapter 7.
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Setting the Font, Style, and Size

Select the text to be 
changed using the Text 
Tool or Pointer Tool.

The font size can be set within 
the Text menu.

Select Text > Font to change the settings for 
the Text Tool or a selected text field.

Note: You can change the default font, style, and size used by the Text Tool by first double-clicking on 
the Text Tool, then selecting Text > Font and making the desired changes.

Tip: You can quickly increase or decrease the font size by one point by using keyboard shortcuts.  "+" 
will increase the size, and "-" will decrease the size.
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Changing the Text Justification 

Changing the Text Settings on Multiple Buttons 

Select the text field using the Text 
Tool or Pointer Tool.

Choose Text > Justify, and then 
choose the alignment you want 
from the submenu. In this 
example the Center option has 
been chosen.

The text in this example is now 
centered.

Tip: You can change the alignment of text with the Pointer Tool by right-clicking the text and choosing 
the alignment option you want from the Justify submenu.

Select the buttons whose text will 
be changed.

Make the desired changes in the 
Text menu.

All selected buttons will reflect 
the text change.

Note: If you are increasing the text size on your buttons by a significant amount, the text may appear 
behind the top portion of some symbols. It may be necessary to resize or reposition some symbols 
within their buttons in order to avoid clipping the text.
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Chapter 4 
Working with Symbols on a Board

Chapter Overview 

A symbol on a button can be easily replaced, added to, resized, moved, or deleted. This chapter will show 
you how to manipulate the symbols and create your own symbols.

The following topics will be covered:

• Replacing a Symbol on a Button

• Resizing and Repositioning a Symbol

• Clearing Symbols and Text from Selected 
Buttons

• Adding an Additional Symbol to a Button

• Using a Portion of a Symbol (Marquee/Lasso)

Quickly replace a button’s 
symbol and text.

Position multiple symbols on a 
button to make a new symbol.

Quickly clear the contents 
of any selected buttons.
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Replacing a Symbol on a Button

1

Search for a new symbol in the Symbol 
Finder.

Using the Placement Cursor, click the 
button whose symbol will be replaced.

2
Click the Replace button to confirm the 
action.

3

The new symbol and text will replace the old 
ones.

Placement Cursor
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Adding an Additional Symbol to a Button

1

Search for the symbol you want to add.

Press the Tab key to move to the Alternate 
Symbol Names field, then press the 
Backspace or Delete key to remove the 
symbol text. Remove the symbol label to 
prevent adding an additional label to the 
button.

\

2

Using the Placement Cursor, click the button 
that will receive the additional symbol or click 
and drag out a marquee box that will 
determine the size and position of the 
additional symbol.

3
Click the Add To button to confirm the 
symbol addition.

4

The new symbol is added to the button on top 
of the previous symbol.

Add another symbol or click on the Pointer 
Tool to resize and reposition the symbol you 
just added.

Alternate Symbol Names Field
Delete this text to temporarily 
remove the symbol’s text.

Placement Cursor
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Resizing and Repositioning a Symbol

1

Select the symbol to resize.

Note: If there are multiple symbols on top of 
each other on the button, the first click 
selects the symbol on top, the next click 
selects the next symbol down, etc.

2

Move the pointer over any portion of the dashed 
selection box. The pointer will become a double 
arrow.

3

Click and drag the lower right-hand corner to resize 
the symbol.

Tip: Hold down the Shift key while resizing 
the symbol to maintain the symbol’s 
proportions.

Tip: If the symbol gets distorted as a result of 
resizing it, right-click the symbol and 
select Restore Proportion to return the 
symbol to it original aspect ratio.

4

If necessary, move the pointer over the symbol, 
then click and drag to reposition the symbol.

Tip: You can change the order in which the 
symbols are stacked on a button by 
selecting a symbol, then selecting 
View > Send To Back in the View or 
contextual menu.

Double 
arrows are 
used to 
resize.
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Using a Portion of a Symbol (Marquee/Lasso)

1

Selecting a Portion of a Symbol

Click either the Marquee or Lasso button then click and drag to select the desired portion of a 
symbol.

2

Placing the Selection

You can click with the Placement Cursor or press the Enter key to place the symbol on the next 
blank button. You can also click and drag out a marquee box with the Placement Cursor to set the 
position and size of the selected portion of the symbol within the button.

To learn how to save a new symbol in the Symbol Finder, please refer to Chapter 8 - Adding New 
Symbols or Photos to the Symbol Finder.

Select a rectangular 
region with the Marquee.

Select a freeform region 
with the Lasso.

Completed button 
(after resizing and 
positioning).
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Clearing Symbols and Text from Selected Buttons

Select the buttons whose symbols 
and text you want to clear.

Choose Edit > Clear or right-
click on one of the buttons and 
choose Clear Buttons > Face 
from the contextual menu.

The cleared buttons are ready for 
new symbols.
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Chapter 5 
Working with Symbolate Buttons

Chapter Overview 

Symbolate buttons provide a quick and easy way to create symbol-adapted sentences, stories, direction strips 
and other instructional materials and aids. As text is typed into a symbolate button, appropriate symbols will 
appear above each word. By design, text and symbols cannot be moved around in symbolate buttons, but in 
most other respects, symbolate buttons are similar to standard buttons. Their background color, border 
thickness, corner setting, font size, style and color can be set in the usual fashion. They can be positioned 
and resized according to your needs. In Boardmaker Plus! and Boardmaker with Speaking Dynamically Pro, 
you can assign a subset of actions to these buttons, including the new Read With Highlighting action 
designed specifically for symbolate buttons.

The following topics will be covered:
• Creating a Symbolate Button

• Changing the Symbol for a Word-Symbol 
Pairing

• Changing the Default Word-Symbol Pairing

• Changing the Text Position

• Changing the Font and Symbol Size

• Read with Highlighting Action

• Editing Symbolate Text

• Making New Word-Symbol Pairs

• Changing the Font and Symbol Size

• Changing the Text for a Word-Symbol Pairing

• Setting the Button’s Symbolate Properties

Symbolate 
buttons

Symbolate 
button

Quickly create symbol-supported learning activities like this current events page using the Symbolate 
Tool. The symbols automatically appear as you type. (Many of the symbols shown above come from 
the optional PCS addendum libraries.)
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Creating a Symbolate Button 

1
Select the Symbolate Tool in the toolbar. 

2

Click on the background where you would like to 
start typing. 

A new symbolate button will extend from the 
location where you have clicked to the right edge of 
the board. You will be able to adjust the width of the 
button later. A symbolate button's height is 
automatically determined by its font and symbol size 
settings.

Tip: Click and drag horizontally with the 
Symbolate Tool to set the initial width of 
the symbolate button. 

3

Begin typing in the new symbolate button. If there is 
a valid word-symbol match, then the symbol will 
appear as each word is completed. 

The text will automatically wrap when it reaches the 
right edge of the button. You can move to a new line 
at any time by using the Enter (or Return) key. 
There is no limit to the amount of text you can type 
into a symbolate button. However, you are limited to 
what you can see by the dimensions of your board.

Tip: To access symbols that are paired with multi-word phrases (like “solar system”) you must 
type “solar_system.” The underscore (“_”), which will appear as a space, prevents the 
program from attempting to symbolate the first word.

Note: You can apply standard button appearance options such as border thickness and color, 
background color and shadow borders to a symbolate button.
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Editing Symbolate Text 

1

Select the Symbolate Tool and click on the text you 
want want to edit. The symbolate button will behave 
like a very simple text editor. 

Tip: Right-click a symbolate button and choose 
Symbolate Tool from the contextual menu 
to edit the text.

2

Once the text cursor is positioned, text can be 
inserted and deleted as in any word processor. Move 
around within the text by repositioning the cursor or 
by using the arrow keys. 

Note: Although you can use standard techniques 
to select text (for example, clicking and 
dragging across the letters you want to 
select), your selection cannot span multiple 
word-symbol pairs.

3

The program will automatically re-symbolate the text 
as it is changed.

You can prevent the application from automatically 
re-symbolating the text by holding down the Alt key 
while you type. Refer to the Changing the Text for a 
Word-Symbol Pairing section for more information.

4

Click between two symbolate word-symbol pairs to 
insert new text.

Use the Symbolate Tool 
to edit symbolate text.

You can not click and drag 
to select multiple words.
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Changing the Symbol for a Word-Symbol Pairing 

The program uses a set of pre-defined word-symbol pairings and symbol library searches to determine the 
symbol that will first appear when a word is typed. The first symbol that appears will not always be appropriate 
for the context of the word. In this situation you can manually step through the candidate symbols (i.e., all 
symbols paired with the word).

Using the F1 and F2 Keys

With the Symbolate Tool, click on the word or symbol you want to change, then press the F2 or F1 keys to 
step forward or backward through any candidate symbols paired to the word. This can also be done for the 
last word you typed.

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - OR - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

The symbol for “saw” is 
not correct for the context.

F2

F1
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Using the Symbolate Candidates Dialog

With the Symbolate Tool selected, double-click on the symbol (not the word) that you want to change. The 
Symbolate Candidates dialog will appear.

Click on the appropriate candidate symbol then click the OK button.

Tip: Double-clicking on the appropriate symbol will automatically select the symbol and close the 
Symbolate Candidates dialog.

Tip: Selecting a word and pressing the Esc key will also open the Symbolate Candidates dialog.

Note: This symbol change only applies to this instance of the word. If you want to make this symbol the 
new default for the word, click the Make Default button.
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Making New Word-Symbol Pairs 

You have access to a large number of PCS symbols in the libraries provided with the program and through the 
optional PCS addendum libraries, but there will be words that will not have any paired symbols. This will be 
especially true for names, places and other proper nouns. In this situation, you can manually make a new word-
symbol pairing.

1

Using the Symbolate Tool, double-click above the 
word (where a symbol would be) to open the 
Symbolate Candidates dialog. 

Tip: Selecting the word and pressing the Esc key 
will also open the Symbolate Candidates 
dialog.

2

Click the Add New Symbol button. This will open a 
special version of the Symbol Finder. 

Search for the symbol that you would like to pair 
with the word (shown in the Label field). 

Click the OK button when you have located the 
appropriate symbol. 

There is no symbol associated with “astronomer.” You will need to make a new word-symbol pairing.

Double-click above a word to create 
a new word-symbol paring.

There are no 
candidate symbols 
for this word yet.

Click on the Add New 
Symbol button to 
search for a symbol to 
pair to the word.
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3

The “stars” symbol is now paired with the word 
“astronomer.” Click the OK button. The newly 
paired symbol will appear in the symbolate button. 
This new word-symbol pairing will be remembered 
by the program for future use.

Tip: Import photos into the Symbol Finder to 
make them available for use in symbolate 
buttons. The name(s) you provide for the 
photo will determine its automatic word-
symbol pairing.
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Changing the Default Word-Symbol Pairing 

You may want to change the default word-symbol pairing to a more appropriate symbol or imported photo, or 
to set the default so that no symbol appears initially. This can be accomplished using the Symbolate 
Candidates dialog.

1

With the Symbolate Tool, double-click the symbol 
for the word-symbol pairing to be changed. This will 
open the Symbolate Candidates dialog. 

2

Click the symbol you want to become the new 
default then click the Make Default button. 

Select the No Symbol entry in the candidate list to 
prevent the application from displaying a symbol for 
the word.

Click OK to save the changes. 

Note: Use the Remove Symbol button to remove 
a candidate symbol from the list and prevent 
it from appearing when pressing F1 or F2 to 
step through the word-symbol pairs.

In this example you might want to change the default word-symbol pairing so no 
symbol appears for the word “a” and find a better symbol for the word “huge.”

Symbols that are already paired to the word.
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Changing the Text for a Word-Symbol Pairing 

Temporary changes can be made to words and phrases in existing word-symbol pairs. This can be done using a 
keyboard shortcut or through the Symbolate Candidates dialog.

Note: Changes to the text in a word-symbol pair are temporary and only apply to that word-symbol pair.

Tip: For specific people, places or things, import photos into the Symbol Finder to make them available for 
use in symbolate buttons. The name(s) you provide for the photo will determine its automatic word-
symbol pairing.

Using the Symbolate Candidates Dialog

Using the Symbolate Tool, double-click the symbol whose word is to be changed.

Type the new word or phrase in the Label field. Click OK when finished.

 - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - OR - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

In this example you might want to change 
the word “Man” to a person’s name.

Edit the label to only change the 
text for this word-symbol pair.
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Changing the Text Position 

The text in a symbolate button can appear on top of or below the symbols.

Note: This change only affects the current button. To change the text position for all future symbolate 
buttons, make sure nothing is selected, then change the setting by choosing 
Edit > Symbolate Properties.

Using the ALT Key

With the Symbolate Tool, select the word you want to change.

While holding down the Alt key, type the new text for the symbol. Holding the Alt key prevents the 
application from attempting to re-symbolate the text.

Click elsewhere in the button when finished.

Hold the Alt key while typing to directly 
edit the text without changing the symbol.

Right-click on the Symbolate 
Button to adjust the text position.
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Adjusting the Button Border 

It is not uncommon to have a gap between the right border of a symbolate button and its contents. The border 
can be adjusted either manually or by using the Autofit Border option (contextual menu). Each option yields a 
slightly different result.

Manual Resizing

Using the Pointer Tool, click and drag on the left or right border to resize the button. The text and symbols 
in the button will not change as you change its width. The height of the entire symbolate button will change 
to accommodate its contents.

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - OR - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

After entering the text, a gap is present 
between the text and the right border. 
Adjust the right border to improve the 
appearance of the button.

Click and drag on the 
right or left border to 
resize the button.
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Autofit Border

Right-click the symbolate button and select Autofit Border from the contextual menu. This will fit the 
border to leave a consistent margin around its contents. This option will never change the top or bottom 
border of the button.

Use the Autofit Border 
option to fit the border 
for a consistent margin.
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Changing the Font and Symbol Size 

As with any text, you can adjust the font size, color, style and justification in a symbolate button. All of these 
settings are available in the contextual menu that can be opened by right-clicking the symbolate button. Many 
of these options can also be found in the Text menu.

Right-click the Symbolate 
button to adjust the font 
settings.
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Setting the Button’s Symbolate Properties 

A convenient method of setting the properties of the symbolate button is to use the Symbolate Properties 
dialog . 

Note: A few of the more commonly used Symbolate Properties are available directly from the contextual 
menu, however, this dialog contains all available properties of a symbolate button.

Note: You can define your personal default properties for symbolate buttons by choosing 
Edit > Symbolate Properties and modifying the default values. You can restore your default settings 
to the factory default settings for symbolate buttons by by choosing Edit > Symbolate Properties 
and clicking on the Restore Factory Default Settings button.

Set the text 
position.

Set the justification.

Specify a set 
symbol size.

Set the line 
spacing – 
small, medium 
or large.

Restores your default 
settings if you have 
made setting changes.

Make all word-symbol 
pairs the same width, 
based on the widest 
pair.

 Contextual 
menu
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Read with Highlighting Action 

In Boardmaker Plus! and Boardmaker with Speaking Dynamically Pro, you can choose to read symbolate 
buttons aloud. Each word-symbol pair will be highlighted as it is spoken.

Double-click the symbolate button and select the Read With Highlighting action in the Basics action category 
in the dialog that appears. By default, the entire word-symbol pair is highlighted as it is spoken. Check the 
Highlight Text Only box to highlight just the text.

Note: This action is only available on symbolate buttons.
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Chapter 6 
Working with the Board Layout

Chapter Overview 

The program contains a variety of useful features that make it easy to change the appearance of a board by 
quickly scaling and rearranging the content of buttons, aligning and centering symbols and text. 

The following topics will be covered: 
• Resizing Buttons and Graphics

• Swapping Button Content and Appearance

• Anchoring Images and Symbols on the 
Background

• Resizing Multiple Buttons

• Shuffling Buttons

Shuffle the content of selected buttons. Align groups 
of items.

Resize multiple buttons and their contents.
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Resizing Buttons and Graphics

1

Resizing a button

Select the button to be resized.

Move the pointer over any portion of the 
dashed button border. The pointer will 
become a double arrow.

2

Click and drag to resize the button.

Notice that the symbol and text don’t 
resize with the button.

3
Resizing the Symbol and Text

Use a similar procedure to resize the 
symbol as necessary.

4

Select the text field, then select an 
appropriate font size in the Text menu.

Use the pointer to reposition the text field 
as necessary.
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Resizing Multiple Buttons

1

Multiple buttons on a board can be resized 
together using the same methods as described 
for single buttons.

Select the buttons to be resized (using the 
Pointer Tool while holding down the Shift 
key or click on the background and drag out a 
marquee box that touches all the buttons).

2

Press the Ctrl key. A red dashed border will 
appear around all the selected buttons.

While holding down the Ctrl key, click and 
drag the red dashed border around the selected 
buttons to resize them and all of their contents.

To resize the buttons, symbols and lines while 
leaving the text the original size, hold down 
both the Ctrl and Alt keys at the same time 
you click and drag.

Note: As with resizing single buttons, 
holding down the Shift key will force 
the buttons to be resized 
proportionally.

Select the buttons 
to be resized.

Resized with the Ctrl 
+ Alt keys held. The 
text does not resize.

Resized with the 
Ctrl key held. The 
text resizes.
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Swapping Button Content and Appearance

Button content (symbols, text and lines) and appearance (color, border color, border thickness, etc.) can 
easily be swapped between two buttons. If the buttons are different sizes, the content will be scaled to fit the 
button.

Note: You can also swap buttons by choosing Edit > Swap Buttons. Both buttons have to be selected first 
(hold down the Shift key and click on each button).

Note: For Boardmaker Plus! and Boardmaker with Speaking Dynamically Pro users, all button actions 
associated with the buttons will also be swapped.

Tip: If you are interested in just moving the appearance (button and border color) from one button to 
another, but not the content of the button, you can copy the button and use the Paste Look option 
(refer to the in-application Help Topics).

Using the Pointer Tool, select the 
first button you want to swap. 

Hold down the Alt key and click 
and drag the button on top of the 
button you want to swap it with.

The buttons will exchange 
positions. Each button will scale 
accordingly, but will maintain its 
appearance.
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Shuffling Buttons

The content (symbols, text and lines) and appearance (button color, border color, border thickness, etc.) of 
multiple buttons on a board can be shuffled easily using the Shuffle Buttons command in the Edit menu. 

Note: As with the Swap Buttons feature, the shuffled buttons can be of different sizes. The content will be 
scaled appropriately. 

Note: For Boardmaker Plus! and Boardmaker with Speaking Dynamically Pro users, all assigned button 
actions associated with the buttons will also be shuffled.

Select all the buttons you want to 
shuffle with the Pointer Tool. 

Choose Edit > Shuffle Buttons. The contents of all selected 
buttons will be randomly 
shuffled.
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Anchoring Images and Symbols on the Background

When designing a board that includes background images, accidentally selecting those background images 
can be a nuisance. To prevent accidental selection, right-click the background image (or images) and choose 
Anchor Picture on Background from the contextual menu.

When this property is set, the background image becomes non-selectable while using the left mouse button. 
To reset the property, simply right-click on it again and deselect the Anchor Picture on Background 
option.

Anchoring the image on 
the board background 
prevents you from 
accidentally selecting it.
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Chapter 7 
Working with the Paint Tools

Chapter Overview 

You have access to a set of paint tools that can be used to change the appearance of a selected symbol. You 
can quickly add lines, change the color of a face, erase an unwanted portion of a symbol, and much more.

The following topics will be covered: 
• Paint Tools at a Glance

• Transparency Color

• Pencil Tool

• Color Tool

• Fill Tool

• Invert Tool

• Rotate Tool

• Important Paint Tools Information

• Pointer Tool

• Eraser Tool

• Thickness Tool

• Fill All Tool

• Flip Horizontal Tool and Flip Vertical Tool

Change a symbol’s color Draw on the symbol.
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Paint Tools at a Glance

Note: The paint tools will appear only after you select a symbol with the Pointer Tool.

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15

Pointer Tool

Color Tool

Line Tool

Zoom In Tool

Zoom Out Tool

Flip Horizontal Tool

Pencil Tool

Flip Vertical Tool

Eraser Tool

Rotate Tool

Fill Tool

Invert Tool

Fill All Tool

Marque Tool

Lasso Tool

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15
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Important Paint Tools Information

Conversion to Bitmap Format

The PCS library contains metafiles (scalable line drawings) that cannot be directly edited. The symbols must 
first be converted into a bitmap format before the paint tools can be used.

Note: Once a symbol is converted into a bitmap format it will lose some print quality. The curved lines in 
the symbol will no longer print smoothly, but will appear jagged. 

When you first select a paint tool to use on a selected symbol, the dialog box shown above will appear. Click 
Yes to change a picture to a bitmap format and start editing it.

Limited Drawing Area

When you select a symbol, it is surrounded by a dashed selection box. This selection box defines the 
available drawing space in which you can use the paint tools.

As you draw a line, the pencil 
(and all other paint tools) will 
not work outside of the 
dashed selection box.
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Transparency Color

Symbol Transparency

When a symbol is converted to the bitmap format (by using a paint tool), any portion of the selected symbol 
that is white will become transparent to the button background color. If you select the Color Tool before 
selecting the Pencil Tool, Fill Tool, or Fill All Tool, you can change the transparency color. Typically, you 
will want to leave white as the transparency color.

Imported Picture Transparency
When importing pictures into the program, you may find it necessary to change the transparency color for 
that picture. If a portion of the imported picture is white (the transparency color), the background will be 
visible through the picture. To correct this, you will need to select a different transparency color by first 
selecting the picture and then selecting an obscure color using the Color Tool. 

Tip: If you want to drop the background out of an imported picture, paint the unwanted portions of the 
picture with the transparency color.

All the PCS 
have white 
backgrounds 
when selected.

Using the eraser, 
another white region is 
created in the symbol.

The new white region 
is transparent to the 
background.

When the transparency 
color is changed, the white 
regions become visible.

When the transparency 
color is white, the back-
ground shows through 
the picture.

With the transpar-
ency set to bright 
green, none of the 
background is visible 
through the picture.

Painting the 
unwanted back-
ground with the 
transparency color.

This portion of the 
picture is now 
transparent.
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Pointer Tool

The Pointer Tool is used to select and move symbols, text, and buttons. When you select a symbol with the 
Pointer Tool, the paint tools palette will appear in place of the standard toolbar.

Double-click the Pointer Tool (or single-click the Pointer Tool if it is already selected) to make the standard 
toolbar reappear.

Pencil Tool

The Pencil Tool is used to draw on a selected symbol or picture. Use the Color Tool and/or Thickness Tool 
to set the color and line thickness before using the Pencil Tool.

Pointer Tool

Click the symbol to 
select it. Paint toolbar.

(dragged into 
a vertical 
orientation)

Use the Pencil Tool 
to draw on a selected 
symbol or picture.Pencil Tool
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Eraser Tool
The Eraser Tool is used to erase a portion of a selected symbol or picture. Use the Thickness Tool to 
change the thickness of the Eraser Tool. 

Color Tool
The Color Tool is used to display the Color palette. It changes the color used on the selected paint tool. 
If you select the Color Tool before selecting the Pencil Tool, Fill Tool, or Fill All Tool, the color you select 
will become the new transparency color. Please refer to the Transparency Color section. 

Tip: Use the eyedropper to set the color for the selected tool by clicking on any existing color on the board.

Eraser Tool

Use the Eraser Tool 
to erase a portion of 
a selected symbol or 
picture.

Select the desired 
color.

Identifies where the 
color will be applied.

Eyedropper

Color Tool
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Thickness Tool
The Thickness Tool is used to display the thickness palette. When using the paint tools, it only affects the 
Pencil Tool and Eraser Tool. 

Fill Tool

The Fill Tool is used to fill a selected portion of a symbol or picture with the chosen color. The selected 
color will flow through that portion of the symbol until is encounters bordering colors.

Note: To avoid accidentally changing the transparency color, select the Fill Tool before selecting a color 
with the color palette. (Refer to the Transparency Color for section more information.)

Thickness Tool

Eraser shown with a 
smaller thickness.

Eraser shown with a 
larger thickness.

Fill Tool

Position the tip of the paint 
pouring from the can over 
the portion of the symbol 
you want to color and click.

The selected portion of the 
symbol will be filled with the 
chosen color.

Color Tool
and palette
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Fill All Tool

The Fill All Tool is used to replace all instances of a color throughout a symbol with the chosen color. 

Note: To avoid accidentally changing the transparency color, select the Fill All Tool before selecting a color 
with the color palette. (Refer to the Transparency Color section more information.)

Invert Tool
The Invert Tool is used to invert the colors of a selected symbol or picture. This tool is only useful with 
black & white symbols.

Fill All Tool

Position the tip of the paint 
pouring from the can over 
the color to be replaced 
throughout the symbol.

All areas of the same 
color will be filled with 
the chosen color.

Color Tool
and palette

The symbol’s 
colors are 
reversed.

Invert Tool
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Flip Horizontal Tool and Flip Vertical Tool
The Flip Horizontal Tool and Flip Vertical Tool are used to flip a symbol along a desired axis. 

Tip: You can also right-click a symbol and choose a flipping option you want from the Flip submenu of the 
contextual menu.

Rotate Tool
The Rotate Tool is used to rotate a selected symbol or picture counterclockwise 90 degrees. 

Tip: You can also right-click a symbol and choose a rotate option you want from the Rotate submenu of 
the contextual menu.

Note: In most cases, the symbol will need to be repositioned in the button after it has been rotated.

Flip Vertical Tool

Flip Horizontal Tool The symbol is 
flipped horizontally.

First click Second click

Rotate Tool
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Chapter 8 
Adding New Symbols or Photos to the 
Symbol Finder

Chapter Overview 

You are not limited to the use of the Picture Communication Symbols (PCS) when creating boards. You can 
copy and paste, or import drawings, clip art, scanned photos, or digital pictures directly into the Symbol 
Finder. The graphics you add to the Symbol Finder will need to be named and categorized so you can 
quickly find them in the future.

The following topics will be covered: 
• Importing Saved Photos or Graphics

• Naming and Categorizing New Symbols

• Library Organization

• Dragging and Dropping Images onto the Board 
Background

• Dragging Images into the Symbol Finder

• Copying a New Symbol from a Button

• Deleting Your Custom Symbols

• Using Drag and Drop to Add Images

• Dragging and Dropping Images from a Web 
Browser

• Dragging Multiple Images into the Symbol 
Finder
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Web Images

Clip Art

Digital Pictures

A symbol created from other symbols within a 
button can be pasted into the Symbol Finder.

Pictures from a variety of sources can easily be 
imported into the Symbol Finder for future use.
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Importing Saved Photos or Graphics
If you intend to use photos or clip art on your boards, you should import them into the Symbol Finder where 
they can be easily accessed again and again. If you import a photo directly to a button, you will have to re-
import it or copy it from that button the next time you want to use that photo again.

1

With the Symbol Finder visible, choose File > 
Import > Picture.

Note: The File menu is active, even though 
it appears grayed out.

2

Locate and open your saved photo or clip art 
file.

You can import any files of the following 
formats: Bitmap, Enhanced Metafile, Windows 
Metafile, JPEG, GIF, PNG, PICT, and TIFF. 

3

The imported graphic will appear in the My 
Symbols dialog where you can name and 
categorize it. Please refer to the Naming and 
Categorizing New Symbols section in this 
chapter.

Choose the 
type of file to 
import.

The newly 
imported 
picture.

The new picture must be given a 
name and assigned to a category 
so you can find it later.
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Copying a New Symbol from a Button
While these instructions specifically refer to copying a new symbol from a button in the application, 
the basic steps apply if you are copying a new symbol from another application. 

Symbols you create or modify on a button can be 
copied to the Symbol Finder, saving them for future 
use.

1

Select the symbol you want to save. If it is made 
up of multiple symbols, be sure to select them 
all.

Note: Do not select the symbol’s text name.

2

Choose Edit > Copy.

You can also right click  any of the selected 
items and choose Copy Image from the 
contextual menu.

3

Select the Symbol Finder Tool, then choose 
Edit > Paste.

Note: When symbols are copied and pasted from a button, they are converted into a bitmap and will 
lose some image and print quality.

The symbol you pasted will appear in a dialog box where it can be named and categorized. Please 
follow the directions in the next section, Naming and Categorizing New Symbols, to complete this 
process.

A new symbol created 
by combining other 
symbols.

To select multiple 
symbols, hold down 
the Shift key while 
clicking each symbol.
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Naming and Categorizing New Symbols

1

Once a symbol is pasted into the Symbol Finder, you must assign it a name and a category.

Naming the Symbol

Type a name for your new symbol in the appropriate field, then click the Add a Name button. You can 
add alternate names to the symbol if appropriate.

Tip: If you are working in multiple languages, you can add symbol names in each language by 
choosing the languages from the First Choose Language drop-down list.

You can assign names 
in other languages.

Names assigned to 
the new symbol.

Type your symbol 
name here.

Click here to add your 
name to the arranged list.
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Deleting Your Custom Symbols

You may delete only those symbols or pictures you have added to the Symbol Finder. Custom symbols and 
pictures are saved in the Mine.pc2 library, which is saved in the My Symbols folder. You cannot delete any 
symbol that is part of the standard PCS that are included with Boardmaker or is not in a library saved in the 
My Symbols folder.

To delete the currently displayed symbol or picture, click in the symbol preview window and press Ctrl + X 
or choose Edit > Cut.

Refer to the Library Organization section later in this chapter for more information on the Mine.pc2 library.

2

Categorizing the Symbol

Click the Assign Categories button. In the categories window, check the category boxes that apply to 
the new symbol. 

Note: When you categorize a symbol, that categorization applies to all languages, not just the 
current language.

The new symbol 
pasted into the 
Symbol Finder.

Categories 
assigned to 
the symbol.

Click here to assign 
a category to the 
new symbol.
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Library Organization

The symbol libraries are saved in the Symbol Folder within the program’s folder. There are three separate 
folders for the symbol libraries: MJ Symbols, MJ Symbols - Additional, and My Symbols.

When symbols are added to the Symbol Finder, they are saved in the Mine.pc2 library which is stored in the 
My Symbols folder. You can share your symbol libraries with other Boardmaker users by moving your 
Mine.pc2 library to the My Symbols folder on another computer.

Note: You may need to change the name of the Mine.pc2 library you are moving so that you do not replace 
someone else’s custom symbols stored in their Mine.pc2 library. If your computer is set to not display 
file extensions, i.e. “.pc2,” you do not add this file extension when renaming a file.

Tip: By quitting the program, renaming the Mine.pc2 library, and temporarily moving it out of the My 
Symbols folder, you can create an additional custom library. This might make it easier for you to 
share a specific set of new symbols with others. By temporarily removing the renamed Mine.pc2 
library from the My Symbols folder, you will force the program to create a new Mine.pc2 library 
when you add your first new symbol. Once the new Mine.pc2 library is created, you can quit the 
program and move the original renamed Mine.pc2 library back into the My Symbols folder so you 
can add symbols to either of these custom libraries. Symbols are pasted into a custom library in front 
of the current symbol displayed in the Symbol Finder.

Applications

Boardmaker

Symbol Finder

MJ Symbols

MJ Symbols - Additional

My Symbols
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Using Drag and Drop to Add Images

Images saved on a computer or found in other programs can be easily imported onto a button or board by 
using the "Drag & Drop" process. A few examples of programs that support this feature include the My 
Computer browser, Windows Explorer, Internet Explorer, Firefox, Word, and Outlook.

1

With the program open and in the background, find the image on the computer using the Windows 
Explorer.
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2

Click and drag the image from the Windows Explorer over to the desired button and release.

Note: In the example above, the Windows Explorer is on top of the Boardmaker window. This 
makes it easy to drag and drop images. If the Windows Explorer (or whichever program is 
supplying the images) fills the screen or obscures the target button, drag the image over the 
Boardmaker product tab in the Windows Taskbar (as shown below). The program will move 
to the foreground and the image can then be dropped into the desired button.

The cursor will 
change to an arrow 
with a “+” when you 
are over a valid drop 
zone.
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3

Once the image is dropped, it will show on the face of the button. The filename of the image will 
appear as the button label. The position of the label (above or below the symbol) will be determined by 
the current Symbol Finder label position setting.

If the imported image has a label that is not appropriate, it can be changed using the Text Tool or it can 
be omitted during the "drag & drop" process by holding down the Alt key when the image is dropped 
on a button.

Tip: If you select the No Label option in the Symbol Finder dialog, labels will be automatically 
omitted during the "drag & drop" process, thus making it unnecessary to hold the Alt key.

Drag and drop an image and its 
file name will become its label.

Hold down the Alt key when an 
image is dropped and it will have 
no label.

The label position, 
font and size will 
match the current 
setting used in the 
Symbol Finder.
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Dragging and Dropping Images onto the Board 
Background

Images can also be imported to the background of a board by using the same “drag & drop” process 
described in the Using Drag and Drop to Add Images section. 

By default, when an image is dropped on a board’s background the application will attempt to scale the 
image to fill the background, unless there is already an image filling the background. The application will 
scale the image as best it can without distorting the image too much. Otherwise, it will preserve the image's 
aspect ratio. Any subsequent image dropped onto the board's background will be scaled as if it were being 
placed in a two-inch square button. The file name will appear as the image's label.

Tip: Hold down the Ctrl key when dropping an image on the background to prevent the image from being 
scaled to fill the background. 

Tip: Hold down the Ctrl + Alt keys to omit the label.

Tip: Hold down the Shift key when dropping an image on the background to use its native resolution. Hold 
down the Shift and Alt keys to use the native resolution and omit the label.

Note: Regardless of how an imported image is scaled, you can manually resize the image if necessary by 
dragging on its borders.

The first image dropped on the background of a 
board will be scaled to fill the board without dis-
torting the image.

Hold the Ctrl key when dropping an image on the 
background to scale it as if to fill a 2” x 2” button. 
The file name will be used as the label.
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Dragging and Dropping Images from a Web Browser

Using images from websites is a popular way to enhance a board or activity. The same "drag & drop" 
process described in the Using Drag and Drop to Add Images section can be used to grab images from most 
web browsers. As with saved images, the image name will be used as a label. Some website images (like the 
one in the example below) do not have image names. The program will automatically label these images as 
"unknown.” It may be difficult to position the browser window so that you can see both it and the button you 
are working with. If this is the case, you can follow the steps below to drag an image between windows.

Tip: Hold down the Alt key when dropping an image to omit the label.

Note: Web browsers are notorious for the widely varied ways they store and present images. Some may not 
support "drag & drop" methods. In that case, the solution is to Ctrl-click an image in the browser and 
choose Copy Image from the contextual menu. Then, in Boardmaker, Ctrl-click a button or the board 
background and choose Paste.

Drag and drop image 
from a web browser 
to a button.
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Dragging Images into the Symbol Finder

1

"Drag & drop" can also be used to add 
images to the Symbol Finder libraries. 

Open the Symbol Finder.

2

With Boardmaker open in the background, find the image to be added to the Symbol Finder.

With the Pointer Tool, click and drag the image over the symbol view area of the Symbol Finder and 
release.

Drag an image 
directly into the 
Symbol Finder to 
add it to the Mine 
library.
113



Chapter 8 - Adding New Symbols or Photos to the Symbol Finder
3

The My Symbols\Mine window will open. Give the image a name and assign it a category. 

Click OK when finished.

Note: If the image has a file name, it will automatically be used as the default name for the image.

Give the new image a name and 
assign it to a category. It will then 
be available in the Symbol 
Finder.
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Dragging Multiple Images into the Symbol Finder

Multiple images can also be added to the Symbol Finder at the same time using the “Drag & Drop” method. 
This is a convenient way to quickly add an entire folder of images. 

1

Select the desired images.

Note: Multiple files in a window can be 
selected by holding down the Shift  
key while clicking.

2

Note: Drag and drop the selected images into the Symbol Finder..

An Import Symbols window will open. Choose the proper naming and categorization options for the 
imported images. (Refer to the Naming and Categorizing New Symbols section for more specific 
instructions.)

Note: Individual, unwanted images that have been added to the Symbol Finder can be deleted later 
by choosing Edit > Cut (or pressing Ctrl+X). For more information, refer to Chapter 2 - 
Working with the Symbol Finder.

Symbol Name Options
Choose to automatically use the image 
file names as the names within the 
library, or opt to name each image 
individually.

Symbol Category Options
Choose to assign all the images to a 
single selected category, or opt to 
manually make category assignments 
to each image individually.
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Chapter 9 
Preparing Your Boards for Printing

Chapter Overview 
You can create both printed activities and interactive, on-screen activities. Boards created for each purpose 
may be sized and oriented differently. It is important to understand how boards are sized so that the 
appropriate steps can be taken to print the boards correctly.

The following topics will be covered:
• Printer Considerations
• Setting the Correct Paper and Board Size
• Print Quality

• Checking the Print Layout
• Using Print Preview
• Printing a Board on a Single Page

This board is a pre-made template 
that is used with the Tech II 32 
digitized communication device.  It 
is designed to be printed on legal 
paper oriented in landscape mode.

Page Break line indicates the board will not print 
on a single page with the current print settings
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Printer Considerations
There are hundreds of different types, makes, and models of printers. Because of this fact, a board that prints 
correctly on one computer-printer combination may need to be adjusted to print correctly on another.
Here are a few facts to keep in mind when preparing to print a board:

• A printer cannot use the entire piece of paper. There is typically a 1/4 to 1/2 inch margin along each 
edge of the paper that cannot be used.

• Because the unprintable margin size may vary on different printers, boards that contain content close 
to the margin may not fit to a single piece of paper on all printers.

• The maximum size board you can create is 60" x 60" (150cm x 150cm).

• The boards you create are very graphics intensive. They may take a long time to print, especially on 
older computers or printers.

• Most printing problems are related to your printer’s driver software. Make sure you are using the most 
current driver. (Updates are available on most manufacturers’ web sites.)

Checking the Print Layout

Before you print your board, make sure you look at it in Fit to Window view (default). You'll probably want 
to make sure that your board will fit on a single page using the current paper size and orientation. The printer 
page breaks will appear as dashed green lines.

If you see a page break running through the board, as shown below, the board does not have the correct 
paper size and/or orientation. This board will unnecessarily print on two pieces of paper. You will need to 
adjust the board’s size so that it fits entirely on a single page. Please refer to Setting the Correct Paper and 
Board Size in Chapter 1.

Page Break Line
This board spans 
two pieces of paper. 
An extra blank page 
will print. The board 
size needs to be 
smaller.

Shown in Fit To 
Window view
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To print larger boards, you may need multiple pieces of paper which have to be trimmed and taped together.

Page Break Line
This board needs to 
be printed on two 
pieces of paper. 
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Setting the Correct Paper and Board Size
 

1

The pre-made templates included with the program are sized and oriented to print correctly from most 
printers. However, the amount of a piece of paper a printer can actually use can vary widely between 
printers. It may be necessary to adjust the paper settings or the board size to accommodate your printer 
and paper selection.

Determine the paper size and orientation necessary for your board.

Note: Each template board will specify the correct paper size and orientation in the upper left 
corner of the board.
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2

Setting the Printer Paper Size and Orientation 

Choose File > Print Setup. Change the Paper Size and Orientation settings as needed. Click the 
Print Setup button if the current printer page settings are not correct. Click OK when finished.

3

Make sure the correct printer is selected, then choose the correct paper size and orientation for your 
board. Click OK when finished.
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4

Setting the Board Size

Typically, a board is designed to fit on a single piece of paper. Click on the Use Printer Page button. 
This will set the board’s size to match the page size, which is determined by the printer settings. Be 
sure to check that all buttons on the board actually fit within the new board dimensions by choosing 
File > Print Preview.

If you are making a large custom board, you may enter appropriate dimensions up to the numbers 
listed in the Maximum column, which correspond to three pages across by two pages down.

Tip: If you are going to create many boards that are the same size, click on the Remember Board 
Settings and/or Remember Printer Orientation button(s) to use the current settings for all 
new boards you create.
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Using Print Preview

1

It is a good idea to get in the habit of checking your 
boards with Print Preview before printing. The Print 
Preview will allow you to catch any sizing or paper 
orientation problems before you actually print the 
board.

Choose File > Print Preview.

2

In this example, you can see it will be necessary after printing the board to trim some paper from each 
page so the overlay can be spliced together.

Tip: If only a very small portion of the board prints on another page, you may find it difficult to 
splice the board together. Try changing the page orientation or using smaller paper to more 
evenly divide the board between the pages.

If the board looks correct on the Print Preview, click the Print button to print the board. Click the 
Close button if you need to make changes to the board.

Prints the board.

Steps through 
multi-page Boards.

Toggles One Page 
or Two Page view.

Zooms In or Out.

Closes the Print 
Preview window.
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Print Quality

Symbol Formats Quality

The PCS symbols available through the Symbol Finder are stored in a Windows metafile format. This format 
makes the printed symbols look smooth and crisp at any size you need. This will not necessarily be the case 
for a symbol or text that is imported or copied from another program or source. 

Note: Editing a metafile symbol using the built-in paint tools will convert that symbol into a bitmap which 
will degrade its print quality. This effect will be minimized if you edit a larger version of the picture 
and then manually shrink it down to fit your button.

Printer Image Quality 

• Standard - Best Performance - This option provides good quality with the fastest print times.

• High - Better Quality Text - This option takes longer but produces smoother looking text.

• Use Printer Resolution - This option matches the program’s output resolution to that of your printer’s 
default setting. This option can take up to four times longer to print and is not recommended on high dpi 
(600+) printers unless you have trouble printing using the other settings.
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Printing a Board on a Single Page

Some boards you create may be designed to span multiple pages or fit on larger paper sizes. You can choose 
File > Print Board on Single Page to automatically scale the board to print on a single piece of paper. 
Choose File > Print Setup to change the paper size and orientation. Use the Properties button in the Print 
dialog to temporarily change the paper size and print orientation for the board you are printing. 

Click the Properties button to temporarily 
change the paper size and print orientation.
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Chapter 10 
Making a Board Set

Chapter Overview 

In this chapter, you will learn how to create a dynamic screen communication board set. You will start by 
exploring the sample boards provided with the program. This will help familiarize you with board 
organization and the program’s features. Next, you will begin to plan your board set and build the user’s 
main board.

The following topics will be covered:
• Design Considerations

• Creating a Main Board

• Mapping Out the Boards and Links

• Creating Separate Folders for Board Organization

Each button is linked to 
a board or set of 
boards that address the 
pictured topic.

The main board is the 
gateway to the other 
boards.
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Design Considerations

When making a board set, a little planning will go a long way. When you are planning activities, here are a 
few of the major design questions you will need to answer.

• What is the goal of the activity (reading, verb tensing, story telling, etc.)?

• How many boards will be needed (number of pages in a story, etc.)?

• How many buttons will be necessary on each board?

• Do you want buttons with only text or also symbols and/or photos?

• Do you want some kind of feedback for a correct answer?  An incorrect answer?

The answer to each of these questions will have a direct impact on how you will create and link the boards 
together. It may be helpful to map it out on a piece of paper before designing the boards.
130



Boardmaker Software Family v6 User’s Guide
Mapping Out the Boards and Links

Once you have your activities planned, you are ready to work out the content of each board and how each 
board will be linked together.

Typically, boards will be organized by topic or activity. You will start with a main board that should have a 
button for each of the topics or activities that you would like to be included in this set of boards. Linked to 
each topic button you will have a topic branch which might be a single board or a group of boards. The 
number of boards you use to develop a specific topic will vary from one activity to the next.

Try to create a board layout diagram like the one shown below. This will help you  the arrangement of the 
topics and activities you want to cover. If you have a large list of topics and activities, you might try 
diagramming topic branches off the main board. This diagram will be helpful for future planning and also 
serves as a paper backup of your board set’s arrangement.
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Creating a Main Board
The first board you should create is the main board, which is displayed automatically when the program 
starts. This is the board they will start with whenever they use the program. It should contain a button for 
each of the major communication topics you identified.

Every other board you create for this user will typically have a button linking it back to this main board. This 
will allow the user to easily move between boards and switch topics.

Creating Separate Folders for Board Organization

The main board you created in the previous section was saved in the My Boards folder, which is the default 
location for saving boards. If you are creating boards for different users or activities, you may want to create 
separate folders within the My Boards folder to help you keep your boards organized. Organization is 
especially important because all boards that will eventually be linked together must be saved in the same 
folder. 

Each board you create 
should have a button 
linking it back to the 
“Main” board.
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1

If you create boards for a specific user, you 
should create a separate folder where those 
boards will be saved.

When you save the first board for a new user, 
click the Create Folder button. Windows will 
create a“New Folder.”

Note: Make sure the folder you create is 
within the My Boards folder.

2

Type in a new name for the folder, then press 
the Enter key on your keyboard to save the 
folder’s new name. Click the Open button to 
open the folder.

Now you can click the Save button to save your 
board in the new folder.

Note: Until you quit the program or save a 
board in another folder, your new folder 
will be the default location for saving 
boards.

My Documents

My Boards

Butterfly Unit

Reading Activities

Math Activities

An example of how 
folders may be used 
to organize boards.

Default board 
storage location.

Creating a new folder 
within the My Boards 
folder.
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Chapter 11 
Assigning Basic Button Actions

Chapter Overview 

This chapter will introduce you to assigning basic actions to your buttons.

The following topics will be covered:

• Button Actions at a Glance

• Basic Button Actions

• Making a Button Play a Recorded Message

• Giving a Button a Spoken Preview

• Adding a Preview Display

• Editing a Button’s Assigned Actions

• Action Categories

• Making a Button Speak

• Making a Button Play a Saved Sound

• Giving a Button a Recorded Preview

• Changing a Button’s Text Preview

Assign Speak 
actions to use 
the synthesized 
voice.

Add a Preview 
Display and/or 
the Text Preview 
action to provide 
a text cue to the 
user.

Assign Play 
Recording 
actions to play 
saved sound 
files (.wav).
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Button Actions at a Glance

You can assign actions to your buttons by double-clicking on them. The Button Actions dialog (shown 
below) will appear. You can assign multiple actions to each button. There are over 135 actions to choose 
from. Refer to Appendix B - Button Actions for a complete listing.

Assigned Actions
Lists the actions assigned 
to the button. Drag the 
actions to change their 
order.

Action Details
Shows what an action 
will say, type, or do. 
Double-click the action 
detail to edit the action.

Action Menu
Click an action to assign 
it to the button. The 
actions listed belong to a 
specific action category.

Dynamic Help Window
Displays helpful informa-
tion about the item under 
the mouse pointer.

Action Categories
Select the category of 
actions that will appear in 
the Action Menu.

Play/Delete Buttons
Used to preview or 
delete the selected 
action.
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Action Categories
There are over 135 button actions to choose from. To help you locate a specific button action, they are 
grouped into categories by function. Selecting the appropriate tab in the Button Actions Categories dialog 
will display the actions in that category in the Action Menu list.

•Basics - Most commonly used actions, such as Speak Message, Type Message, Change Board, etc.

•Messages - Actions that control the function of a Message Display.

•Board Change - Actions that link buttons to other boards or PopUps.

•Text & Cursor - Actions that perform cursor movements and text selections.

•Message Files - Actions that open and save text and picture documents.

•Settings - Actions that allow a user to change access and preference settings.

•Variables - Actions that are used to create conditional button responses, such as If, Else, Otherwise, etc.

•Quick Actions - Actions used to create buttons that can be edited in Use mode.

•Cool Stuff - Assorted useful actions, such as Random, Launch Application, and Set Picture.
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Basic Button Actions

The Basics category contains the most commonly used button actions. All of the actions in this list will be 
covered in this chapter with the exception of Change Board and Picture Button, which will be covered in 
later chapters.

•Speak Message - Makes the button speak the message you enter using a synthesized computer voice.

•Read with Highlighting - Reads and highlights the symbols and text on the face of a symbolate button. 
(Only appears in the action list for symbolate buttons.)

•Type Message - Places a message you enter into the Message Display. You must have a Message Display 
on your board to use this button action.

•Play Recorded Message - Plays a message you record or a selected saved sound.

•Change Board - Displays the board you select.

•Change Board Back- Steps the user through the boards they were previously using.

•Text Preview - Displays a text cue for the button’s function. You must have a Preview Display on your 
board to use this button action.

•Spoken Preview - Plays a spoken (synthesized voice) cue for the button’s function.

•Recorded Preview - Plays a recorded cue for the button’s function.

•Clear Message Display - Clears the contents of the Message Display, if present on the board.

•Picture Button - Places the symbol and/or graphic on the face of a button into the Message Display. You 
will use two associated actions, Picture Speech and Picture Sound, with this action. You must have a 
Message Display on your board to use this button action.
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Making a Button Speak

1

Double-click the button you want to speak. 
The Button Actions dialog will appear.

The button’s border will appear as a dashed 
line when it is selected. 

2

Select Speak Message in the Action Menu 
list.

3

In the dialog box, enter the message you 
want this button to speak.

Tip: You can have the button 
automatically speak the text on the 
button face by clicking on the Use 
Button Text option.You can listen to 
your message by clicking on the 
Speak button.

Click the OK button or press the Enter key 
on the keyboard when finished.
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Making a Button Play a Recorded Message

4

The Speak Message action and its message now appear in the Assigned Actions and Action Details 
lists. Click OK or press Return when finished.

5

Put the program in Use mode by choosing 
Dynamic Boards > Use or by pressing Ctrl 
+ U. Try clicking on the buttons that have 
been assigned speak actions.

When you are finished, put the program 
back in Design mode by pressing the Esc 
key or pressing Ctrl +  D.

1
Double-click the button you want to play a 
recorded message. The Button Actions 
dialog will appear.

2

Select Play Recorded Message in the 
Action Menu list.

Note: You must have a sound card with a 
microphone or a built-in 
microphone to use this feature.
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3

Click the Record a New Sound button.

4

Click the Record button and speak into the 
microphone “Bobby wants.”

Click the Stop button (previously the 
Record button) to stop recording.

Click the OK button when you are finished 
recording. A dialog box will appear asking 
for a description of the recorded message.

5
Enter a descriptive name for your recorded 
sound that will appear in the Assigned 
Actions list, then click the OK button.

6
The Play Recorded Message action and 
the recording name now appear in the 
Assigned Actions list.

Click the OK button when finished.
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Making a Button Play a Saved Sound

1
Double-click the button you want to play a 
saved sound.

Select Play Recorded Message in the 
Action Menu list.

2

Click the Select Sound from Computer button. A navigation window will appear.

3

Browse to any .wav sound you have saved 
on your computer.

Note: Although rare, some .wav files 
contain compressed audio in 
unsupported formats.  Although 
ending in .wav, these types of files 
are actually in a different format 
and will not play.

4
Type a descriptive name for the sound you 
have selected and click OK.

The descriptive name will help you identify 
the sound later.

Click here to attach a 
sound used on another 
board.

Click here to attach a 
sound file saved on 
your computer or disk.

Click here to attach 
one of the sounds 
provided in the MJ 
Sounds library.
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5
The Play Recorded Message action and 
the sound file name now appear in the 
Assigned Actions list.

6
You can listen to the sound by selecting the Play Recorded Message action then clicking the Play but-
ton.

Tip:  The Play button can also be used to preview any selected button actions that speak or play a 
recording.

Click OK when you are finished editing the button.
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Giving a Button a Spoken Preview

1

The Spoken Preview action will cause a button to speak a message whenever the mouse cursor moves 
over the button or that button is highlighted while using one of the scanning methods of access. A 
preview message is commonly used to provide an audio cue for individuals with visual challenges.

Double-click the button you want to assign a Spoken Preview to. The Button Actions dialog will 
appear.

2

Select Spoken Preview in the Action Menu 
list.

3

In the dialog that appears, type the preview 
message you want to hear.

Click OK when finished.

Note: A preview message should be only one 
or two words. Long previews can slow 
scanning or button access.

4

The Spoken Preview action and the preview 
message now appear in the Assigned Actions 
list.

Click OK when finished.

Note: For information on setting the preview volume level or completely disabling all preview 
messages, refer to Voice and Sound Volume in Chapter 19.
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Giving a Button a Recorded Preview

As an alternative to the synthesized speech of the Spoken Preview action, the Recorded Preview action 
will cause a button to play a recorded message whenever the mouse cursor moves over the button or that 
button is highlighted while using one of the scanning methods of access. A preview message is commonly 
used to provide an audio cue for individuals with visual challenges.

1

Double-click the button you want to assign a 
Recorded Preview to. The Button Actions dialog 
will appear.

Note: You must have a sound card with a 
microphone or a built-in microphone to 
use this feature.

Select Recorded Preview in the Action Menu 
list.

2

Click the Record a New Sound  button to use a microphone to record the preview.

Click the Select Sound from Computer button to use a pre-recorded sound. If you choose this option, 
a navigation window will appear allowing you to locate and import the desired sound.

Note: A preview message should be only one or two words. Long previews can slow scanning and 
button access.

You can record a preview 
sound using a microphone 
or select (import) a saved 
sound file (.wav).
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3

If you select the Record a New Sound option, the 
Record Sound box will appear.

Click the Record button and speak the preview 
message into the microphone. 

Click the Stop button (previously the Record 
button) to stop recording.

Click OK when you are finished recording.

4
Type a descriptive name for your recorded 
preview, then click OK.

5

The Recorded Preview action and the recording 
name now appear in the Assigned Actions list.

Note: Click OK when you are finished editing 
the button. For information on setting the 
preview volume level or completely 
disabling all preview messages, refer to 
Voice and Sound Volume in Chapter 19.
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Adding a Preview Display

The Preview Display will automatically display the messages or actions assigned to a button whenever the 
mouse cursor moves over the button or that button is highlighted while using one of the scanning methods of 
access.

1

Choose Dynamic Buttons > Preview 
Display.

The Preview Display will appear toward 
the top of the board.

2

Reposition the Preview Display then drag its border to change its size.

3

As you pass the cursor over your buttons 
you can preview the text previews. The 
Preview Display functions in the Design 
mode as well as the Use mode.

Note: The size and color of the display 
text can be changed. Refer to 
Adding a Message Display and 
Setting Its Appearance in Chapter 
13.
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Changing a Button’s Text Preview

1

If you don’t like the preview text that appears 
automatically, you can assign your own 
preview text using the Text Preview action.

Double-click the desired button. The Button 
Actions dialog will appear. 

Select Text Preview in the Action Menu list.

2

Type the text preview message for the button 
in the dialog. Then click OK.

3

The Text Preview action and the text preview 
message now appear in the Assigned Actions 
list.

Click the OK button when you are finished 
editing the button.
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Editing a Button’s Assigned Actions

In the process of creating a board, you will probably find it necessary to edit the actions assigned to your 
buttons. The actions in a button’s Assigned Actions list can easily be edited, added to, deleted, or 
rearranged.

1

Editing an Assigned Action

To edit an action on a button, double-
click the button, and then double-click in 
the Action Details list for that action. In 
this case, double-click on “math class” 
for the Speak Message action.

2

The appropriate dialog for the action 
will appear, allowing you to make the 
necessary changes.

Note: Many actions perform a set 
function and cannot be edited.

3

Adding an Action to the List

Select the action in the Assigned 
Actions list that you want to precede the 
new action. Assign the new action to the 
button.

There is no limit to the number of 
actions a button can be assigned.

Any action added to a button will appear 
after the selected action. To add an 
action in a specific position, select the 
action that will precede it.

Any action(s) you add will appear 
after the highlighted action. Typically, 
this is the last action in the list.
149



Chapter 11 - Assigning Basic Button Actions
4

Rearranging the Assigned Actions

To change the order of the Assigned 
Actions list, you can click and drag an 
action into a different location.

Note: Action order can be very 
important. For example, all 
board change actions must be 
last in the list.

5

Deleting an Assigned Action

To delete an action, select it in the 
Assigned Actions list, then click the 
Delete button.

Tip: If you need to delete a series of 
actions, select the topmost 
action and you can repeatedly 
click the Delete button to 
remove the actions.

Click and drag actions to change 
their order in the list.
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Chapter 12 
Linking Boards Together

Chapter Overview 

With Boardmaker Plus! and the Boardmaker-Speaking Dynamically Pro allow you to dynamically link 
boards together. This allows a user to easily navigate from one board to the next as needed to support the 
current activity or branch off to a different activity. In this chapter, you will learn the basic methods of 
linking boards together to create an activity or navigable set of activities.

The following topics will be covered:

• Linking Boards Together
• Adding a Button Link to the Previous Board
• Navigating Board Links in the Design Mode

• Adding a Button Link to the Main Board
• Linking Specific Boards Together
• Board Change Indicators

The "go back" button 
automatically returns 
the user to the 
previously used board.

The "Home" button 
returns the user to 
the main board.

“Recipe” Topic Branch

Buttons can be linked 
to specific boards that 
provide additional 
topic choices.
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Linking Boards Together

Once a main/topic board has been created, the next step is to create the supporting boards for a specific topic 
branch, e.g., recipe boards. Usually, you want to start by building the boards at the end of a topic branch first. 
The general sequence for building a topic branch is outlined in the steps below. Following this building 
sequence will allow you to make the necessary board links as each board is created.

1

General Building Sequence

Start by building the boards at the end of the topic 
branch first. These boards can then be linked directly 
to the main board.

Note: Every board you create should have a button 
that links it to the main board.

2

Create any additional boards, working back up the 
branch toward the main board.

In the example pictured, the “Recipe 1” board is 
created next. This board can then be linked to the 
“Recipe 2,” “Food Review,” and “Main” boards.

Note: Every board you create should have a button 
assigned the Change Board Back action to 
aid in navigation.

3

Once the boards in a topic branch are linked together, 
the appropriate button on the “Main” board can be 
linked to the completed branch.

"Recipe" topic branch is linked to the 
Recipe button on the Main board.

Recipe 2 Board

Main Board

Food Review 
Board

You would create and 
link the boards at the 
end first, then work 
toward the main 
board.

Recipe 1 Board

Food Review 
Board

Recipe 2 
Board

Recipe 1
Board

Main Board 
(Recipe button)

Recipe 2 
Board

Food Review 
Board

Recipe 1 
Board

Main Board 
(Recipe button)

Recipe 1 
Board
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Adding a Button Link to the Main Board

All the boards you create should have a link to the main board. This prevents a user from navigating down a 
topic branch and then getting stuck at the end.

By creating the boards at the end of a topic branch first, the only direct link you need to add is to the main 
board, which should already exist. You cannot create a link to a board that doesn’t exist. So, if you 
started by creating the “Recipe 1” board, you couldn’t create a link to the “Recipe 2” board until after that 
board was created.

1

You should create and position the Main 
button in the same location on every board.

Double-click the Main button.

Select Change Board in the Action Menu 
list.

“Recipe” Topic Branch

Create and link the 
last board in the 
recipe branch first.
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2

Click on your main board in the list of boards, 
then click OK.

Note: Only boards saved in the same folder 
as the current board will appear in the 
list.

3

The Change Board action and the linked 
board now appear in the Assigned Actions 
list.

Click the OK button when you are finished 
editing the button.
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Adding a Button Link to the Previous Board
Adding a Change Board Back action to a button on a board provides the user with an easy way to 
automatically return to the previous board - much like one would use the "Back" button on a web browser. 
The application keeps track of the user's board history, which means the user can return not just to the 
previous board, but back many boards if necessary. There is also a complementary Change Board Forward 
action (Board Change category) that will step forward through the board history if needed.

1

You should create and position the “go back” 
button in the same location on every board.

Double-click the “go back” button.

Select Change Board Back in the Action Menu 
list.

2
The Change Board Back action appears in the 
Assigned Actions list.

Click OK when finished.

“Recipe” Topic Branch

The "go back" button 
is an automatic link to 
the previous board.
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Linking Specific Boards Together
Having created and linked the board at the end of the topic branch, work toward the main board. For 
example, if you’ve created a story you’ll want to link page 2 to page 1 and so on.

1
Double-click the button that will link to the next 
board.

Select Change Board in the Action Menu list.

2

A list of boards that have been saved in the 
same folder as the one you’re working on will 
appear. Double-click the name of the board you 
want to link to.

If the board is not listed, make sure it is in the 
same folder as the one you’re currently working 
on.

3
The Change Board action and the linked board 
now appear in the Assigned Actions list.

Click OK when finished.

“Story” Topic Branch

The "Next Page" 
button will be linked to 
the "Page 2" board.

The "Story" button 
will be linked to the 
"Page 1" board.
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Navigating Board Links in the Design Mode

In the Design mode, it is possible to quickly open a board that is linked to a specific button. Simply right-
click the button and choose Open Board: <board name> from the contextual menu. The Open Board 
option can be a real time-saver if you are editing a large collection of linked boards.

Note: If a button has more than one Change Board or Go to Popup action (which is possible if the board 
change actions are inside If or Random action blocks), a separate Open Board option will be 
available for each link (up to six).

Actions assigned to the “breakfast” button.
In this example, 
selecting the Open 
Board option will 
open the linked 
“breakfast” board.
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Board Change Indicators

By default, the program will mark each button that is assigned a board change action with a small green 
arrow in the bottom right corner. This is a Board Change Indicator and it acts as a visual cue to the user 
that selecting a specific button will make another board appear.

The indicators can be turned on and off within the Dynamic Boards menu. You may also assign another 
graphic to act as the Board Change Indicator.

Note: In order to use a Custom Indicator, you must have a 16 by 16 pixel bitmap graphic named “Custom 
Indicator” saved in the SDP Externals folder. (This folder can usually be found in the C:\Program 
Files\Boardmaker with SD Pro folder.)
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Chapter 13 
Using a Message Display with Text

Chapter Overview 

On the most basic level, the Message Display allows text messages entered by button selections or keyboard 
input to be displayed, created, and/or printed. In this chapter you will learn how to incorporate a Message 
Display to create a simple picture-to-text sentence building board. There are a variety of button actions such 
as speak, print, clear, etc. that allow you to control the Message Display.

The following topics will be covered:

• Adding a Message Display and Setting Its 
Appearance

• Adding Simple Message Display Controls
• Changing the Message Display’s Settings

• Making a Button Type a Text Message
• Message Display Actions

Adding a Message Display allows 
the user to create text messages.

Buttons using a 
Type Message 
action can add a 
letter, word, or 
phrase to the 
Message Display.

There are a 
variety of 
button actions 
designed to 
control the 
Message 
Display.
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Adding a Message Display and Setting Its Appearance

1

Choose Dynamic Buttons > Message 
Display.

2

You can reposition and resize the Message 
Display according to your needs. 

Click and drag the Message Display to the 
appropriate position, then drag its border to 
change its size.

3

Changing the Text Size

If the display text is too small or too large, you 
can change it to the size you want.

With the Message Display selected, you can 
set the font, style, and size using the Text 
menu, or Ctrl right-click the Message Display 
and choose the option you need.

4

Changing the Text and Display Colors

If desired, you can change the color of the text 
or the Message Display itself.

With the Message Display selected, click the 
Color Tool.

In the Color Palette click on Button, Border, 
or Text, then click the desired color.

NOTE:You can also change the color of the 
Message Display text by right-
clicking the Message Display and 
choosing Font Color from the 
contextual menu.

Color Tool
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Making a Button Type a Text Message

1
Double-click on a button that you want to 
type a message in the Message Display.

2

Select Type Message in the Action Menu 
list.

3

In the dialog, type the text to appear in the 
Message Display.

Tip: Add a space after the text to keep it 
from being combined with any 
additional text added to the Message 
Display.

4
The Type Message action and the text 
message now appear in the Assigned 
Actions list.

Click the OK button when finished.

This button will 
type the "I" in the 
Message Display.
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Adding Simple Message Display Controls

1

Making the Message Display Speak

Double-click the button you want to use to 
speak the contents of the Message Display.

2

Select the Messages tab then select the Say 
Message action in the Action Menu.

3

The Say Message action now appears in the 
Assigned Actions list. This action will make 
the Message Display speak its contents when 
this button is selected.

Click the OK button when finished.

4

Removing the Last Message

Double-click the button you want to use to 
remove the last message from the Message 
Display.

Select the Messages tab, then select the 
Remove Last Message action in the Action 
Menu..

This button 
will make the 
display 
speak.

This button 
will remove 
the last word 
entered.

Viewing actions that control 
the Message Display.
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Message Display Actions

The Messages tab contains button actions used to control the various functions of a Message Display.

• Type Message - Places a message you enter into the Message Display.

• Say Message - Speaks the contents of the Message Display.

• Say Selection - Speaks any selected text in the Message Display.

• Delete - Deletes any selected text, or if no text is selected, deletes the character before the cursor.

• Remove Last Message - Removes the last text message entered into the display by a button or any text 
typed with the keyboard since the last button selection.

• Clear Message Display - Clears the contents of the Message Display.

• Select All - Selects the entire contents of the Message Display.

• Cut - Cuts the selected text from the Message Display and places it on the clipboard.

• Copy - Copies the selected text from the Message Display to the clipboard.

• Paste - Pastes text from the clipboard into the Message Display.

• Print Message - Prints the contents of the Message Display.

• Capitalize Next - Capitalizes the next character entered into the Message Display.

• Picture Button - Makes a button add its symbol to the Message Display.

• Picture Speech - Assigns the message to be spoken by a Picture button.

• Picture Sound - Assigns the recorded message to be played by a Picture button.

• Caps On - Turns on Automatic Capitalization. All characters entered will be in upper case.

• Caps Off - Turns off Automatic Capitalization.

• Expand Abbreviation - Expands defined word/phrase abbreviations.

5

The Remove Last Message action now 
appears in the Assigned Actions list. This 
action causes the button, when selected, to 
remove the last text message entered in the 
Message Display. The button will behave as a 
backspace key if you click on it again.

Click the OK button when finished.
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Changing the Message Display’s Settings

The Message Display has a variety of built-in settings that can be used to change its look and behavior. 
Double-clicking on a Message Display will open the Message Display Settings dialog shown below.

Note: The Message Display settings apply only to the display on the current board.

Setting Notes:
• Saying the Message - Selecting all three options will make the display speak the message, speak the 

message again while highlighting each word, and speak the message one final time. Typically, only 
one Say Message is checked when used with Say with Highlighting.

• The Delay option is used to specify a pause between each spoken word when using Say with 
Highlighting.

• When Selectable Display is checked you cannot use the mouse to edit the contents of the display. The 
display text can only be edited by using buttons which are assigned text editing actions. The Cancel 
Speech and Pause Speech actions (Cool Stuff tab) will not work when this option is selected.

Selecting the contents of the 
display after it is made to 
speak will cause the text 
entered to replace the 
display's current contents.

Click here to change the 
selection highlight color.

These settings are used with 
pictures and will be covered 
later.

Select either or both of 
these options to make the 
display speak as text is 
being entered.

Select one or all of these 
options to set how and in 
what order the display 
will speak.

Select this option to make the display 
selectable like a button. The display 
will speak when selected.
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Chapter 14 
Using a Message Display with Pictures

Chapter Overview 

This chapter will show you how to create picture sentences rather than text sentences. A Message Display 
can accept picture input from buttons on your board in addition to text. Pictures placed in a Message Display 
can be edited, spoken, printed, and saved just like text.

The following topics will be covered:

• Placing a Picture into the Message Display

• Uniform Line Spacing - Pictures and Text

Picture Buttons 
copy the picture 
and text on 
their face into 
the Message 
Display.

The Message Display accepts pictures 
as well as text from a button.
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Placing a Picture into the Message Display

1
Double-click the button whose picture you want 
placed in the Message Display.

Note: A picture of the button will then be 
placed in the Message Display.

2

Select Picture Button in the Action Menu.

Two actions will automatically appear in the 
Assigned Actions list:

• Picture Button tells the button to place its 
picture in the Message Display.

• Picture Speech makes the button speak when 
selected and when the Message Display is 
spoken.

Note: You can create a button with the Picture Button and Picture Speech actions already assigned, 
by selecting Dynamic Buttons > Picture.

Note: The Picture Speech and Picture Sound (plays a recording or sound) can be assigned 
separately and are found in the Messages category. The Picture Button action must precede 
any Picture Speech or Picture Sound action.

Note: The Picture Speech action is similar to the Speak Message action in that both make a button 
speak when it is selected. However, the Picture Speech action is required to make a button’s 
picture speak from within a Message Display. The Picture Sound action behaves in the same 
fashion.
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3

Double-click the Picture Speech action to edit 
it.

In the Enter Text dialog that appears, type the 
word or text you want the button to speak, then 
click OK.

If you want the button to speak the text on the 
face of the button, select the Use Button Text 
option.

4 Action Options

• Hide Text (Picture Button) - When this option is selected, any editable text on the face of the button 
will not be placed in the Message Display along with the button’s picture.

• Suppress (Picture Speech/Sound) - When this option is selected, the action(s) will not be per-
formed when the button is selected. The Picture Speech/Sound action(s) will be performed only 
when the Message Display is spoken.

5

Setting the Picture Size in the Message Display

The Message Display will scale pictures sent by any size picture button to a uniform size. The default 
size is 1 inch.

Double-click the Message Display to edit its settings. To change the size of the picture to be placed into 
the Message Display, click in the Picture Size box and type a picture size.
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Uniform Line Spacing - Pictures and Text

The Message Display will accept both text and pictures from the buttons on your boards. If you plan on 
using both, it is recommended that you select the Uniform Line Spacing option in the Message Display 
Settings dialog. This feature will make all lines in the Message Display the same height, allowing space for 
either pictures or text.
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Chapter 15 
“Use Button Text” Boards

Chapter Overview 

In this chapter you will learn about the special Use Button Text option that allows a button to speak and/or 
type whatever text is on its face. With this option selected, you can quickly create a board whose buttons will 
speak or type any text placed on them. This feature makes it possible to create pre-programmed template 
activities that can be customized quickly by changing the symbols and labels on the buttons. 

A collection of template boards are provided that take advantage of the Use Button Text option. You can use 
one of the templates to quickly create a board for spoken communication or writing with text or pictures.

The following topics will be covered:

• Creating a “Use Button Text” Template Board

• Actions that Can Use Button Text

A template board that makes use 
of the Use Button Text option.The Picture Buttons on 

this board will speak 
whatever text is on the 
button face.

All of the buttons are 
already assigned the 
necessary Picture But-
ton actions set to use 
the button text. Simply 
add the desired sym-
bols (with text) and the 
board is ready to use.

Later, if you change 
the symbol and text, 
the button will speak 
the new text.
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Creating a “Use Button Text” Template Board
The key to this method of board construction is to assign the necessary actions and appearance to the first 
button you create - the template button. When you then use the Button Sprayer Tool to create a grid of 
buttons, each button in the grid will have the same assigned actions and appearance as the template button. 
This saves you from having to assign actions to each button individually.

1

Create a new board with a message display and 
then make one button that will become your 
template button. 

Double-click the blank (template) button. 

Select Picture Button in the Action Menu list. 
The three picture button actions will appear in the 
Assigned Actions list.

OR

Another option of creating a Picture button is to 
choose Dynamic Buttons > Picture. This will 
create a 1-inch square button with the two picture 
button actions already assigned to it.

Double-click the Picture Button item.

2

Double-click the Picture Speech action.

In the Enter Text dialog, click the Use Button Text option. This will cause the Picture button to speak 
any editable text that is placed on the face of the button. If you were to change the text and picture on 
the button’s face at a later time, you would not need to change the Picture Speech message; the Use 
Button Text option does it for you.

Click OK when finished.

Select Use Button Text. 
This makes the button 
speak any text on the 
button face.
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3

Under Action Details you will see “Use Button Text” as the description for the Picture Speech action. 
This lets you know that the button is set to speak the text on the button face.

Click the Suppress box to uncheck this option and make the button speak when selected.

4

In this example, we will also make the button 
provide an audible cue using the text on the button 
face.

Select Spoken Preview in the Action Menu list.

As in step 3, select the Use Button Text option.

Click OK when finished.

5
Under Action Details, you will see Use Button Text as the description for the Spoken Preview action. 
This lets you know that the button is set to preview the text on the button face.

You are finished assigning actions to this template button. Click OK when finished.

6

Now that actions have been assigned to the 
template button, make any appearance changes to 
the button.

For this example, click the Shadow Tool and turn 
on button shadows.

Add a Spoken Preview that speaks 
the text on the button face.

Set the 
appearance for 
your template 
button.

Turn on button 
shadows.
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7

Once you have the template button completed, 
you can use the Button Sprayer Tool to drag out 
a grid of picture buttons. 

Double-click on any one of the new buttons to 
verify that it has the same actions you assigned to 
the template button. Click OK when finished.

8
You can then move the buttons around according to the needs of the activity being created. The buttons 
are now ready to accept pictures and be used.

Note: Make sure you have a Message Display on your board if you’re going to use Picture Buttons. 
See Chapter 14 - Using a Message Display with Pictures for more information about Message 
Displays.

Note: You must have text on the buttons if you want them to speak or preview.

Note: At this point, you can turn this board into a locked template board that can be accessed using 
the Open a template button. This will allow you to use the blank template again and again to 
make different activities. For information on saving a board as a locked template, refer to 
Appendix E - Creating a Template Board.
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Actions that Can Use Button Text

The Use Button Text option is available with the following actions:

• Speak Message

• Type Message

• Text Preview

• Spoken Preview

• Picture Speech

This window is common 
to all the above actions.

With the Type Message action, 
you are provided with an 
additional option to Add a 
Space after the Text. Typically, 
you will leave this selected. You 
would deselect this option if you 
are working with individual 
letters that will be combined to 
form words, for example when 
creating a keyboard or spelling 
activity.
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Chapter 16 
Working with Movable Buttons

Chapter Overview 

Movable buttons allow you to create on-screen activities in which the position of buttons can be 
manipulated. Buttons no longer need to be static objects; instead, they can be dragged around the screen and 
dropped on other buttons to trigger a spoken message or other actions. Movable buttons allow you to create 
dynamic activities for counting, sorting, sequencing and more. The Movable Button Tool allows you to 
quickly pair a Movable button with a Destination button and assign actions to be performed when the 
Movable button is dropped on that Destination button.

The following topics will be covered:

• Showing the Movable Button Tool

• Editing Actions for a Movable-Destination 
Button Pair

• Setting a Movable Button to Clone Itself

• Changing Button Types

• Limitations of Movable Buttons with Scanning 
Access Methods

• Creating Movable and Destination Buttons

• Setting a Movable Button to “Snap Back”

• Centering a Dropped Movable Button

• Scanning and Movable Buttons

In this sorting and counting activity, the student moves 
the specified number of shapes into the correct box.

Invisible Movable 
buttons. They can 
be moved and 
dropped on any 
valid destination.

This button is 
being dragged 
into the green 
box.

Destination buttons will 
perform actions when the 
correct movable button is 
dropped on them.
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Showing the Movable Button Tool

Initially, the Movable Button Tool is not visible in the toolbar. You will need to set the application to show 
this tool. Choose Dynamic Boards > Show > Movable Button Tool.

The Movable Button Tool 
is initially hidden. You 
must set the program to 
display this tool.

Movable Button Tool
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Creating Movable and Destination Buttons

1
Click the Movable Button Tool.

2

Click the button you want to make movable. 
The Enter Name dialog for the Movable 
button will appear. Every Movable button 
must be given a unique name.

3

Type a name for the Movable button and click 
OK.

Note: Movable button names will appear in 
a green box displayed in the center of 
the button whenever the Movable 
Button Tool is active.

4

Click and drag the Movable button on top of 
the button that will be the destination, then 
release the mouse button to drop it. The Enter 
Name dialog will appear for the Destination 
button.

Note: The board background can be a valid 
destination for a Movable button. 
Simply drag the Movable button to 
any location on the board 
background to create that pairing.

Movable Button Tool cursor

The red highlight indicates the original position 
of the Movable button.

Drag and drop the Movable 
button onto the desired 
Destination button.
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5

Type a name for the Destination button and 
click OK. 

Note: Destination button names will appear 
in a red box displayed in the center of 
the button whenever the Movable 
Button Tool is active.

6

Assign actions to the Destination button that 
will get performed when the current Movable 
button is dropped on this Destination button.

Note: A Destination button can be paired 
with multiple Movable buttons.

Note: A Destination button can not be 
selected unless it is assigned its own 
actions that are not associated with a 
specific Movable-Destination 
pairing. Refer to the Editing Actions 
for a Movable-Destination Button 
Pair section in this chapterfor more 
information.

7

When the application is placed in the Use 
mode and the “Square” Movable button is 
dropped on the “Green Box” Destination 
button, the assigned Speak Message action 
will be performed.

A recorded “boing” sound will be played when 
the paired movable button is dropped here.

When you drop 
the square into 
the green box, 
you will hear the 
“boing” sound.
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Editing Actions for a Movable-Destination Button Pair

Using the Movable Button Tool (Preferred 
Method)

Using the Movable Button Tool, drag the Movable 
button on top of the Destination button you want to 
edit. Because you’ve already given names to the 
Movable and Destination buttons, you won’t be 
asked again to enter names.

The Button Actions dialog will appear. Only the 
actions that are associated with this Movable-
Destination button pair will be displayed. Edit the 
action list as necessary.

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - OR - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

The easiest method to edit the 
assigned actions for a 
Movable-Destination pair is to 
drag and drop the Movable 
button onto the Destination 
using the Movable Button Tool.
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Editing the Destination Button (advanced)

Double-click the Destination button as you would to edit the actions of a normal button.

The Button Actions dialog will appear. All actions assigned to this button will appear. Edit the actions in the 
If or Else If action block with the name of the appropriate movable button. 

Note: Refer to the Chapter 20 - Working with Variables for more information on conditional If blocks.

Action that is performed if the 
button is selected directly or via 
scanning.

Actions that are performed only 
if the Movable button “Square” 
is dropped on this button.

Actions that are performed only 
if the Movable button 
“Diamond” is dropped on this 
button.
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Setting a Movable Button to “Snap Back”

A Movable button can be set to “snap back” to its original position if it is dropped on an invalid destination. 
(By default, the program would leave the Movable button wherever it was dropped.) This can be useful if 
you want to create an activity that provides feedback as to correct Movable-Destination pairs.

1

Right-click the Movable button which will be 
assigned the “snap back” property and choose 
Movable Button Properties from the 
contextual menu. The Button Properties 
dialog will appear.

2

Select the Snap Back option and click OK.

The background of the board is not a paired destination for the circle Movable button. 
If this button is dropped on the background, it will snap back to its original position.

In this activity, the 
board background is 
not a valid destination.

The name of the 
Movable button 
being edited.

The Snap Back setting returns the 
Movable button to its original position if 
it is not dropped on a valid destination.
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Setting a Movable Button to Clone Itself

A Movable button can be set to clone itself. When such a Movable button is dragged to a new position, the 
original button will remain in place and an identical copy of the button will be moved. A single Movable 
button now becomes a source for an unlimited number of cloned Movable buttons. This is especially useful 
in counting activities.

1 Right-click the Movable button you want to clone, and choose Movable Button Properties from the 
contextual menu. The Button Properties dialog will appear.

2

Select the Move Clones setting, and click 
OK.

The original button 
remains in place.

A cloned copy of the 
original button is 
moved in its place.

With the Move Clones options 
selected, you can now move copies of 
the original movable button.

The name of the 
movable button 
being edited.
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Centering a Dropped Movable Button

A Destination button can be set to automatically center any paired Movable button that is dropped on it. This 
is a very useful setting if it is important for a Movable button to snap to a specific location, which is 
determined by the location and size of the paired Destination button.

1 Right-click the Destination button you want to center, and choose Destination Button Properties 
from the contextual menu. The Buttons Properties dialog will appear.

2

Select the Center Movables option, and click 
OK.

The name of the 
Movable button 
being edited.

The Center Movables setting 
will center a dropped Movable 
button within this button.
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Changing Button Types

Using the Button Properties dialog, it is possible to change a Movable button into a Standard or Destination 
button. Similarly, a Destination button can be changed into a Movable or Standard button. 

Note: This is done primarily to turn a Movable or Destination button back into a standard button.

1
Right-click the Movable or Destination button whose type is to be changed and choose Destination 
Button Properties or Movable Button Properties from the contextual menu. The Buttons 
Properties dialog will appear.

2

Select the appropriate option, and click OK.
The name of the 
Movable or 
Destination button 
being edited.

The type of the button 
(Movable, Destination, 
Standard) can be 
changed here.
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Scanning and Movable Buttons

Movable buttons are best used with one of the direct selection access methods. However, Movable buttons 
can also be used with any of the scanning access methods. Special scanning behaviors were added to the 
program to allow Movable buttons to function with the various scanning access methods. 

Note: By default, when in a scanning access method, the program attempts to distribute selected Movable 
buttons within the Destination button to prevent them from being stacked on one another. If 
appropriate for the activity, use the “centering” Destination button property to have the Movable 
buttons centered in the Destination button. Refer to the Centering a Dropped Movable Button section 
in this chapter.

1

Select the Auto Scan access method 
(Dynamic Boards > Access Method), then 
place the program in the Use mode.

The program will highlight buttons according 
to normal scanning rules.

Note: Destination buttons will not scan 
unless they are also assigned actions 
that are not associated with a specific 
Movable-Destination button pairing.

2

Once a Movable button is selected, it will 
remain highlighted in blue as a reminder that 
it is selected. The subsequent scanning 
choices will be limited to only paired 
Destination buttons.

Selecting one of the Destination buttons will 
cause the Movable button to glide from its old 
position into the Destination button.

Note: If a Movable button is accidentally 
selected, it can be deselected by 
allowing the scan to loop through the 
Destination buttons until the loop 
limit is reached as specified in the 
Scan Loop Settings (Dynamic 
Boards > Access Method > 
Scanning Options).

In this activity, only the Movable buttons will scan.

The program attempts to distribute the Movable 
buttons around in the Destination button.

Only valid Destination 
buttons will scan.

The selected Movable button 
remains highlighted in blue.
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Limitations of Movable Buttons with Scanning Access 
Methods

While Movable buttons can be used with scanning access methods, there are limitations that need to be taken 
into consideration when designing a Movable button activity for use with a scanning access method.

• If the board background is paired with a Movable button, it will not be highlighted as a valid 
destination for a selected Movable button. The workaround for this is to make an invisible button on 
the background that is paired to the Movable button.

• Movable and Destination buttons should not be placed within scanning groups. They will exhibit 
unexpected scanning behavior if they are part of a scanning group.
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Chapter 17 
Working with PopUp Boards

Chapter Overview 

You have the ability to create small communication boards that pop up on top of the current board in use. 
PopUps allow you to keep the overall appearance of a board very simple while allowing the user access to 
additional button choices when necessary. PopUps are an excellent way to contextually organize a large 
quantity of vocabulary that is related to a specific activity.

The following topics will be covered:

• Creating a PopUp Board

• Using PopUp Boards with a Message Display

A PopUp board can 
provide a user with 
more button choices 
when they are needed.
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Creating a PopUp Board

To create a PopUp board, lay out the buttons for the PopUp right on the topic board itself. A special 
command will remove the additional buttons and create a PopUp board sized to exactly fit them.

Note: A PopUp board can open another PopUp board, but it should not be used to change to another board 
(Board Change action). The Change Board Back action should be used to leave a PopUp board and 
return to the topic board that called it.

1

Create the buttons that will become the PopUp 
board in the location where the PopUp board 
should appear.

Tip: Create the buttons wherever it is 
convenient, then use the Pointer Tool 
to move them into final position where 
the PopUp board should appear.

2

Note: Make sure ALL the buttons created 
for the PopUp board are selected 
before proceeding with this step. 
(Hold down the Shift key while 
clicking on each button.)

Choose Dynamic Buttons > Create PopUp 
Board.

The board that 
opens a PopUp 
is called the 
topic board.

This button will 
open the PopUp 
board shown.

The buttons for 
this PopUp are 
first arranged on 
the topic board 
before the PopUp 
is created.
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3

The selected buttons are cut from the topic 
board and pasted into a new board that is sized 
accordingly.

When the Save As dialog appears, type the 
name for your new PopUp board.

Tip: It will be helpful to give the PopUp 
board a name that will identify it as a 
PopUp; for example, "Utensil PopUp", 
or “PopUp-Utensil".  That way, it can 
quickly be identified for other use as a 
PopUp on other boards.

4

Once the PopUp board has been created, the appearance of the buttons can be set by choosing the 
desired color, border, and corner settings.

Add symbols, text, and button actions to the PopUp if that was not done before using the Create 
PopUp Board command.

Note: Be sure to assign at least one button the Change Board Back Action, then save the board.

5
Go back to the original topic board.

Double-click the button that will be used to activate your PopUp board.

6

Select Go To PopUp Board in the Actions 
list (Change Board category).

The program will 
set the PopUp 
board size to be 
slightly larger 
than the selected 
buttons.
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Using PopUp Boards with a Message Display

PopUp boards can be used to place text into or control a Message Display on the topic board or a previous 
PopUp board. Message Display actions selected on a PopUp board without its own Message Display will 
flow back down PopUp links until a Message Display is found.

7

The new PopUp board will automatically be 
selected in the board list. Its location is based 
on where you originally placed the buttons on 
the topic board when you used the Create 
PopUp Board command.

Click the OK button when finished.

Tip: To reposition the PopUp board later, 
edit the assigned Go To PopUp Board 
action and adjust the location 
measurements, which are relative to the 
upper left corner of the board.

Specifies the 
PopUp board's 
location on the 
topic board.

PopUps without Message Displays PopUps with and without MessageDisplays 
190



Boardmaker Software Family v6 User’s Guide
Chapter 18 
Working with Quick Action Buttons

Chapter Overview 

A collection of “Quick” actions are provided to create buttons whose content can be edited while working in 
the Use mode. Quick Text buttons and actions allow a user to compose and save text messages to the face of 
a button. Quick Picture buttons and actions allow the user to copy a picture from one button to another. 
Quick Record buttons and actions allow the user to record and save a message to a button. There are also 
Quick Day, Quick Date, and Quick Time buttons which automatically display the current day, date and time.

These “Quick” buttons and their associated actions provide a means by which the content of a specific board 
or activity can be quickly updated or personalized as needed, without having to edit the board in the Design 
mode.

The following topics will be covered:

• Working with Quick Text Buttons

• Working with Quick Picture Buttons

• Adding Quick Day, Quick Date, or Quick Time 
Buttons

• Creating Optional Quick Text Control Buttons

• Working with Quick Record Buttons

Save text mes-
sages using 
Quick Text but-
tons

Record 
messages 
using Quick 
Record 
buttons.

Quick Day 
button 

Quick Date 
button 

Quick Time 
button 

Change 
pictures using 
Quick Picture 
buttons
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Working with Quick Text Buttons

The Quick Text actions make it possible to compose and save a message to a button while in the Use mode. 
This can be useful for saving novel messages, schedules, and menus. Quick Text buttons are ideal for 
individuals who need the content on a board or in an activity to be updated periodically.

1

Double-click the button that will become a 
Quick Text button.

Quick Text buttons make it possible to update this daily cafeteria menu.

A Message 
Display is 
needed to 
compose the 
text that will 
be copied to 
a Quick Text 
button.

The text on 
these Quick 
Text buttons 
can be quickly 
updated while 
the program is 
in the Use 
mode.

Special actions allow these buttons to copy 
text back and forth between the Message 
Display and a Quick Text button.
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2

Assign the Quick Text action (Quick Actions 
tab). The Enter Text dialog will appear.

3

Type an initial message for the Quick Text or 
leave the message blank and it can be filled in 
later by the user.

Click OK when finished.

4

Assign the Quick Speak and/or the Quick 
Type actions (Quick Actions tab) to make the 
button speak and/or type its message into the 
Message Display when selected.

Click OK when finished.

5

Double-click the button to be used to copy the 
Message Display text to a Quick Text button. 
Assign the Display to Quick Text action 
(Quick Actions tab), then click the OK 
button. 

Type the initial message 
or leave it blank.

The Quick 
Speak and 
Quick Type 
actions tell the 
button how to 
use its saved 
message text.

This button will copy the 
new message and start 
the Quick button 
selection mode.
193



Chapter 18 - Working with Quick Action Buttons
6

To use a Quick Text button, switch the application to the Use mode (Ctrl +U). 

Type a message in the Message Display. 

Click the “Paste to Button” button. The cursor will change to a pointing finger, indicating the 
application is in the Quick button selection mode.

Click on a Quick Text button. The new message text will appear on the face of the button. Any existing 
text will be replaced.

Click the Quick Text button to hear it speak the message.

Note: The font and font appearance of Quick Text buttons can be set by using the contextual menu 
or by choosing the appropriate command from the Text menu.

Click here to enter 
the Quick button 
selection mode.

Click the Quick 
Text button and 
the new message 
will appear.

Type a new 
message.
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Creating Optional Quick Text Control Buttons

Buttons with additional Quick Text actions can provide the user with control over the content of the Quick 
Text buttons.

1

Clearing the Message Display

Double-click the button to be used to clear the 
Message Display. 

Assign the Clear Message Display action 
(Messages tab), then click the OK button. 

In the Use mode, click on this button to clear 
the Message Display so you can type a new 
message.

2

Clearing a Quick Text Button

Double-click the button to be used to clear a 
Quick Text button. 

Assign the Clear Message Display action 
(Messages tab) and the Display to Quick 
Text action (Quick Actions tab), then click 
the OK button.

In the Use mode, click on this button, then 
click on a Quick Text button to clear its 
contents.

3

Copying text from a Quick Text button to 
the Message Display

Double-click the button to be used to copy the 
text from a Quick Text button to the Message 
Display. 

Assign the Clear Message Display action 
(Messages tab) and the Quick Text to 
Display action (Quick Actions tab), then 
click the OK button.

In the Use mode, click on this button, then 
click on a Quick Text button whose text will 
be copied to the Message Display.

This button clears the 
Message Display.

This button clears a 
Quick Text button.

This button will copy 
the text from a 
Quick Text button 
into the Message 
Display where it can 
be edited, printed, 
or spoken.
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Working with Quick Picture Buttons

The Quick Picture action makes it possible to change the picture on the face of a button while working with 
the board in the Use mode. This is extremely useful for creating interactive activities, quizzes and games.

Note: The Set Button Picture action can also change the picture on a button while in the Use mode.

1
Double-click the button that will become a 
Quick Picture button.

Quick Picture buttons make it possible to create “fill in the blank” activities like this one.

Quick Picture 
buttons will dis-
play the answer 
the student 
selects.

The answer 
buttons are set to 
copy their pictures 
to any one of the 
Quick Picture 
buttons.
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2

Assign the Quick Picture action (Quick Actions tab), then click OK. 

Note: By default, Quick Picture changes are not saved on the board. To save any changes, select the 
Save All Changes box in the Action Details list for this action. If you will be using an 
activity over again and wish to have the same starting point, do not select the Save All 
Changes option.

3 Double-click the button whose picture will get 
copied to a Quick Picture button.

4

Assign the Copy to Quick Picture action (Quick Actions tab), then click the OK button.

Note: By default, only the picture closest to the top-left corner of the button (if there are multiple 
pictures) will be copied to a Quick Picture button. To copy the entire content of the button 
(pictures, text, and lines), select the Copy Everything option in the Action Details list for 
this action.

Check the Save All 
Changes box to save any 
Quick Picture change 
made to this button. Other-
wise, the changes will be 
temporary. 

Check the Copy Every-
thing box to copy every-
thing on the button face to 
the selected Quick Picture 
button. 
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5

To use a Quick Picture button, put the application in the Use mode (Ctrl +U). 

Select any button assigned the Copy to Quick Picture action. The cursor will change to a pointing 
finger, indicating the application is in the Quick button selection mode. 

Click on any Quick Picture button.

Note: After selecting a button with the Copy to Quick Picture action, selecting any button other 
than a Quick Picture button will cancel the Quick button selection mode.

Click on the “cow” button and 
then on the blank Quick Picture 
button to fill in the blank.

The pointing finger indicates the 
program is in Quick button 
selection mode. 
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Working with Quick Record Buttons

The Quick Record action makes it possible to record and save a message on a button while in the Use mode. 
This can be useful for recording novel messages, sending audio notes to or from home/school, or in creating 
articulation activities.

Note: Quick Record requires partner assistance to be fully accessible. Be careful when using Quick Record 
buttons on boards designed for individuals using scanning access. Consider removing these buttons 
from the scanning sequence (refer to the Using the Sequence Tool in Chapter 22). Buttons removed 
from the scanning sequence can still access Quick Record buttons by enabling the Allow Direct 
Selection When Possible option in the Scanning Options dialog (Dynamic Boards >Access 
Method > Scanning Options…).

1

Double-click the button that will become a 
Quick Record button.

Quick Record buttons make it possible to create activities in which 
messages can be quickly recorded and saved while in the Use mode.

Quick 
Record but-
tons. One 
message but-
ton is provided 
for each 
potential 
need.

This button 
initiates the 
Quick Record 
mode.
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2

Assign the Quick Record action (Quick 
Actions tab), then click OK. 

3

Double-click the button that will be used to 
initiate the Quick Record mode.

4
Assign the Set Quick Record action (Quick 
Actions tab), then click OK.

5

To use a Quick Record button, put the 
application in the Use mode (Ctrl +U). 

Select the Record Notes Home button. The 
cursor will change to a pointing finger, 
indicating the application is in the Quick 
button selection mode.

Click on any Quick Record button. The 
Record Sound dialog will appear.

Note: After selecting a button with the Set 
Quick Record action, selecting any 
button other than a Quick Record 
button will cancel the Quick button 
selection mode.

Click here 
to initiate 
the Quick 
Record 
mode.

The pointing finger indicates 
the program is in Quick but-
ton selection mode
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6

Click the Record button to begin recording 
the message. Click the Stop button (toggled 
Record button) when finished recording. 
Click the Play button to hear the recorded 
message.

Click the OK button to close the dialog and 
save the recorded message.

Note: The Record Sound dialog is not 
accessible via scanning selection. To 
prevent an individual using scanning 
access from being unable to cancel 
out of this dialog, it has been 
modified so that it will automatically 
close after 15 seconds if a recording 
has not been initiated.

7

After saving a Quick Record message, 
selecting the button again will play the 
message that was just recorded.

The Record button will 
become the Stop button 
once recording has started.

Recording time counter.

Selecting 
the button 
again will 
play the 
message. 
“Sarah 
needs to 
practice….”
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Adding Quick Day, Quick Date, or Quick Time Buttons

The program provides button actions that will display the current day, date, or time on the face of a button. 
Two additional button actions allow these buttons to speak or send their contents to a Message Display.

Note: Your computer must be set for the correct date and time. This can be changed using the Windows 
Date/Time control panel.

1

Double-click the button that will be used to 
display the current day, date, or time. 

Assign the Quick Day, Quick Date or Quick 
Time action (Quick Actions tab) as 
appropriate.

Note: To change the display format of the 
date or time, click the Customize 
button in the Regional and 
Language Options Windows 
control panel (Regional Options 
tab.)

2

Assign the Speak Day/Date/Time/Prediction 
and/or Type Day/Date/Time actions (Quick 
Actions tab) to make the button speak and/or 
type its contents in to the Message Display. 

This invisible button will 
display the current date.

Use these actions to display, speak, 
or type (in this case) the current date.
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Chapter 19 
Other Useful Program Features

Chapter Overview 

This chapter provides instructions and information on a variety of very useful program features. Some of the 
most common “how to” questions about the program are answered and explained in this chapter.

The following sections will be covered:

• Launching Programs

• Playing Movies

• Voice and Sound Volume

• Changing the Pronunciation of Words

• Greeting

• Saving a Board’s Action List

• Printing Interactive Boards

• Random Action

• Selecting and Changing Voices

• Setting a Private Audible Cue

• Password

• Display Menus or Title Bars

• Usage Counts

You can play movies on your 
buttons, in a Message 
Display, or on the board itself.

Change and configure the 
voices you want to use.

Change the pronunciation 
of mispronounced words.
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Launching Programs

Programs, documents, or files can be launched from a board by linking a button to a shortcut for the program 
or file. You should create an alias of theprogram or file you want and move it to the SDP Externals folder 
before you assign the Launch Programaction to a button. 

1

Creating a Shortcut

Locate the program you want to launch in 
Windows Explorer (or using My 
Computer).

Right-click on the desired program or file icon 
and select Create Shortcut from the pop-up 
menu.

2

Drag (or copy) the shortcut you created into 
the SDP Externals folder. This folder can 
usually be found along the following path: 
C:\Program Files\Boardmaker with SD 
Pro\SDP Externals.

3
Linking a Button to the Shortcut

Create a button that will be used to launch the 
application or file and assign it the Launch 
Application action (Cool Stuff tab).

Right-click a file to 
create a shortcut.

This button will launch the 
Calcu-Scan program.
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4

In the dialog box that appears, select the 
shortcut you created and click on OK. Close 
the Button Actions dialog when you finish 
editing it.

Note: Only shortcuts placed in the SDP 
Externals folder can be selected.
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Random Action

You have the ability to create buttons that can perform a random action from their list of assigned actions. 
This allows you to create a button that might randomly select a response from a list of greetings or randomly 
select a name, number, or color. 

1

The following is an example of creating a 
button that will speak students’ names at 
random.

Create a button and assign it the Random 
action (Cool Stuff tab).

2

Assign a series of Speak Message (or other) 
actions, each given a different student’s 
name.

When the program is in the Use mode, the 
button will randomly speak one of the 
student's names each time it is clicked.

Note: If you want a button to perform 
another action after a Random 
action, e.g., a board change, assign 
the End Random action (Cool 
Stuff tab) then assign the other 
desired action.

Only the indented actions under the 
Random action are selected randomly.
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Playing Movies
You have the ability to play a movie from a button. The movie can play on the face of the button, in the 
Message Display, or it can fill the entire board.
The program supports movies in the .avi, .mpg, and .wmv formats. 
Note: There are many variations of all the formats. Certain variations will require the installation of 

additional encoding software. 

1

Double-click the button that you want to use 
to play a movie.

Click the Play Movie action in the Cool 
Stuff tab.

2

Locate and open a saved movie.

3 The Play Movie action and the name of the selected movie will appear in the Assigned Actions list.
By default, the movie is set to play on the face of the button. Clicking where it says Play on Button 
will change where the movie is played. You have the following three options:
• Play on Button - Plays the movie on the face of the button.
• Play on Message Display - Plays the movie in the board’s Message Display.
• Play on Board - Plays the movie on the board.
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Voice and Sound Volume
The various types of sounds (voices, recordings, feedback sounds) in the program can be configured with 
different volume levels or turned off entirely. To set the volume levels, choose Dynamic Boards > Speaker 
Volumes.

Separation of Sounds
These three options let you choose how the program volume levels will be controlled.

• No Separation. Use Control Panel Volume Setting - All volume levels are set by the Windows 
Sounds control panel.

• No Separation. Use Volume Settings Below - Allows you to set volume levels for each of the 
different types of sounds (pictured above).

• Left Channel and Right Channel - Allows you to set independent volume levels for the right and left 
speakers for each of the different types of sounds. This is used to set up a private audible cue. Please 
see the next section for details.

Loud and Soft Volume Settings
You can set the individual volume levels for two different volume sets, Soft or Loud. Click the Show Soft 
Settings button to change the volume levels for that set. The user can change between the Soft or Loud 
volume sets by clicking on buttons assigned the Use Loud Settings and Use Soft Settings actions (Settings 
tab).

Turning Off Audible Cues

If you would like to turn off any spoken or recorded previews that are assigned to your boards, select Mute 
as the Preview Sounds volume level. Any Spoken Preview or Recorded Preview action assigned to a 
button will be ignored, rather than just playing the sound and muting the volume.

Configure how the 
different volumes are 
set and controlled.

Normal 
voice and 
recording 
volume.

Preview 
voice and 
recording 
volume.

Set the Loud 
and Soft 
volumes.

Audible feedback 
sound volumes.
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Selecting and Changing Voices

Speaking Dynamically Pro comes with the English Microsoft SAPI voices and the Nuance RealSpeak™ 
voices in the appropriate language (installed with the localized SDP files). You can also use other software-
based SAPI 4.0 and SAPI 5.1 compliant voices.

Boardmaker Plus comes with only the English Microsoft SAPI voices. You can also use other software-
based SAPI 4.0 and SAPI 5.1compliant voices.

You can change the voice settings by selecting Voice in the Dynamic Boards menu. At the top of the 
window, you can choose to use either the Nuance RealSpeak™ or the SAPI 4 voices or SAPI 5 voices. You 
will have different voices and voice settings in each speech engine.

Note: The Nuance RealSpeak™ voices are female only. US English is the only language that includes a 
male voice. Nuance RealSpeak™ voices for other languages can be purchased separately. Contact 
your local Mayer-Johnson reseller for more information.

Switching Voices from a Button

You can make your buttons switch between any of the 
four voices by using one of the Use Voice actions 
(Settings tab of the Button Actions dialog).

Note: These actions should only be used on a fast 
computer due to the potential delay resulting 
from a voice change.

Access the 
voice settings.

Main speaking 
voice.

Voice used for 
spoken previews.

Two alternate voices can be configured. 
See description below.

Change speed 
and pitch settings.
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Setting a Private Audible Cue
You can configure the program to provide a user with private audible cues through an earpiece or headset. To 
do this, you must use the Recorded Preview action (in the Basics tab) and will need to purchase a stereo 
splitter jack into which you will plug an earpiece and an external speaker. The splitter jack will send the right 
channel sounds to the earpiece and the left channel sounds to the external speaker, or vice versa.
By using the Left Channel and Right Channel setting in the Speaker Volumes window (Dynamic Boards 
> Speaker Volume), a Recorded Preview can be configured to play through one channel (right or left) but 
not the other (see the picture below). You will want to set an appropriate preview volume level for the 
channel you have the earpiece plugged into and mute the volume for the other channel.
Note: The synthesized voices cannot be set to play out of only one channel (right or left). They will always 

play through both channels.

Note: If you will be using a mono earpiece, you will need a stereo to mono adapter between the earpiece and 
the splitter. 

Plug the earpiece or headset 
into the channel (right or left) 
set under Preview Sounds in 
the above screen.

You may need an external 
speaker plugged into the other 
channel. Plugging the splitter 
into the computer may disable 
any built-in speaker(s).

You must use Left 
Channel and Right 
Channel for private
audible cues.

Set the volume level 
for the main output 
voice. Right and Left 
should be the same for 
synthesized voices.

Set the volume level 
for the channel 
connected to the 
earpiece. The other 
channel should be 
muted.

Book cassette adapter 
(stereo splitter)
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Changing the Pronunciation of Words

The synthesized voices will not always say words correctly, especially in the case of certain proper names 
and foreign-derived words. Alternate phonetic spellings for words can be saved to correct pronunciation 
problems for all available voices.

1

Choose Dynamic Boards > Voice. The 
Choose Voices dialog appears.

Click the Change Word Pronunciations 
button.

Note: Make sure the voice you need to edit is 
selected as the Main Voice.

2

Type the word that needs its pronunciation 
changed.

Click the Play button to hear the current 
pronunciation.

Note: The screens shown in this example are 
for the SAPI voices. The 
pronunciation screens for the 
RealSpeak voices will look different, 
but function in a similar fashion.
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Printing Interactive Boards

Typically, interactive boards are designed to fill the computer screen, which will make the board too large to 
print on a single piece of paper. To get around this problem, choose File > Print Board on Single Page. The 
application will automatically scale the board to fit on the piece of paper according to the current printer 
page settings. Refer to Setting the Correct Paper and Board Size in Chapter 1 for help with the printer page 
settings. 

Note: Typically, interactive boards should be set to print in landscape mode rather than portrait mode as 
depicted above. Refer to the Setting the Correct Paper and Board Size in Chapter 1 to learn how to set 
a board to print in landscape mode.

3

Click in the empty box in the middle of the 
screen. Type a phonetic spelling for the word. 
As you type each letter you will hear the 
progress of the new pronunciation.

Click Play again if you need to hear the new 
pronunciation.

Click Finish when you are satisfied with the 
new pronunciation.

Note: If you click the Phonemes button, you 
must enter language specific 
phonemes.

Use the Print 
Board on Single 
Page command to 
scale the board to 
fit the selected 
paper.

If you use the 
Print command, 
the board will print 
on multiple pieces 
of paper.
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Password
A password can be set to prevent curious users from accessing the program’s Design mode. The password 
will be required when entering the Design mode only if the program is launched by double-clicking the 
board. Choose Dynamic Boards > Password.

Note: To turn off the Password function, choose Dynamic Boards > Password. Leaving the new password 
field blank, click on the OK button.  Click OK.

Greeting
When the program starts, it can play a greeting message. Choose Dynamic Boards > Greeting to type in the 
greeting text. Click OK to save the greeting.

The Design mode is 
password protected only 
when the application is 
opened in Use mode.

Enter your 
greeting here.
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Display Menus or Title Bars

By default, the program is set to hide both the menu bar 
and the board's title bar when in Use mode. Either of 
them can be turned on.

Choose Dynamic Boards > Show and then choose 
Menu Bar in Use Mode or Board Title in Use Mode 
from the submenu.

Note: When you change the display options of the 
menu or title bar, the boards will automatically 
scale themselves to fit the available screen 
space.
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Saving a Board’s Action List
For the purpose of training or as a form of paper backup, a list of all the actions assigned to the buttons on a 
board can be saved to a text file, then printed. Each button on a board is assigned a specific number which is 
used to organize the action list file. The button numbers can be displayed on-screen and/or printed to match 
the action list.

Displaying Button Numbers

Choose Dynamic Boards > Show > Button Numbers.

Saving the Action List

Choose File > Export > Action List.

Displaying the 
button numbers 
on a board.

A portion of the action list text file.

Saving the action 
list text file.
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Usage Counts

Choose Dynamic Boards > Usage Counts to display the Usage Counts dialog and to keep track of the 
number of times each button on a board was selected by the user. Recording the button usage can help track 
how a user is actually using each board.

Note: Usage counts will not be saved until the action from the Board Change category occurs. No usage 
counts will be recorded by simply putting a board in the Use mode, using the board and then returnig 
to the Design mode.

Note: The usage counts will not get reset until the OK button is clicked.

The number of times these 
buttons have been selected.

Turn on and off 
Usage Counts.

Display the Usage 
Counts on the 
buttons.

Used to reset the 
button counts on a 
single board or on 
all boards.
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Chapter 20 
Working with Variables

Chapter Overview 

The Variables category of button actions gives you the ability to create buttons that will respond differently 
based upon previous button selections. These actions are based on the use of variables and “if, then, else” 
logic, i.e., “if” a condition is met (a certain button is selected), “then” a particular action is performed (when 
another button is selected), “else” a different action is performed. With these conditional actions, you can 
create smart buttons that can provide personalized responses, perform verb tensing, and a range of other 
custom behaviors.

The following topics will be covered:

• Variables Button Actions

• Assigning Variables and Values

• Testing Variables and Assigning Conditional Actions

These buttons assign 
the person’s name to a 
variable called “person.”

These buttons 
check the value 
of the “person” 
variable to 
determine what 
message to 
speak.
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Variables Button Actions

The Variables tab of button actions provides actions that can make your buttons respond conditionally. A 
list of the Variables actions is given below.

• Assign Variable - Assigns a variable value to a button, i.e., Person = “mom.”

• Assign Variable From Display - Assigns the contents of the Message Display to a variable.

• Adjust Variable - Adjusts a numerical variable by an amount, or adjusts a string (or word) by 
appending additional characters.

• Speak Variable - Speaks the value of a variable.

• Type Variable - Sends the value of a variable to the Message Display.

• If - Performs a conditional test on a variable to check for a specific value, i.e., does Person = “mom”? 
If the condition is true, actions assigned after the If action will be performed.

• Else If - Used in conjunction with the If action. This action is used to check a variable for alternate 
values, i.e., if Person NOT = “mom,” then does Person = “Dad”? If this condition is true, actions 
assigned after the Else If action will be performed.

• Otherwise - Used to provide a default action if all conditional tests are false, i.e., Person NOT = 
“mom” or “Dad.” Actions assigned after the Otherwise action will be performed.

• End If - Used to end a block of actions that are performed after an If, Else If, or Otherwise action.

• Variable To Quick Text - Saves the value of a variable on a Quick Text button.

Example of conditional 
actions assigned to a button.
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Assigning Variables and Values

Having a button or buttons assign a value to a variable is the first step in creating a board with conditional 
button responses. Once a button assigns a value to a given variable (i.e., the user selects that button) other 
buttons can then test that variable for a specific value and perform actions accordingly.

1

Double-click a button that will be used to set 
the value of a variable. 

In this example, the name of the conversation 
partner depicted on the button is assigned to a 
variable.

2

Assign the Assign Variable action 
(Variables tab) to the button.

3

Type a variable name and a value for that 
variable.

In this example the name of the person 
depicted on the button is assigned to the 
variable “person.”

Click OK when finished.

Choose a button 
that will assign a 
variable a value.
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Testing Variables and Assigning Conditional Actions

Having created at least one button that assigns a value to a specific variable, the If action can be used to 
check the value of the variable and conditionally perform an action or a block of actions. The Else If and 
Otherwise actions can also be used to check a variable for additional values and to define default actions 
when all If variable tests are false.
.

1

The “If” Action

Double-click on a button that will test a 
variable and conditionally perform an 
action. 

In this example, the variable “person” will 
be tested to determine if a specific message 
will be spoken.

2

Type the name of the variable to test and 
the value being tested for, then click OK 
when finished.

In this example, the variable “person” is 
being tested for the value of “mom”.

Note: Variable/value comparison is not 
limited to just the “=” option. 
Other comparison options such as 
“not =” are available in the drop-
down menu.

3

Assign the action or actions that will get 
performed when the If variable test is true.

Note: Actions that follow an If action 
will automatically be indented to 
help visually organize the actions.

This button will 
speak a specific 
message based on 
the value of the 
“person” variable.

The indented action will be 
performed only if “person = mom".
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4

The “Otherwise” Action

The Otherwise action is used to provide a 
default response when all the If and Else If 
conditional tests are false.

Assign the Otherwise action (Variables 
tab) to the button, then assign the default 
action or actions to be performed.

Note: The Otherwise action must 
follow an If action and can not be 
used by itself.

5

The “Else If” Action

Use the Else If action to test a variable for 
other possible values.

Click the last action to be performed in the 
If conditional block and then assign the 
Else If action (Variables tab) to the button. 

Enter the name of the variable to test and 
the next value to be tested for, then click 
OK when finished.

Note: The Else If action must follow an 
If action and can not be used by 
itself.

6

Assign the action or actions to be 
performed if the Else If conditional test is 
true.

The Otherwise action 
provides a default response 
when all If conditions are false.

Use Else If to test for 
other possible value.

This action get performed 
if “person = dad.”
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7

If Blocks and End If Actions

The End If action is used to let the 
application know there are no more actions 
associated with the initial If conditional 
test, and any related Else If or Otherwise 
actions. These actions together form an If 
block.

Assign the End If action (Variables tab) 
after the last action in the complete If 
block.

Any actions that are not part of an If block 
will always be performed when the button 
is selected.

Note: If you do not assign an End If 
action before you close the 
Button Actions dialog, the 
application will attempt to add one 
for you. 

8

Variables in Action 

When in the Use mode, selecting the 
“mom” button will assign the value “mom” 
to the variable “person.” This value will 
remain until another person is selected or 
the Use mode is exited. 

When any of the conversation buttons are 
selected, they will speak a message that is 
specific to that person (assuming one was 
specifically defined for that person). 

If a button does not have an If block testing 
the variable “person” for the value of 
“mom”, then it would speak the default 
message that follows the Otherwise action.

Use an End If action to 
terminate an “If” block.

Any actions that precede or 
follow an “If” block will 
always be performed.

Select the 
“mom” button.

These buttons will 
speak a message 
that is specific to 
mom.
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Chapter 21 
Creating Boards for Writing

Chapter Overview 

There are a wide range of features and button actions that allow you to create boards that can function as 
writing aids or talking word processors.  Numerous typing boards are supplied with the application, but you 
can also create your own. Features like word prediction, abbreviation expansion, and typing shortcuts can be 
used to improve the speed and quality of a user’s writing. The ability to save and open different message 
files can easily be added. The message files can contain text and/or symbols.

The following topics will be covered:

• Typing Board Layout Considerations

• Adding Prediction Buttons

• Accessing the Word Prediction Keys

• Abbreviation Expansion

• Adding Text Editing and Cursor Control Buttons

• Editing the Message File Boards

• Improving Access with the Scan Tools

• Word Prediction

• Changing the Prediction Settings

• Editing the Word Prediction Dictionary

• Typing Shortcuts

• Message File Control Buttons

• Basic Considerations for Scanning Access

Message 
Display

Word 
prediction 
buttons

Speaks the 
Message 
Display

Abbreviation
expansion
button

Each button 
uses a Type 
Message 
action to 
input the 
letter.

Print button

Buttons to 
open and 
save 
message 
files

Sample typing board



Chapter 21 - Creating Boards for Writing
Typing Board Layout Considerations

A big advantage of using the program as your talking word processor or writing aid is that you can create a 
board that contains the exact buttons and features needed by your user. The cognitive and physical needs of 
the user will dictate the layout of the board you create. All typing boards share the same basic components: a 
Message Display, letters, function keys, and Message Display controls. 

Message Display

The text in the Message Display can be any size or color that will benefit the user. The display can be 
configured to read letters or words as they are typed, or highlight words as they are read back. Refer to  
Chapter 13 - Using a Message Display with Text.

Key Layout

There are a variety of different letter layouts for a typing board. The layout you choose will most likely be 
determined by the user’s method of access. Typically, the letters are arranged to either simplify locating the 
desired letter or maximize access speed. An ABC layout is shown above, and two other examples of letter 
layouts are shown below. 

Display Control Buttons

Typically, you will want to provide the user with common function buttons such as space, return, shift, 
backspace, clear, speak, and print. Typically, these actions, with the exception of the space, are placed at the 
end of the scan sequence because of their relatively infrequent use.

Message 
Display

Letter keys 
add a letter to 
the display.

Function keys 
control the 
display.

The “frequency 
of use” layout 
positions the 
most often used 
letters in the 
first positions in 
the scanning 
sequence.

This layout is based on the 
standard QWERTY keyboard.
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Word Prediction

For many users, the word prediction feature available in Speaking Dynamically Pro can be tremendously 
helpful in assisting them in the writing process. Word prediction works by searching for and displaying the 
most frequently used words that begin with the letter or letters the user is typing. The user can then select 
their word when it appears in the list of predicted words. Word prediction saves a lot of time and effort by 
freeing the user from potentially typing every letter of each word.

The Prediction buttons in the program can be arranged and configured to suit the user’s access, visual, and 
cognitive needs. The word prediction can be customized to:

• learn and then predict new words entered by the user.

• predict phrases manually entered into the dictionary.

• make audible predictions to assist the pre-literate or visually impaired user.

• be accessed either by on-screen selection or keyboard key.

• make predictions either alphabetically or based on frequency of use.

• use alternate dictionaries with specific vocabulary for language-based activities.

These options will be covered in the next few sections.

When letters are typed, the prediction 
buttons search for the most frequently 
used words that start with the letter or 
letters.
Clicking on a prediction button copies 
the word to the display.
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Adding Prediction Buttons

You can add up to 100 Prediction buttons to a board. Only the Button Speak (Cool Stuff tab) and the 
actions in the Board Change tab can be assigned to a prediction button.

1

On this example typing board, space was left in 
the upper left corner to add a few Prediction 
buttons. 

2
Choose Dynamic Buttons > Prediction.

3

Drag the first button into the upper right corner of 
the board.

Stretch out the button and increase the font size.

Tip: Assign the Speak Day/Date/Time/
Prediction actions (Quick Action 
category) to the Prediction button to make 
it speak the predicted word when selected.

4

Use the Button Sprayer Tool to to spray out 
additional prediction buttons.

Save the board, then switch the application to the 
Use mode. As you type letters, the Prediction 
buttons will start predicting words. Click the 
Prediction button to put its word into the 
Message Display.

Return to the Design mode when finished.

Use the Button 
Sprayer Tool to 
create additional 
Prediction buttons.
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Changing the Prediction Settings

Depending on the skill level of the user, it may be necessary to adjust some of the word prediction options. 
These can be set by choosing Dynamic Boards > Word Prediction.

Settings

Update Usage Count - When enabled, the frequency count in the prediction dictionary will be updated each 
time a word is used. Words with higher frequency counts will be predicted more quickly.

Learn New Words - When enabled, new words will be added to the prediction dictionary as they are typed 
in the Message Display. If the user is a bad speller, you will want to turn this feature off to prevent the 
program from learning misspelled words.

Use Audible Predictions - When enabled, the prediction buttons will speak the predicted word as they are 
highlighted or scan.

Turns on and off 
word prediction

Allows the predic-
tion to adapt to 
the user
(See below)

Turns on and off 
audible prediction

Add to or edit the 
prediction library.
(Later section)

Choose the prediction 
method: alphabetical 
or frequency of use

Configure the predic-
tion buttons for key-
board access
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Accessing the Word Prediction Keys

The Prediction buttons can be accessed either directly (selecting on-screen) or by hitting the corresponding 
numeric key on the keyboard. By default, the numbers 0 through 9 are assigned to activate the first ten 
prediction buttons. The number keys can only be used to type numbers until words appear in the prediction 
buttons. Typically, this approach works well, but if this is a problem for the user, you can either reassign the 
activation keys for the prediction buttons, or turn off the Button Keys feature which will de-activate 
keyboard selection.Button Keys Toggle

Button Keys is an SDP feature that allows you to assign and activate any button on a board using a 
keyboard key. Using the 0 through 9 keys to activate Prediction buttons is an example of this feature. You 
can define a toggle key that will disable and re-enable the use of Button Keys. This will free the keyboard 
from any Button Key assignments that might prevent the use of the keyboard for writing, i.e. typing numbers 
rather than accessing Prediction buttons. 

Reassigning the Prediction Activation Keys

You can change the keyboard assignments for the Prediction buttons. To do so, choose Dynamic Boards > 
Word Prediction, when click the Prediction Button Keys button. In the dialog that appears, click the 
corresponding text boxes to reassign the prediction activation keys.

Note: The Button Keys feature must be turned on to enable keyboard selection of the Prediction buttons.

Turn on or off the 
key to toggle the 
Button Keys fea-
ture.
F2 is the default 
toggle key.

Click here to turn on or off the Button Keys feature.

Uncheck this option to 
disable the Prediction 
activation keys.

Click the correspond-
ing boxes and press 
the keyboard keys to 
be assigned to the 
Prediction button.
228



Boardmaker Software Family v6 User’s Guide
Editing the Word Prediction Dictionary

You can edit the contents of the word prediction dictionary by using SDP or a word processing program. It is 
recommended that you make dictionary changes from within SDP to prevent an entry error which may cause 
problems. Editing the prediction dictionary allows you to:

• preload the existing or a new dictionary with specific vocabulary.

• enter commonly used phrases you would like predicted.

• add necessary words to the dictionary (people’s names, other proper names, places, etc.).

• remove misspelled words added when the learning option is enabled.

• add words that are capitalized. SDP will not remember capitalizations for words learned automatically.

Editing the Dictionary Using SDP

Choose Dynamic Baords > Word Prediction to edit the prediction dictionary.

--------------------------------------------------------- OR ------------------------------------------------------------

Type the word 
to be added or 
edited.

Each word must 
have a fre-
quency count. 
Initial counts are 
between 1 & 10.

Click here to 
look up a word 
for editing.

Used to 
browse the 
dictionary.

Click here to add 
a new word

Click here to 
delete a word from 
the dictionary.
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Editing the Dictionary Using a Word Processor

If you are going to make a large number of changes to the prediction dictionary it will be quicker if you use 
a word processing program. You will need to open the SDP Predictions.txt file and enter your new words in 
the format shown below.

Using a Different Prediction Dictionary

If you need to work with multiple prediction dictionaries, you can use a different dictionary by swapping 
dictionary names. SDP will use the dictionary named SDP Predictions.txt. You must rename the original 
dictionary and name the new dictionary SDP Predictions.txt.

If you want to work with a new blank prediction dictionary, remove the SDP Predictions.txt file. SDP will 
automatically create a new blank dictionary. The easiest way to quickly add specific vocabulary to the new 
dictionary is to turn on SDP’s Learn New Words feature and type the vocabulary into a Message Display.

If you have a lot of words to add and are not 
concerned with the prediction count, simply turn on 
the Learn New Words option and type in the words 
you want to add in the Message Display.

Typing the same word over and over will increase its 
prediction count.

SDP has now learned the word 
“widgit” and the word now has 
a frequency count of 4.
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Abbreviation Expansion

Abbreviation expansion allows the user to quickly enter a phrase or block of text into the Message Display 
by entering only a few letters. Abbreviations are useful for full names, addresses, or other frequently used 
phrases and text.

When an abbreviation is entered into the Message Display, the user will need to hit a key or button to expand 
the abbreviation. You have the choice of expanding abbreviations using a button assigned the Expand 
Abbreviation action (Message tab), a keyboard key, or a Prediction button. 

Expansion Button (used by scanners)

Keyboard Key (used by keyboarders)

Prediction Button (used by scanners)

It is possible to use the Prediction buttons to 
expand abbreviations. Each abbreviation will 
need to be entered into the Prediction dictionary 
followed by the abbreviation expander character, 
e.g., enter “mj`” for the “mj”/”Mayer-Johnson” 
abbreviation. The Expander character/key is 
assigned as shown above.

Abbreviation Expansion
Expand the Abbreviation 
using the assigned button.

The default expander is the “ ‘ “ (accent) 
key. You may assign a different key.

The abbreviation and the expander, e.g., “mj‘ “, 
can be added to the prediction dictionary.
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Typing Shortcuts

The Typing Shortcuts feature is a collection of writing actions the program can perform automatically for the 
user. Typing Shortcuts includes the following actions:

• The first word typed in the Message Display or after punctuation will 
be capitalized.

• A space will automatically be inserted after a comma.

• Two spaces will automatically be inserted after a period, question 
mark, or exclamation point.

• The user doesn’t need to hold down the Shift key to type a question 
mark. (You hold down the Shift key to type a “/” with this feature 
enabled.)

You may want to disable Typing Shortcuts when doing math or spelling lessons where the automatic 
capitalization and letter spacing would cause problems. You can create a button and assign a Typing 
Shortcut Setting action (Settings category) to it that will turn on, turn off, or toggle on and off the Typing 
Shortcuts.

Adding Text Editing and Cursor Control Buttons

In the Text & Cursor and Message action categories there are over 40 different button actions that can be 
used to create buttons that will allow the user to select and edit the text in a Message Display. With these 
editing buttons alternate access users can:

• scroll the contents of the Message Display.

•move the cursor in any direction within the 
Message Display.

•select letters, words, sentences, or paragraphs.

•cut, copy, and paste text.

It is a good idea to place any editing buttons you 
create on a PopUp board to keep from cluttering 
your typing board. Button actions on a PopUp 
board can affect a Message Display on the topic 
(typing) board.

Example 
PopUp board 
that contains 
editing buttons.
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Message File Control Buttons

The contents of a Message Display can be saved to a message file. Button actions in the Message Files 
category allow you to create buttons to open and save message files. Two special boards, Select Message 
File and Save Message File As, are used to select a file to open or enter a name for the file being saved. All 
message files are saved in the SDP Message Files folder found in the application folder.

Basic Message Files Actions
• New Message File - Creates a blank untitled message file.

• Open Message File - Opens the Select Message File board so the user can select a saved file to open. 
The contents of the selected file will replace the current contents of the Message Display.

• Save Message File As - Opens the Save Message Files As board so the user can type a name for the 
message file they are saving.

• Save Message File - Saves the contents of the Message Display to the current message file. If the 
current message file is untitled the action will behave like the Save Message File As action.

Create buttons like these 
on your typing boards to 
manage message files.

Action:
Open Message File

Action:
Save Message File As

Action:
New Message File

Action:
Save Message File

The Select Message File board is 
used to open a saved message file.

The Save Message File As board is 
used to type a file name for saving.
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Editing the Message File Boards
The Select Message File and Save Message File As boards are specialized for the task of managing 
message files. These boards are saved in the SDP Message Files folder where all saved message files are 
stored. The boards can be modified, but some care must be taken because these boards require the use of 
specific button actions to function properly.

Important Notes
• To edit one of these boards, it must be opened from within the Design mode.

• These boards must remain in the SDP Message Files folder.

• Navigation buttons, i.e. “go back” or “Main,” are not necessary on these boards. The Save and Cancel 
actions automatically return you to the typing board that calls them.

Action:
Cancel

Action:
OK

Mes-
sage 

Basic letter, 
number, and 
control buttons

Action:
Cancel

These Filename but-
tons are created with 
the menu shown below.

Action:
Next Message Files

Action:
Previous Message Files

Location of the message 
file boards.
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Basic Considerations for Scanning Access

Typing boards are fairly complex due to the number of buttons they require for writing. There are a variety 
of basic steps you can take to improve scanning access.

Scanning Groups

In Chapter 22 - Access Methods and Custom Scanning, you will learn about scanning groups which allow 
you to make a group of buttons scan as a single unit until the group is selected. You can create scanning 
groups around groups of letter or function buttons for more efficient scanning. 

Group Breakout Buttons

By default, when the scan enters a group it will scan through the buttons three times before breaking out of 
the group, if a button is not selected. If a user makes an incorrect group selection, this looping can take 
considerable time. Adding breakout buttons, buttons with no assigned actions, to the beginning of each 
scanning group will allow the user to exit the group without entering an unwanted letter, or waiting for the 
scan to automatically break out. 

Audible Cues for Scanning Groups

Scanning groups can be assigned a Spoken Preview or Recorded Preview action as you would any button 
on the board. Providing audible cues as to the content or function of the buttons in a group may be beneficial 
for some users. 

Each row of letters is a 
separate scanning group.

Create scanning groups 
around function buttons.

Breakout buttons are added to 
escape looping in a group scan 
if a selection error is made.

Spoken Preview “a to i”

Spoken Preview “j to r”

Spoken Preview “s to z”
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Improving Access with the Scan Tools

Typing boards can really benefit from the use of the Sequence Tool and Scan Next Tool. Proper application 
of these two tools can create a more efficient scanning sequence that scans groups in the logical order of use 
and can anticipate the next group or button to scan after a button selection is made. Refer to Chapter 22 - 
Access Methods and Custom Scanning to learn about the Sequence Tool and Scan Next Tool.

Application of the Sequence Tool
Use the Sequence Tool to set the groups containing the letters to scan first, followed by the group of 
prediction buttons, then any groups containing file control or text editing buttons. This is the natural order in 
which the groups will typically be accessed. An example scanning sequence is shown below.

Application of the Scan Next Tool

The Scan Next Tool might be used very effectively on a 
board with word prediction. Typically, Prediction buttons 
are accessed after a letter selection. This can be set 
automatically in the scan by using the Scan Next Tool. 
The scan next location for each letter button would be set 
to the prediction group

Note: The group should be the scan next choice rather 
than the first prediction button. This avoids 
potential scan loop problems if the desired word 
is not yet predicted.

The dashed lines 
represent the 
scanning groups.

6
1

2

3

4

5

Each letter key 
should be set so that 
the prediction group 
will scan next.
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Chapter 22 
Access Methods and Custom Scanning

Chapter Overview 

The application can be accessed through a wide range of access methods such as a mouse, a touchscreen, 
single or multiple switch scanning, etc. The program also provides a variety of special settings and tools 
designed to let you customize the way your boards scan to better meet a user’s needs.

The following topics will be covered:

• Selecting an Access Method

• Keyboard Response

• The Default Scanning Sequence

• Displaying the Scan Tools

• Using the Scan Next Tool

• Button Selection Options

• Configuring Switches

• Creating Scanning Groups

• Using the Sequence Tool

• Using the Scan Pause Tool

A Scan Pause can be 
assigned to stop the scan.

Buttons can 
be grouped 
to scan as a 
single unit. Each button has 

an order in the 
scan sequence 
that can be 
changed.

A Scan Next 
location can 
be assigned 
to create 
predictive 
scanning.
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Selecting an Access Method

Within the application, users can control their communication boards by using almost any alternate method 
of access. You can set the access method by selecting from a menu of choices. Each access method, through 
an options window, can be customized to meet the specific needs of the user. A brief description of the 
available access methods is provided below. For more detailed information on designing boards for alternate 
access users, refer to Chapter 23 - Designing Boards For Alternate Access Methods.

Access Methods
Direct Pointer - Used with direct selectors using a mouse, trackball, joystick, head mouse, or touchscreen.

Direct Touch - Used with touchscreen users and provides touch, release, and dwell time selection options.

Auto Scan - Provides basic scanning access for single switch users. Settings are provided to control the scan 
rate and use of a switch or keyboard key.

Step Scan - Provides scanning access for users who can control their button selections by using one switch 
to advance the scan and a second switch to make a button selection.

Inverse Scan - Provides scanning access that requires the user to hold down the switch to start and maintain 
the scan. Selections are made by releasing the switch.

Arrow Keys - Provides scanning access for a user who can directionally guide the scan using multiple 
switches, keys, or an alternate keyboard.

You can change how 
the user accesses the 
program by selecting 
an access method.

Each access 
method has its 
own window to 
adjust the settings.
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Button Selection Options 

The program provides you with a variety of options that control when a button selection can be made and 
when subsequent button selections should or should not be ignored. These options are accessed by choosing 
Dynamic Boards > Button Selection.

For example, an unsteady switch user might hit a switch two or three times very quickly when he or she 
attempts to make a button selection. If you only want the first switch hit to count, you can adjust one of the 
Button Selection Options so that the program will ignore the additional inadvertent switch hits.

Button Selection Enabled During Speech
Only advanced users with good cognitive and access skills should use this option. The user can continue 
making button selections (or the scan will continue moving) while a previously selected button is 
performing its assigned actions.

New Speech Cancels Old
This option is available only if Button Selection Enabled During Speech is checked. If a button is selected 
while another button is speaking, the previous button message is canceled and the new button message is 
played.

Finish Current Actions Before Allowing Next Selection
This is the default setting. A user who is unsteady or has a tendency to make additional, unwanted button 
selections or switch hits should use this option. The program will ignore all switch hits or button selections 
until the currently selected button finishes its actions.

Tip: If your buttons finish their actions too quickly, enabling the user to make unwanted selections, add a 
Delay action (Cool Stuff category) to the end of each button. This action allows you to specify an 
additional period of time the button will wait before letting the user make another selection. 
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Recognize Mouse Down After

You may specify an amount of time that the mouse button or mouse click-emulating switch must be 
continuously held down before the program will register a button selection. This option helps eliminate 
quick inadvertent button selections.

Note: This option only affects input made by the mouse button or the equivalent. For keyboard or keyboard-
emulating switches, a similar option is available in the Keyboard Response settings covered in the 
next section.

Selection/Movement Debounce

This option allows you to control repeated hits (mouse click, keyboard key, switch, etc.) made by an 
unsteady user. You may specify a “time out” period after an initial hit in which any additional hits will be 
ignored by the program.
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Keyboard Response

You can change how quickly the program will respond to a keyboard keystroke or keyboard-emulating 
switch hit by choosing Dynamic Boards > Keyboard Response. Changing how the program responds to 
brief or repeated keystrokes can help eliminate selections made by a user who is physically unsteady. the 
program makes use of the Windows Accessibility control panel to adjust how the program responds when a 
keyboard key, or the equivalent, is pressed.

Note: The Accessibility support is not always installed by default with Windows. To install Accessibility 
support, refer to Appendix G - Enabling Accessibility Options.

Note: The settings in the Accessibility control panel not only affect the keyboard response within the 
program, but also within Windows and all other software programs.

1

Choose Dynamic Boards > Keyboard 
Response.

2

In the Keyboard Response dialog box click on 
the Accessibility Options button.
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3

Click on the Use FilterKeys box to enable the 
option.

Next, click on the Settings button to configure 
FilterKeys.

4

There are two Filter options:

• Ignore repeated keystrokes - After a keystroke the com-
puter will ignore any subsequent keystrokes unless you 
wait a set amount of time between each keystroke.

• Ignore quick keystrokes and slow down the repeat rate 
- Specify how long a key must be held down before the 
computer accepts the keystroke and if the key is held 
down, specify how fast it will repeat.

Select the appropriate option for your situation. Click on the 
Settings button to change the timing(s) for the selected 
option.

Tip: Make use of the test area to try out your settings.

Continue clicking on the OK buttons when you are finished 
configuring the keyboard response to apply the settings.
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Configuring Switches

Standard desktop and laptop computers are not equipped with jacks that enable you to plug in a switch. A 
switch interface will be required to access the computer via switch input. Typically, a switch interface plugs 
in between the computer and the keyboard, and provides one to five switch jacks. Most switch interfaces are 
keyboard emulators which means that the switches are mimicking keys on your keyboard.

.

1

Plug your switch into one of the jacks on the 
switch interface.

2

Select the appropriate scanning access method.

Auto Scan will be used in this example.

A switch interface 
connects between 
the computer and 
keyboard.

A typical switch interface will 
emulate arrow keys on the 
computer’s keyboard.
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3

Set Activate Button Using to Key Click, then press your switch. The application should read the input 
from the switch and will display the emulated key in the box. Click the OK button when the switch 
input is set correctly.

The application is now set to accept input from your switch.

Use Key click 
with a switch 
interface.

Press the switch 
or type in the 
key the switch is 
emulating here.
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The Default Scanning Sequence

The application will scan the buttons on a board from top to bottom, and for buttons at the same height, from 
left to right. This may not be the ideal scanning sequence for one or all of the activities.

1

You can create any board and choose Dynamic 
Boards > Access Method > Auto Scan to see 
how the default scan works.

The Auto Scan Access dialog will appear. Click 
OK.

2
Place the application in the Use mode and observe the default scanning sequence for this board. The 
linear scanning sequence does not follow the visual organization of the board, or assist the user in 
selecting messages in a logical order. Switch the application to Use mode when finished. 

3

Place the program in the Use mode and observe the default scanning sequence for this board. The 
linear scanning sequence does not follow the visual organization of the board, or assist the user in 
selecting messages in a logical order. Return to the Design mode when finished. 

1 2
3

4

18

19 2021 22 23 24

A linear scanning 
sequence is not 
ideal on this board 
because it ignores 
the organization of 
the buttons.
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Creating Scanning Groups

A collection of buttons can be grouped together so that they will highlight as a single group in the scan. 
When a user selects a scanning group, the scan will then work its way through the buttons that make up the 
group. Scanning groups allow the scan to conform to the visual or logical arrangement of the activities.

1

Select the buttons that you want to become a 
scanning group.

Choose Dynamic Buttons > Scanning 
Group.

The application will create a button that 
surrounds the selected buttons.

Tip: A scanning group is simply a button 
that surrounds other buttons. You can 
use the Button Tool to drag out a 
scanning group like you would a 
button.

2

With the scanning group selected, change the 
background color to transparent and make the 
border thickness none.

NOTE: When the group is deselected, the 
buttons will appear on top of the 
group. Smaller buttons always 
appear on top of larger buttons that 
fully surround them.

Tip: For some users, giving scanning 
groups different colors can help to 
visually organize a board.

3

Switch the application to Use mode and observe the new scanning sequence.

Each scanning group highlights instead of each button. Selecting a group causes the application to scan 
through the buttons in the group. If a button selection is not made within a selected group, the scan will 
break out of the group after three cycles through the buttons.

Return to the Design mode when finished.

Tip: Because a scanning group is a button, you can assign actions to the group. You might use a 
Speak Message action to talk when the group is selected or a Text Preview, Spoken Preview, 
or Recorded Preview action to provide a cue during the scan.

You are going 
to create a 
scanning 
group around 
these buttons.

The scanning 
group will be 
transparent 
except when 
scanning.
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Displaying the Scan Tools

The application provides you with three special scanning tools, the Sequence Tool, the Scan Next Tool, and 
the Scan Pause Tool. These tools allow you to completely customize the scanning sequence on your boards, 
both before and after the user makes a button selection. The Scan Tools are not normally visible in the 
Standard toolbar and must be turned on in order to access them. 

Show the Scan Tools by 
choosing Dynamic Boards 
> Show > Scan Tools.

Sequence 
Tool

Scan Next 
Tool Scan Pause 

Tool
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Using the Sequence Tool

1
The Sequence Tool is used to change the 
scanning order of the buttons on a board.

Select the Sequence Tool in the toolbar.

Click one of the buttons on your board.

2

Numbers will appear in the middle of each 
button or group. This is the default scanning 
order for the buttons and groups on this board.

Note: Clicking on a button that is part of a 
scanning group will display the 
scanning order for only the buttons in 
the group.

3

You will be removing some buttons from the 
scanning sequence and changing the scanning 
order of the buttons to help structure the 
activity.

Click the same button again. Notice that it is 
marked as “1” and all other buttons are 
marked with a “?.”

The “?” indicates a button is not currently part 
of the scanning sequence.

Sequence Tool

The first button in the scanning order 
is assigned. All other buttons are 
waiting to be assigned their order.
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4

Click the buttons in the order you would like them to scan. You want the buttons and groups to scan in 
the logical order the user would select them in.

Tip: If you make a mistake in assigning the scanning order, double-click the Sequence Tool to reset 
the default scanning order.

Note: Buttons that are not assigned a number in the scanning sequence will not scan or be selectable 
even when using a direct selection access method. Unassigned buttons can be accessed 
through Button Key assignments. Please refer to the Button Keys section in the in-program 
help (Help Topics in the Help menu).

1

2 3 4 5 6

7

8 9
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Using the Scan Next Tool

1

The Scan Next Tool is used to specify the 
next button or group that will scan after the 
user selects a particular button. This is called 
predictive scanning.

Select the Scan Next Tool in the toolbar.

2

Move the pointer over one of the Quick Text 
buttons in the “Main dishes” group, then click 
and hold the mouse button down. The button 
you click on and another button will highlight.

The other highlighted button is the next button 
that will scan if the user were to select the 
current button. By default this is the first 
button in the scanning sequence.

3

To change the Scan Next assignment, while 
still holding down the mouse button, drag the 
cursor over to the button or group where you 
want the scan to go next.

If you drag over a button that is part of a 
scanning group, you will see the highlight 
cycle between the button and the group. 
Release the mouse button when the one you 
want is highlighted.

Tip: You can reset the default Scan Next 
assignment for the board by double-
clicking on the Scan Next Tool.

Scan Next Tool

Click and hold a 
button to show the 
next button to scan.

Next button 
to scan.

Click and drag 
to change the 
Scan Next 
assignment.
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Using the Scan Pause Tool

1

The Scan Pause Tool is used to temporarily stop the scan on a button until the 
user hits their switch. There are three different types of Scan Pauses that can 
be applied to a button or group. Each type of pause is used to achieve a 
slightly different scanning goal.

Select the Scan Pause Tool in the toolbar.

2

Click once on any button. All the buttons on the 
board, or in that scanning group, will appear 
highlighted in green. The green highlight 
means no Scan Pauses have been applied.

3

Click repeatedly on the button. The highlight 
changes to red and different letters will appear 
in the upper left corner of the button. Each 
letter represents a different type of Scan Pause.

Continue clicking on the button until an “I” 
appears. This will pause the scan on this first 
button.

Scan Pause Types
"B" The scan will pause on the button when it becomes highlighted. A switch hit will restart the scan 

on that button.

"A" The scan will pause on the button after it is selected. It will remain highlighted as a visual cue to 
the user as to which button they just selected. A switch hit will restart the scan on the next button 
in the scanning sequence.

"I" The scan will pause on the button when it becomes highlighted. A switch hit will select the current 
button and restart the scan. The scan will then continue on to the next button in the scanning 
sequence.

Scan Pause Tool

Green highlight 
means no Scan 
Pauses are 
assigned.

Red highlight

Each letter 
indicates a 
different type of 
Scan Pause.
251



Chapter 22 - Access Methods and Custom Scanning
252



Boardmaker Software Family v6 User’s Guide
Chapter 23 
Designing Boards for Alternate Access 
Methods

Chapter Overview 

A wide range of access methods, features, and options are available to help you accommodate any special 
access needs a user may have. This chapter will help you sort through all the features and options that are 
related to access. Access methods and board design techniques are briefly discussed for each of the major 
categories of alternate access scanning, touchscreen, and/or head-tracking devices.

The following topics will be covered:

• Access Methods for Scanners

• Design Aspects for Scanners

• Design Aspects for Touchscreen Users

• Working with Head-Tracking Device Users

• Button Keys

• Special Scanning Options

• Access Methods for Touchscreen Users

• On-Screen Keyboard

• Design Aspects for Users with Low Vision

• Additional Program Features that Assist User 
Access

Scanning Access Touchscreen Access

Head-Tracking Access Low-Vision Access
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Access Methods for Scanners

There are four access methods in the program that are designed for scanners: Auto Scan, Step Scan, 
Inverse Scan, and Arrow Keys. Each of these access methods can be configured to suit a user’s specific 
needs. You will need to use a switch and/or switch interface with these access methods. Please refer to 
Creating Scanning Groups in Chapter 22 for information on creating scanning groups. 

Auto Scan

This is the most commonly used scanning access method. When enabled, the buttons on the board will 
highlight in a set order, one at a time. To make a selection, the user will hit a switch. The scanning rate, the 
time each button remains highlighted, can be set to meet the needs of the user.

Step Scan

Step scanning allows a user to more directly control button selection by allowing them to advance the scan 
as needed. The user advances the scan by hitting a switch. Button selection can be triggered either 
automatically, by dwelling on a button for a set period of time, or by using a second switch.

Inverse Scan

This scanning access method combines aspects of both the Step Scan and the Auto Scan methods. The scan 
highlight will move only while the user holds down their switch. Button selection can be triggered either auto-
matically, by releasing the switch and dwelling on a button for a set period of time, or by using a second switch.

Arrow Keys
This scanning access method requires the use of the arrow keys on a keyboard or multiple switches. The user 
will control the direction that the scan highlight moves by using a switch or key to move up, down, right, and 
left. Button selection can be triggered either automatically, by dwelling on a button for a set period of time, 
or by using a fifth switch or key for selection. When the user encounters the last button in a row or column, 
the scan highlight will wrap around the screen and continue on the other side. 

Each access method 
has its own window to 
adjust the settings.

You can change how the user 
accesses the program by 
choosing the Access Method.
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Special Scanning Options
There are two advanced scanning features listed at the bottom of the Access Method submenu that provide 
advanced options for customizing scanning access.

Loops 

Special Access Options

Loops - Used to change the default 
scanning loop settings.

Extra Switches - Assigns specific scan 
controls to extra switches.

Sets the number of 
times the scan will loop 
through a group before 
breaking out.

Sets the number of 
times the scan will loop 
before the scan pauses 
on the first button.

Requires a switch 
hit to start the scan 
after each board 
change or button 
selection.
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Extra Switches

Design Aspects for Scanners

There are a variety of techniques and tools to help you organize the content of your boards. The suggestions 
provided below will help you create boards that scan more efficiently.

Layout

Use a consistent approach to the button layout of your boards. A consistent approach will help the user 
locate the desired buttons more quickly.

•Always place navigational buttons in the 
same location on each board.

•Some users may benefit by having the 
same layout and number of buttons 
on each board.

•When you have a board layout that 
works, save a blank copy of the 
board, lock it, and use it as a template 
for all future boards you create. Refer 
to Appendix E - Creating a Template 
Board.

If the user can work with multiple 
switches, specific scanning 
actions or commands can be 
assigned to additional switches. 

Type in the keyboard character 
that the extra switch sends.

Keep your boards 
simple and clear.

Use consistent 
button 
placement.
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Scanning Groups

Use scanning groups to organize the buttons on your board to improve access speed and assist the user in 
understanding the available button choices. The effectiveness of scanning groups will depend on the user’s 
cognitive skills and method of scanning access. Please refer to Chapter 22 - Access Methods and Custom 
Scanning for information on creating scanning groups. 

• If a user has ten or more buttons on their board, scanning groups will probably speed their access.

• Create scanning groups around buttons based on content or function.

• When possible, you should place the most frequently used button choices in the first few scanning 
positions within a group.

• You can use your groups for visual organization by making the groups different colors or resizing them 
to make them visible around the buttons.

• If there are ten or more buttons in a scanning group, consider creating subgroups. (Be careful with 
subgroups. Using too many subgroups may actually slow down a user’s access speed.)

• Depending on the number of times the scan is set to loop through a group before exiting, you may want 
to add an extra button to large groups that allows the user to exit the group without having to wait for 
the scan to automatically exit the group.

Most frequently-
used buttons 
appear in the 
first group.

Buttons are 
grouped based 
on content.

The groups 
can be sized 
and color 
coded.
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Modifying the Scanning Sequence

The Scan Tools allow you to customize the sequence and behavior of the scan on your boards. You can add 
structure to your boards by changing the scanning order and adding predictive scanning. Please refer to 
Chapter 22 - Access Methods and Custom Scanning for more information on the Scan Tools.

• Consider making the navigational buttons the first to be scanned on a board. This allows the user to 
quickly change boards if the current board is not the one desired.

• Use the Sequence Tool to set the scanning order for the groups and buttons on the board to guide the 
user through the natural order in which they should be selected.

• Use the Scan Next Tool to make the scan anticipate what choice the user may need to make after a 
button selection; predictive scanning.

• For visual reinforcement after a button selection, you may want the scan to stop so the button remains 
highlighted. To achieve this, use the Scan Pause Tool to set a type “A” scan pause on each button. 
When the user hits their switch again, the scan will start on the next button in the scanning sequence.

3 4 5

6

7

12

Use the Sequence Tool to make the 
buttons or groups scan in an effective order.

Use the Scan Next Tool to guide the 
user from one selection to another.
258



Boardmaker Software Family v6 User’s Guide
Using Button Keys to Assist a Scanner

The Button Keys feature can be used in conjunction with the Sequence Tool to create buttons that can be 
accessed only by pressing keyboard keys. These buttons would not be visible to or accessible by the user, but 
would be available to someone assisting the user. You can assign actions to cancel speech, clear the display, 
exit a scanning group, print, etc. to these keyboard-activated buttons with the goal of helping the user 
successfully use the communication board. Refer to the Button Keys section in this chapter for more 
information on this feature.

These transparent buttons have Button 
Keys assignments and have been 
removed from the scan sequence.

Sends the 
scan to the 
subjects 
group.

Key: “x”

Removes the 
last picture 
sent to the 
Message 
Display.

Key: “r”

Prints the 
contents of 
the Message 
Display.

Key: “p”

You can assign any keyboard 
key you like to a button.
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Access Methods for Touchscreen Users
When using the program with a touchscreen, you will use either the Direct Touch or Direct Pointer access 
method. Each access method can be configured to support a user’s specific physical needs. 

Direct Touch

This access method supports users who rest or drag their hand on the touchscreen when making a button 
selection. Button selection can be triggered by either the user breaking contact with the screen or 
automatically, by dwelling on a button for a set period of time.

Direct Pointer

This access method supports users who can touch and remove their hand from the touchscreen. Button 
selection can be triggered by either the user making contact with the screen or automatically, by dwelling on 
a button for a set period of time.

Access Method Toggling

If the user is prone to fatigue due to direct selection on a touchscreen, you can provide them with a button to 
change their method of access (perhaps to some type of scanning). The button action Access Method 
(Settings tab) allows you to set and configure an alternate access method for the user. This button may also 
be helpful if the user needs to access a more complicated board, such as an onscreen keyboard, which may 
be difficult for them to access via direct selection.

Starting Pointer Position

Use this feature to set the starting location for the pointer when 
the program starts and after a board change. You will want to 
set the starting pointer position to a location on your boards 
where no buttons are located. This feature corrects the problem 
where a button could automatically highlight or select because 
the pointer happens to appear on top of the button after a board 
change. Choose Dynamic Boards > Access Method > 
Starting Pointer Position.
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Design Aspects for Touchscreen Users

Board Layout

Listed below are some suggestions to keep in mind when creating boards for a touchscreen user.

• Make the buttons large enough so that the user can hit the button and maintain steady contact within 
the button’s border.

• A user with targeting problems may benefit from some degree of spacing between the buttons to act as 
a buffer against inadvertent button selections.

• Arrange the buttons on the boards to accommodate any limitations in a user’s range of motion, e.g., if 
a user has trouble moving his/her hand up and down, arrange the buttons horizontally in a line.

• Make the most frequently used buttons the easiest for the user to reach and access.

Note:  You can record the frequency of button use by choosing Dynamic Boards > Usage Counts and 
setting up the options in the dialog that appears.

• Try not to place small buttons in the corners of your boards. The corners of a touchscreen tend to be the 
least accurate in registering the correct position of a touch.

Large buttons (2” sq.) 
make easy selection 
targets.

Spacing between the 
buttons eliminates 
unintentional selections.

Large navigation buttons 
(1” sq.) are easy to select 
in the corners.
261



Chapter 23 - Designing Boards for Alternate Access Methods
Designing Boards on a Touchscreen

The program has a variety of features that enable you to edit and create boards on touchscreen computers 
that do not have a standard built-in keyboard or mouse.

Onscreen Keyboard

Choosing View > Use OnScreen Keyboard lets you enter text and numbers with an onscreen keyboard 
when you are working in the Design mode.

Design Mode Toggle Button

The menu bar can be difficult to access with a finger. You may want to place a button assigned the Design 
Mode action (Settings category) on at least one of your user’s boards to allow you to switch into the Design 
mode. In the event you don’t have access to a Design mode button, you can triple-tap the very upper left 
corner of the screen in order to enter the Design mode.

Pointer Tool Shift Lock

When the on-screen keyboard is in use, double-tap on the Pointer Tool to activate the shift lock. This feature 
allows you to make multiple selections as if you were holding down the Shift key on the keyboard while 
clicking on various items to be selected. Double-tapping on the Pointer Tool again will turn off the shift 
lock.
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On-Screen Keyboard 

Working with Head-Tracking Device Users

Head-tracking input devices allow users to manipulate the cursor on the computer screen by simply moving 
their head. Head-tracking devices behave like a mouse or trackball except the user is not in physical contact 
with the computer. A timed dwell select access method and a special button action are provided to support 
this type of user access.

Access Method

Since these devices emulate a standard mouse, you will use the Direct Touch access method. Typically, the 
Automatically Activate Button After option (dwell selection) should be used with an appropriate dwell 
time. The problem with using dwell selection is that it is always on, so the user has to make a conscious 
effort to keep the pointer off of any buttons to avoid making unwanted selections. The Rest Toggle button 
action (Settings tab) is provided to address this problem. By selecting a rest toggle button, the user can 
temporarily disable the dwell selection for all buttons on the board except the rest toggle button. This allows 
the user to freely move his/her head until ready to communicate, in which case he/she would dwell on the 
Rest Toggle button again to re-enable the dwell selection. 

The application includes an on-screen keyboard that 
will allow you to type text on computers that have a 
touchscreen, but no keyboard.

Choose View > Use On-screen Keyboard to turn 
this feature on..

Most head tracking device users will use 
a dwell select as their selection option.

Add a button like this to toggle on and off 
the dwell selection.
Action: Rest Toggle (Settings tab)
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Design Aspects for Users with Low Vision

The program provides features which will help support users with low vision. The suggestions in this section 
may be applied to any user’s boards to provide additional selection prompts.

• If you need to use large buttons and are having a difficult time fitting all the necessary buttons on a 
board, move some of the buttons onto PopUp boards to simplify the original board’s appearance.

• Turn on the Enlarge option in the Highlight Buttons dialog. You can open this dialog by choosing 
Dynamic Boards >  Highlight Buttons. You can also specify the magnification level.

• Some users may have an easier time seeing white symbol outlines that appear on a black button 
background. Try using Invert or one of the other highlighting options in the Highlight Buttons dialog.

• Users with severe visual needs should make use of the audible cue features. By using audible cues, a 
user may not even need to see the screen in order to access the program.

The Enlarge 
option will double 
the size of the 
button under the 
pointer.

The Invert option 
will reverse the 
symbol’s colors. 
This is best used 
with black and 
white symbols.
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Button Keys

Through the use of Button Keys, buttons on your boards can be selected by pressing specific keys on the 
keyboard. This feature might be used to provide access through an IntelliKeys keyboard, as a quick method 
for a typer to access frequently used buttons, or to provide an aide access to buttons needed to assist the user.

Any button on a board can be assigned a selection key. The same key should not be assigned to multiple 
buttons. Once a key is assigned to a button, that key will no longer perform its normal function while that 
board is in use, i.e. if the “k” key is assigned to a button, the “k” key can’t be used to type a “k” into a display 
on that board. A Button Key Toggle can be used to turn on and off the Button Keys feature.

1
Assigning a Button Key

Select the button that you want to assign a 
Button Key to.

Assigned 
to “F1”

Assigned 
to “F3”

Assigned 
to “F2”

Assigned 
to “F4”

Assigned 
to “F5”

Assigned 
to “F6”

Using Button Keys 
to access the 
program using an 
IntelliKeys keyboard.

Sends 
an “F1”

Sends 
an “F2”

Sends 
an “F3”

Sends 
an “F4”

Sends 
an “F5”

Sends 
an “F6”

The “F1” key will 
be set to select 
this button.
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2

Select Button Keys in the Dynamic Boards 
menu.

3

Press the F1 key on the keyboard. Click on 
the OK button when finished.

The F1 key is now set to select the 
“breakfast” button regardless of the user’s 
method of access.

4

Turning On and Off Button Keys

A different Button Keys window will appear if no buttons on the board are selected when Button 
Keys is selected in the Dynamic Boards menu. In this case, the Button Keys settings window will 
appear.

Press the desired key.

You can change the 
default Use Button 
Keys Toggle if 
necessary.

Enable or disable 
the Button Keys 
feature.

Enable or disable 
the Use Button 
Keys Toggle key.

Click here to 
remove all Button 
Keys assignments 
on the current 
board.
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Additional Program Features that Assist User Access

Button Selection and Keyboard Response

Users who are unsteady or are prone to making unwanted button selections will benefit from the options 
within within the Button Selection and Keyboard Response dialogs which can be opened from the 
Dynamic Boards menu.. These options allow you to fine-tune when the program will accept or ignore 
switch hits, keystrokes, or other forms of input made by the user to minimize unwanted button selections.

Please refer to the appropriate section in Chapter 22 - Access Methods and Custom Scanning.

Using Audible Cues

All the buttons and groups on a user’s board can be configured to provide an audible cue about their message 
or function. The audible cues can be either spoken (synthesized) or recorded. Audible cueing is extremely 
helpful for users who have visual difficulties or simply need the reinforcement of a spoken cue to assist them 
in making button selections.

Your audible cues should be short so they don’t needlessly delay the user in scanning through the button 
choices.

• If you want to use a set of boards that utilize audible cues with a user who does not need them, you can 
turn off the cues by muting Preview Sounds in the Speaker Volume settings. Refer to Chapter 19 - 
Other Useful Program Featuress.

• You may want to use a different synthesized voice for the spoken cues and for the final spoken 
messages. This will help the user and the communication partner distinguish between the two. Refer to 
Chapter 19 - Other Useful Program Features.

• You can set the volume for the audible cues to be softer than that of the final communication messages. 
The cues can even be set to play through an earpiece or pillow speaker so only the user can hear them. 
Refer to Chapter 19 - Other Useful Program Features.

Audible Feedback

The program provides audible feedback sounds for button activation and button scanning. Audible feedback 
sounds assist the user in tracking the scan and reassuring them that they were successful in selecting a 
button.

• You can change the volume of the audible feedback sounds or mute them entirely if necessary. Refer to 
Chapter 19 - Other Useful Program Features.

• The audible feedback sounds can be changed, if desired. Rename the new wave sound files as SDP 
Button Scan.wav and SDP Button Click.wav, and replace the original sound files in the SDP 
Externals folder. Be sure to keep the sounds very short in duration or they will slow down the button 
selection process.
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Disabling Buttons Using the Sequence Tool

You can use the Sequence Tool to exclude certain buttons from the scan sequence which also makes them 
unselectable to a direct selector. This allows you to tailor an activity by making only a specific topic or 
vocabulary buttons on a board selectable by the user. You can also do this to limit the boards a user has 
access to during class time by removing certain buttons from the scanning sequence on their main board.

Launching Applications

You can launch other applications, documents, or files from the program by linking the program or file to a 
button. You can create a launcher button by using the Launch Application action (Cool Stuff category) and 
selecting the appropriate shortcut.

Note: You must first make a shortcut to the program or file and place it in the SDP Externals folder. Refer 
to Chapter 16 - Other Useful Program Features.

Bookmarks

Users can bookmark a board they may need to return later. Selecting a button assigned the Set Bookmark 
action (Change Board category) places the bookmark on the current board. Selecting a button assigned the 
Return to Bookmark action (Change Board category) opens the bookmarked board. There is only one 
bookmark, so each time you place the bookmark on a new board you will lose the link to the previously 
bookmarked board.

Speaker Volume

This option, found under the Dynamic Boards menu, allows you to change the volume of the Normal 
Sounds (spoken messages or recorded messages), Preview Sounds (audible cues), Button Click Sounds 
(activation), and Button Scan Sounds (movement). There are also controls for configuring how various 
sounds will be played through the computer’s speakers or through headphones or amplified speakers 
plugged into the computer’s speaker jack.

If you want to play audible cues through headphones or a pillow speaker so only the user can hear them, you 
will use this window to specify what sounds will be heard where. The Separation of Sounds option you 
choose will depend on the type of computer you are using. Refer to Chapter 16 - Other Useful Program 
Features.

Setting Up SDP for Multiple Users on the Same Computer

If you are using SDP on a single computer to support multiple users, you will typically have a separate folder 
of boards for each user. In each user’s folder of boards you can create a custom preference file, message files 
folder, or dictionaries folder to preserve that user’s individual program settings. Starting the program by 
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double-clicking on one of the user’s boards, or a shortcut to a board, will make the program use the 
preference or dictionaries files that located in that user’s folder.

To create a custom SDP preference file for a user:

Make a copy of the PrefsSDP file which is typically located in your My Documents folder. (If you can not 
find the file there, locate the My Boards folder used by SDP and the PrefsSDP will be saved in the same 
location.) This file contains all of the user’s specific program settings. Paste the copy of the PrefsSDP file 
into your user’s folders of boards.

To create a custom SDP Message Files folder for a user:

Make a copy of the SDP Message Files folder which is typically located in the Program Files/Boardmaker 
with SD Pro folder. Any documents saved by the user will be saved into this folder. Paste the copy of the 
SDP Message Files folder into your user’s folders of boards.

Note: You must start SDP by double-clicking on one of the boards in the user’s folder to make the program 
use the PrefsSDP file, or SDP Message Files folder contained in that folder. Once the program is 
running, any setting or dictionary changes you make in SDP will be save to the files in that user’s 
folder.
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Appendix A 
Keyboard Shortcuts

Most of the keyboard shortcuts and key modifiers listed below are also listed in the application’s various 
menus next to their respective commands.

.

Draw Window With Text Selected
Ctrl + D Enter the Design Mode Ctrl + “+” Increase the font size
or ESC Ctrl + “-” Decrease the font size
Ctrl + U Enter the Use Mode Tab Select all Text
Ctrl + N New board
Ctrl + O Open a board With Symbolate Text Selected
Ctrl + S Save a board Ctrl + “+” Increase the symbol size
Ctrl + P Print a board Ctrl + “-” Decrease the symbol size
Ctrl + Q Quits the application
Ctrl + Z Undo (negates the results of Symbol Finder

your last action) Ctrl + T Display thumbnail view
Ctrl + A Select all Ctrl + L Select categories
Ctrl + X Cut the selection → Next image in search
Ctrl + C Copy the selection ← Previous image in search
Ctrl + V Paste from the clipboard Ctrl + H Change Line 1 to “Hidden”
Ctrl + G Create a scanning group 

around the selected buttons
Ctrl + 1 Change Line 1 to “English”

Ctrl + R Show rulers Ctrl + (2 - 9) Change Line 1 to 
corresponding language

Backspace or 
Delete

Delete the selection Ctrl +  Shift + C Copy current symbol as a 
bitmap instead of a metafile

Ctrl + 1 Actual size window view Ctrl + Shift+F11 Show MJ Special dialog
Ctrl + 2 Half size window view Ctrl + Shift+F12 Show MJ Special (extended) 

dialog
Ctrl + 3 Reduce to fit view
Ctrl + 4 Double size window view Pasting Images
Ctrl + B Open Symbol Finder Ctrl + paste Size for a 2” x 2” button
Ctrl + F1 Select Pointer Tool Shift + paste Use native resolution
Ctrl + F2 Select Button Sprayer Tool Alt + paste Suppress the label
Ctrl + F3 Select Button Tool
Ctrl + F4 Select Line Tool Shuffle Buttons
Ctrl + F5 Select Text Tool Ctrl + Shuffle Make sure every button 
Ctrl + F7 Select Freeform Tool changes place
Ctrl + → Open next board in folder
Ctrl + ← Open previous board in folder Swap Buttons
Ctrl + F6 View the next open board Alt + drag Swap buttons
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Resizing Buttons Freeform Button Tool
Ctrl + resize Resize contents Ctrl + click Set a vertex for a polygon
Shift + resize Maintain the aspect ratio Shift + select Make the polygon regular
Ctrl + AltOpt Resize contents (excluding polygon in 
+ resize text) Corner Tool

Symbolate Selection with Pointer Tool
Esc Open Symbolate Candidates Shift + click Select the button

dialog (no items selected)
“_” Insert a space without Shift + click Select/deselect additional 

creating a new word-symbol (items selected)  item/button
pair Shift + click Select all stacked items

Alt + typing Don’t resymbolate the text (stacked item 
Alt + “_” Insert an underscore instead selected)

of a pseudo-space Ctrl + drag Select and move button in 
one step
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Appendix B 
Button Actions

Button actions are listed by action category.

Basics
Speak Message
Type Message
Play Recorded Message
Change Board
Change Board Back
Text Preview
Spoken Preview
Recorded Preview
Clear Message Display
Picture Button

Message
Type Message
Say Message
Say Selection
Delete
Remove Last Message
Clear Message Display
Select All
Cut
Copy
Paste
Print Message
Capitalize Next
Caps On
Caps Off
Picture Button
Picture Speech
Picture Sound
Expand Abbreviation

Message Files
New Message File
Open Message File
Save Message File
Save Message File As
Delete Message File
OK
Cancel
Next Message File
Previous Message File
Message File Name
Speak File

Board Change
Change Board
Change Board Forward
Change Board Back
Return to Last Board
Set Bookmark
Return To Bookmark
Go To PopUp Board

Text & Cursor
Move Up
Move Down
Scroll Up
Scroll Down
Move Left Char
Move Left Word
Move Left Sentence
Move Left Return
Move Begin
Move Right Char
Move Right Word
Move Right Sentence
Move Right Return
Move End
Select Left Char
Select Left Word
Select Left Sentence
Select Left Return
Select Left Begin
Select Right Char
Select Right Word
Select Right Sentence
Select Right Return
Select Right End
Retract Left Char
Retract Left Word
Retract Left Sentence
Retract Left Return
Retract Right Char
Retract Right Word
Retract Right Sentence
Retract Right Return

Settings
Normal Volume Up
Normal Volume Down
Preview Volume Up
Preview Volume Down
Use Loud Settings
Use Soft Settings
Access Method
Design Mode
Rest Toggle
Word Prediction Toggle
“Typing Shortcut Setting
Reset Stopwatch
Use Voice 1
Use Voice 2
Use Voice 3
Use Voice 4
Quit
Shutdown

Variables
Speak Message
Type Message
Play Recorded Message
Assign Variable
Assign Variable From 
Display
Adjust Variable
Speak Variable
Type Variable
If
Else if
Otherwise
End if
Variable To Quick Text
Comment

Quick Actions
Quick Text
Quick Speak
Display To Quick Text
Quick Text To Display
Variable To Quick Text
Quick Picture
Copy To Quick Picture
Quick Record
Set Quick Record
Quick Day
Quick Date
Quick Time
Speak Day/Date/Time/ 
Prediction
Type Day/Date/Time

Cool Stuff
Launch Application
Play Movie
Random
End Random
Pause Speech
Cancel Speech
Set Button Picture
Set Button Label
Set Button Properties
Delay
Activate Macro
Speak File
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Appendix C 
Exporting and Importing Board Packages

You may want to transfer a collection of Boardmaker boards to someone from one computer to another. In 
previous versions, there was no easy and efficient way to share your boards with others.

Now individual boards or an entire folder of boards can be “packaged” into a single compressed file that can 
be transferred easily. Once transferred, a package must be imported before the boards are ready for use.

1

Exporting a Board Package

Choose File > Export. Then choose either 
Individual Boards to a Package or Folder of 
Boards to a Package from the submenu.

2

Select a board, multiple individual boards or a folder of boards to be packaged as appropriate for the 
export option you selected. 

Click the Open or Choose button when finished.

Tip: Multiple boards can be selected by holding down the Control (Ctrl) key on your keyboard 
while clicking on the individual boards.

Note: Any multimedia files (i.e., sounds, videos) associated with the selected boards will 
automatically be included in the board package.

Selecting individual 
boards to package.

Select a 
folder to 
package.
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3

Select a location and enter a name for the 
packaged board. By default, the application 
will attempt to save board packages in your 
My Boards folder.

Click the Save button.

The board package can now be emailed, 
transferred to a memory stick, transferred over 
a network, archived as a backup, etc. 

4

Importing a Board Package

A compressed board package must be 
imported before the boards it contains can be 
used.

Choose File > Import > Board Package.

Note: Board packages can only be imported 
by version 6 and later of the 
application.

5

Select the package file then click the Open 
button.

Note: Board Packages have a .zbp file 
extension.

Select a location 
and name for the 
board package.

Board Packages 
will have a .zbp 
file extension.
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6

Select the location where the imported boards 
will be saved. The default location will be the 
My Boards folder, but another location can 
easily be selected.

Click the the Choose button. The board 
package will be expanded here.

Choose File > Open to open one of the 
imported boards.

Note: If you attempt to import a board or a 
folder that has the same name as a 
board or a folder which already exists 
in the selected location, you will be 
asked if you want to overwrite that 
board or folder.
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Appendix D 
Exporting Boards to Version 5.3

Due to the addition of exciting new features in version 6, the file format of the saved boards has changed. 
Although this makes version 6 boards incompatible with version 5 of the application, there is a way to share 
boards created in version 6 with version 5.3 users. If you want to open a board or boards created in version 6 
in version 5.3, you will first have to “export” them using the appropriate Export option in the File menu.

Note: Version 6 of the application can directly open version 5 boards without needing to use the export/
import options. Whenever possible, version 6 will attempt to save boards in the version 5.3 format to 
maintain backward compatibility.

1

Boardmaker lets you export a single board or a 
folder of boards.

To export the currently open board, choose File > 
Export > Current Board to a Version 5.3 Board.

Note: If you have not yet saved the board, you 
will be prompted to give your board a name 
and select a place to save it.

To export a folder of boards, choose File > Export > 
Folder of Board to a Version 5.3 Folder. This will 
create a folder with the same name as the target 
folder with "5.3" appended to it.

Note: The new folder will be placed in the same 
folder as the target folder.
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Boardmaker version 6 features not supported in version 5.3:

Boardmaker Plus! and SDP version 6 features not supported in version 5.3:

Version 6 button actions not supported in version 5.3:

2

The exported board or folder of boards can then be transferred to a computer with version 5.3 
Boardmaker on it, and the board or folder of boards can be opened directly.

Caution: If the exported boards contain features that are not supported in version 5, the export 
function will warn you about the incompatibilities. If you choose to proceed with the 
export process, the incompatible features will either be stripped out or replaced with 
reasonable alternatives.

• Dashed lines

• Symbolate buttons

• Freeform buttons (replaced with rectangles)

• Background image anchors

• Movable buttons

• Open board actions

• Macros

• Advanced variables (embedded, numeric, system)

• Advanced conditional statements

• Nested, not selectable, hidden buttons, and button names

• Change Board Back

• Change Board Forward

• Quick Record

• Set Button Label

• Set Button Properties

• Reset Stopwatch

• Quick Type

• Quick Picture

• Adjust Variable

• Set Button Picture

• Read with Highlighting

• Activate a Macro

The 
freeform 
button is 
converted 
into a 
standard 
square 
button.

The symbolate button 
is converted to a 
standard button with 
multiple symbols. 

Basic Boardmaker 
board before export.

Board after export 
with alterations.

The dashed button border 
is converted into a 
standard solid border.
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Appendix E 
Creating a Template Board

Template boards are set up to prevent users from saving over them. You can turn any board you create into a 
protected template board.

1

All template boards are stored in the Templates 
folder. They can be found in the Boardmaker with 
SD Pro folder (typically in C:\Program Files).

You can create your own subfolders in the 
Templates folder to help organize your templates.

2

Once you create a board that you want to keep as a 
template, choose File > Save as Template.

3

Enter a name for your new template and save it in 
the Template folder of an appropriate subfolder.

Click the Save button. Your template will now be 
automatically saved and designated as ”read only”.

When your template board is opened, it will appear 
as an untitled board. This forces the user to give the 
template board a new name every time it is used, 
preserving the original. 

Program Files

Boardmaker with SD Pro

Templates

Give your template board a name 

The Save as Template 
function automatically 
directs your template 
boards here.
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Appendix F 
Launching a Board at Computer Startup

Your computer, at startup, can be set to automatically launch a specific the program board. This is especially 
useful on a computer that is dedicated to providing communication for a set user.

1

Open the board you want the program to open on 
startup. Choose Dynamic Boards > Startup Board.

2

Click the Use Current Board button; then click the 
OK button. Now when you launch the program, it 
will automatically open the specified board in the Use 
mode.

NOTE:You can change or remove the startup board 
any time using the steps above.
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3

On the desktop, right-click the the program shortcut and hold the mouse button down. Drag the 
shortcut to Start > Programs > Startup then position the shortcut in the Startup submenu, then 
release the right mouse button. In the contextual menu that appears, select Copy Here.

4 Your computer is now set to automatically launch the the program board you set with the program in 
the Use mode.
284



Boardmaker Software Family v6 User’s Guide

285

Appendix G 
Advanced Board Construction Tips

The following tips are provided to help experienced the program users save time when constructing boards. 

Spraying Already Programmed Buttons

If you need to create several buttons that all perform the same set of actions but differ only in their content, it 
can be faster to create one button and assign it the necessary actions first, then use the Button Sprayer Tool 
to create a grid of copies. Now, all you need to do is edit the content of each button since the necessary 
actions are already assigned to each copied button. Refer to Working with Quick Text Buttons in Chapter 18 
to see the basic steps of this approach to board building.

Modifying an Existing Board and Saving it with a New Name

If you like the way a particular board looks or functions, you can make a copy of the board and customize its 
content to meet your specific needs. To quickly make a copy of a board, use the Save As command in the 
File menu to save a copy of the board under a new name. You can then freely change the content of this 
newly-named copy without affecting the original board.

Copying and Pasting Buttons Between Boards

The program will allow you to open and view numerous boards simultaneously. This makes it very easy for 
you to copy and paste already-programmed buttons from one board to another.

Tip: If you want to use an existing set of boards with a new individual, but need to reduce the number of 
topic choices on the main board, you can cut the unwanted buttons from the board and paste them 
onto a new board for storage. The topic buttons on the storage board can then be added back to the 
main board as the user is able to handle more vocabulary.

Right-click Feature 

Right-clicking over a button, a symbol, text, the Message Display, the Preview Display, or the background 
will provide an additional menu for editing the selected item.

Using the Placement Cursor  

Use the Placement Cursor to click and drag out a marquee box that is the desired size and in the correct 
position. The pasted symbol will be scaled to fill that marquee box.

Note: This feature is best used when you are not working wih only the symbol and not the symbol text and 
symbol. Use the Tab key and delete the text in the Alternate Symbol Names field or set the Line 1 
Language to Hidden.
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Appendix H 
Application Language

The menus, messages, dialogs, and supporting files and folders in the program can be displayed in a variety 
of languages. The program retrieves all its text from special language resource files. You can set the program 
to use any currently available language resource file to translate the program’s text.

1

NOTE: If you are using Windows NT, 2000, XP, or Vista you must have administrator privileges to 
change the application language. Consult your network administrator.

From the File menu select Application Language. The dialog box shown below will appear.

Click on the pop-down menu to view the list of languages currently available. Highlight the language 
that you want to use.

NOTE:Additional language resource files may be available in the future. Contact Mayer-Johnson, Inc. 
for information on available languages.

2

Click on the Accept Language Change button. The program is now set to start up using the language 
you selected.

Quit and restart the program to apply the language change.

NOTE:Because changing the application language also renames some of the supporting files and 
folders, it is strongly recommended that you quit and restart the program immediately.

Click here to view the 
list of available lan-
guages. Highlight 
your selection.

Click here to set the 
program to start up 
on the new language.
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Index
A

Abbreviation expansion 223, 231
Access methods 237

alternate 253
Arrow Keys 238, 254
Auto Scan 238, 254
Button Selection Options 239
Direct Pointer 238, 260
Direct Touch 238, 260, 263
Extra Switches 256
Inverse Scan 238, 254
Keyboard Response 241
Loops 255
scanning 254
Starting Pointer Position 260
Step Scan 238, 254
toggle 260
touchscreen users 260

Accessibility Options 241
Action categories 137, 273

Basics 137, 273
Board Change 137, 273
Cool Stuff 137, 273
Message 137, 273
Message Files 137, 273
Settings 137, 273
Text & Cursor 137, 273
Variables 137, 273

Action Details 136
Action list 215
Action Menu 137
Actions

Movable-Destination button 
pair 179

AdaptedLearning 8
Addendum libraries 107
Aligning text 61
Alternate access methods 253
Alternate Symbol Name field 42
Alternate symbol names 42

adding or editing 43
Alternative Symbol Name field 4
Arrow Keys 238, 254
Assign Categories button 49, 51
Assigned actions 136

adding 149

deleting 150
editing 149
rearranging 150

Assigning categories to a symbol 49
Audible cueing 171, 208, 210, 235, 
267
Auto Scan 238, 254

B
Background color

board 28
button 28

Basic button actions 137, 273
Bitmap format 93, 104, 124
Board change action category 137, 273
Board Change Indicator 90, 158
Board dimensions 18
Board Magnification Indicator 3
Board size 20, 122
Board title bar 214
Board Workspace 3
Boardmaker’s Symbol Finder at a 
Glance 4
Boards

action list 215
advanced construction tips 285
assigning basic actions 135
background color 28
creating a template 281
default storage 133
design considerations 130
dimensions 122
filling with symbols 48
gap spacing 26
layout diagrams 131
main 132
modifying 285
multi-page 21
multiple, working with 23
opening 6, 271
organizing 132
orientation 19, 120
page break lines 22
paper size 118
planning content of 131
PopUp 187
sample 5, 8

separate folders for 132
setting default size 20, 118
setting the size 20, 118
storage 132, 285
template 281
typing 224
viewing multiple (Tile) 23

Bookmarks 268
Borders

3-D shadow 31
hidden 29
thickness 28

Button actions
basic 137
complete listing 273
variables 218

Button Actions dialog 136
Button actions window 136
Button gap spacing 26
Button Keys 228, 259, 265
Button Keys toggle 228
Button numbers 215
Button Selection Options 239
Button Sprayer Tool 3, 26
Button Tool 3
Button types

changing 184
Buttons

assign actions 136
basic actions 138
Button Keys 265
changing types 184
copying and pasting between 

boards 285
cursor control 232
design aspects 263
disabling 268
display control 224
edit assigned actions 149
highlight options 264
layout 256, 261
link to other boards 151
message file control 233
movable 175
Movable Button Tool 176
Movable-Destination pair 179
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Index
numbers 215
picture 165, 166
Quick 191
quick action 191
Quick Date 202
Quick Day 202
Quick Picture 196
Quick Record 199
Quick Text 192, 195
Quick Time 202
scanning group 246, 271
scanning group breakout 235
scanning movable 185
selecting multiple 188
setting movable button 

destination 183
text editing 232
Usage Counts 216
Use Button Text option 169
Word Prediction 225

Buttons (cells)
3-D shadows 31
adding additional symbol to 65
background color 28
border color 28
border thickness 28
clearing a group of 32
clearing symbols and text from 32
combining symbols in 65
copy new symbol from 104
creating 25
creating a grid of 25
creating a square 25
dimensions 20
filling quickly 48
gap spacing 20
importing clip art and photos 101
placing a symbol on 40
replacing a symbol on 64
resizing 26, 86, 87
select all 27
shape 30

C
Categories

adding a new symbol 106
Categories Button 4
changing a symbol’s 49
creating your own 51
selecting a search 46

Cells. See Buttons
Change Board 138, 153, 273
Changing text on multiple buttons 61
Clear 32
Clear Symbols. See also categories

clearing 68
Clip art

importing 101
Clipboard button 4
Clone

Movable button 182
Color

board background 28
border color 29
button background 28
changing colors in symbols 98
transparency 94, 96

Color palette 28, 59, 96
Color Tool 3, 28, 29, 59, 96
Cool Stuff action category 273
Copying symbols

automatic placement 40
manual placement 40
to a button 40
to another program 41
to the Symbol Finder 104

Corner Tool 3
Create Popup Board 188
Creating symbol categories 51
Cursor control buttons 232

D
Default

board size 20, 122
for Text Tool 60
print settings 20, 122

Default board storage location 132
Design aspects for scanners 256
Design aspects for touchscreen 
users 261
Design Board menu

Abbreviations 231
Access Method 238
Button Keys 266
Design mode 7
Greeting 213
Highlight Buttons 264
Show Board Change Indicators 158
Show Board Titles in Use Mode 214
Show Button Numbers 215

Show Menu Bar in Use Mode 214
Show Scan Tools 247
Speaker Volume 208
Typing Shortcuts 232
Usage Counts 216
Use mode 5, 140
Voice 209
Word Prediction 227

Design considerations 130
Design mode 5, 140
Design Mode toggle button 262
Destination buttons

changing type 184
creating 177
editing actions 179
scanning limitations 186
setting 183

Direct Pointer 238, 260
Direct Touch 238, 260, 263
Display control buttons 224
Draw Window at a Glance 3
Drawing on symbols 95

limited drawing area 93
Dynamic Buttons menu

Create PopUp Board 188, 189
Filename 234
Message Display 160
Picture 166
Prediction 226
Preview Display 147

Dynamic Help 3

E
Edit

button’s assigned actions 149
Message File boars 234
word prediction dictionary 229

Edit menu
Clear 32, 68
Copy 104
Paste 104
Select All 27

Editing a symbol name 59
Enlarging the Symbol Finder 
window 54
Eraser Tool 92, 96

change thickness of 96
Extra Switches 256
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F
File menu

Import 103
Print Board on Single Page 125
Print Preview 122, 123
Print Setup 18, 21, 121

Fill All Tool 92, 94, 98
Fill Tool 92, 94, 97
Flip Horizontal Tool 92, 99
Flip Vertical Tool 92, 99
Fonts

setting size in Symbol Finder 44
setting size on symbol 60, 86
style 60
type 60

G
Gap spacing 26
Getting Started 129
Greeting 213
Grid

Snap to Grid 25
spacing 25

H
Head tracking device users 263

design aspects 263
Help 3
Highlight Buttons 264

enlarge 264
invert 264

I
Imported picture transparency 94
Importing

clip art 101, 103
photos 101
pictures 101

Inverse Scan 238, 254
Invert Tool 92, 98

K
Keyboard

on-screen (Design mode) 262
on-screen (user). See typing boards

Keyboard (on-screen) 263
Keyboard Response 241

L
Languages

assigning symbol names 105
Lines 1 and 2 in symbols 45
Search Language 45

Launching a board at startup 283
Launching applications 204, 268
Libraries (of symbols) 107

organization 107
selecting b&w or color 55

Line Tool 3, 30
Lines 1 and 2 Languages 45
Lines 1 and 2 Sizes 44
Linking boards 151

building sequence 152
main board button link 153
previous board button link 155
topic branch 152

Loops 255

M
Magnification for Enlarged Window 54
Main board ??–7, 129, 131, 132, 151, 
153, 156
Mapping out the boards and links 131
Marquee/Lasso button 67
Maximize size of window 24, 54
Menu Bar 3
Menu bar (display options) 214
Message action category 137, 273
Message Display 159

actions 163
adding 160
adding simple controls 162
changing the text and display 

colors 160
changing the text size 160
clearing 195
Remove Last Message 162
settings 164
Type Message 161
Use Button Text 169
with pictures 165

Message Display settings 164
picture size 167
Uniform Line Spacing 168

Message File boards 233–234
Message File control buttons 233
Message Files action category 137, 
233, 273

Modify
existing board 285
scanning sequence 258

Modifying symbols
changing symbol colors 97
combining 67
drawing on 95
limited drawing area 93
resizing 86

Movable Button Tool 176
Movable buttons

changing type 184
cloning 182
creating 177
editing actions 179
overview 175
properties 181
scanning 185
scanning limitations 186
setting a destination 183
snap back 181

Movable-Destination button pair 179
Multiple boards 23
Multiple user settings 268
My Boards folder 6, 132

N
Names (symbol)

alternate 42
editing 43

Naming a new symbol 105

O
One-time symbol name change 42
On-Screen Keyboard 263
Onscreen keyboard (design mode

in Design mode 262
Onscreen keyboard (design mode)

in Use mode. See Typing boards
Open

board 271
new board 271
next board 271
previous board 271
saved board 6
Symbol Finder 271

Orientation of paper and boards 18

P
Page break lines 22
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Paint toolbar 95
Paint Tools

Color 92, 96
Eraser 92, 96
Fill 92, 97
Fill All 92, 98
Flip Horizontal 92, 99
Flip Vertical 92, 99
Invert 92, 98
Pencil 92, 95
Pointer 92, 95
Rotate 92, 99
Thickness 92, 97

Paint tools 91
Paint Tools Palette 92
Paper orientation 21, 121
Paper size 21, 120
Password 213
Pencil Tool 94, 95

setting the color of 95
setting the line thickness of 95

Photos
importing 101

Picture Button 138, 166
Picture Sound 138
Picture Speech 138, 166

suppress 167
Placement Communication 
Symbols 107
Placement Cursor 40, 64, 65, 67
Placing a symbol in a button 40
Play

movie 207
recorded message 138, 142

Play Movie 207
Play Recorded Message 138, 140, 
142, 273
Pointer Tool 3
PopUp boards 187

creating 188
using with a Message Display 190

Prediction activation keys 228
Prediction buttons 223, 226, 231

accessing 228
adding 226

Preference file 269
Preview Display 147
Previous/Next Arrows 4, 38, 39, 47
Print Board on Single Page 125
Print Preview 122, 123

Print quality 124
Print Setup 18, 21, 121
Printer considerations 118
Printer Setup 18, 121
Printing 212

checking the print layout 118
default settings 20
on single page 212
preparing boards for 118
Print Preview 123
Print Review 122
Print Setup 121
setting the board size 18
setting the orientation 18
setting the printer paper size 19

Private audible cue 210
Program menu bar 214
Pronunciation 211
Properties

movable button 181

Q
Quick action buttons

overview 191
Quick buttons

Quick Date 202
Quick Day 202
Quick Picture 196
Quick Record 199
Quick Text 192, 195
Quick Time 202
types of 191

Quick Date buttons 202
Quick Day buttons 202
Quick Picture buttons 196
Quick Record buttons 199
Quick Text buttons 192, 195
Quick Time buttons 202

R
Random action 206
RealSpeak 209
Recorded message 142
Recorded Preview 138, 145, 210, 
235, 273
Reduce To Fit view 22, 118
Replace button 64
Replacing a symbol on a button 64
Repositioning

symbols 66

text fields 58
Resizing

a board’s window 24
buttons 26, 86
graphics 86
symbols 86
text 44, 60, 86

Restoring window size 24, 54
Return to Last Board 152, 273
Rotate Tool 92, 99
Ruler 25

units of measure 25

S
Sample boards

explore 5, 8
Saving a board’s action list 215
Scan

movable button limitations 186
Scan Next Tool 250
Scan Pause Tool 251
Scan tools 236

Scan Next Tool 236, 247, 250
Scan Pause Tool 247, 251
Sequence Tool 236, 248, 249

Scanning 235, 254
access methods 238
advanced 255
audible cues for groups 235
Button Keys 259
button layout 257
Button Selection Options 239
default sequence 245
design aspects 256
Extra Switches 256
feedback sounds 208
group breakout buttons 235
groups 235, 257
Keyboard Response 241
Loops 255
modifying the sequence 258
movable buttons 185

Scanning groups 246
Scroll Bars 3
SDP Externals folder 204
SDP Messages Files folder 234
Search Language 45
Search options 38

anywhere 38
beginning of word 38
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whole word 38
Searching for symbols

individually 38
using categories 39
using thumbnails 39

see On-Screen Keyboard 263
Select All 27
Select Categories button 46
Selecting

b&w or color libraries 54, 55
portion of a symbol 67
search category 46

Send To Back 66
Sequence Tool 248
Setting

board size 18, 120
font, style, and size 60
paper size 19, 120
Symbol Finder font size 44

Shadow 31
Shadow Tool 3
Shortcut 204
Snap To Grid 25
Sound

separation 208
volume 208

Speak
button 139

Speak Message 138, 139, 140, 173, 
273
Speaker Volume 208
Speaker Volumes 210
Spoken Preview 138, 144, 173, 235, 
273
Standard Tool Palette

Line Tool 30
Standard toolbar 25

Button Sprayer Tool 26
Button Tool 25
Pointer Tool 59
Shadow Tool 31
Text Tool 59

Starting Pointer Position 260
Starting pointer position 260
Starting the program 6

in the Use mode 6
Step Scan 238, 254
Switches 243
Symbol Finder

adding a symbol to 41, 101

alternate name field 42
at a glance 4
category search 46
deleting a symbol 106
enlarging the window 54
importing a picture to 101
language settings 45
line 1 and 2 font sizes 44
line 1 and 2 languages 45
Previous/Next Arrows 38
Search Language 45
search options 38
selecting b&w or color symbols 54, 

55
Selection Marquee/Lasso 4
setting the font size 44
Settings Button 4
thumbnail view 47
window 3

Symbol Finder Tool 54
Symbol Name Search option 38

anywhere 38
beginning of word 38
whole word 38

Symbol Names button 4, 43
Symbol transparency 94
Symbols. See also categories

adding to a button 65
alternate names 42
assigning categories 49, 106
changing colors in 98
clearing a group of 32
color changes 98
combining 65
conversion to bitmap format 93, 

104, 124
copying new to Symbol Finder 104
creating new 65, 104
deleting parts of 67
drawing on 95
editing name 59
erasing a portion of 96
filling selected portions of 97
flipping 99
inverting black & white 98
metafiles 93
MJ Symbols - Additional 

libraries 107
MJ Symbols library 107
modifying 91

My Symbols folder 107
naming new 105
placement in button 40
replacing color 97
replacing on a button 64
repositioning in button 66
resizing 66, 86
rotating 99
selecting 95
selecting a portion of 67
selecting multiple 104
Symbol Folder 107
transparency color 94

Synonyms for symbol names 42

T
Technical support 2
Template boards 281

creating 281
premade 281
Use Button Text 170

Text
adding or editing alternate names 43
adding to symbol 59
alignment 61
alternate symbol names 42
changing on multiple buttons 61
changing the color 59
editing a symbol name 59
font size 44, 60, 86
font style 60
one-time symbol name change 42
removing name from alternate 

list 43
repositioning 86, 95

Text & Cursor action category 137, 
273
Text editing control buttons 232
Text Preview 108, 111, 112, 113, 
115, 138, 147, 148, 173, 273
Text Tool 3, 57

adding text with 58
editing symbol name with 59

Thickness 95
Thickness Tool 3, 28, 92, 95, 96
Thumbnails 47

Thumbnails Button 4
using to search for symbols 39

Tile view 23
Title Bar 3
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Title bar (display options) 214
Title Bars 214
Tools

Button 25
Button Tool 26
Color Tool 28, 29, 59, 92, 95
Corner Tool 30
Eraser 92
Fill 92, 94, 96, 97
Fill All 92, 94, 96, 98
Flip Horizontal 92, 99
Flip Veritcal 99
Invert 92, 98
Line 30
Pencil 92, 94
Pointer 92, 95
Rotate 92, 99
Symbol Finder 104
Thickness 28, 92

Topic board 188
Touchscreen users 260
Transparency Color 94
Type Message 138, 159, 161, 163, 
173, 273
Typing boards 224
Typing Shortcut Toggle 232
Typing shortcuts 232

U
Usage Counts 216
Use All Standard Categories button 46
Use Button Text 169

actions that can Use Button 
Text 173

creating template board with 170
Use mode 5, 140
Use Prediction Keys button 228
User categories 51

V
Variables 217

actions listing 273
View menu

Reduce To Fit 22
Send To Back 66
Snap To Grid 25
Tile 23

Visually impaired users. See Low vision 
users
Voices 209

pronunciation 211
selecting and changing 209
switching from a button 209
volume 208

Volume 208

W
Window

maximizing 24
resizing 24
viewing multiple 23

Windows taskbar 41
Word Prediction 225

adding 226
change the settings 227
learn new words 227, 229
update usage count 227

Word Prediction dictionary 229
editing using a word processor 230
editing using SDP 229
using different 230

Word Prediction keys 228
Word pronunciation 211
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